Fix fuse in devel, close bz 265321

This commit is contained in:
Tom Callaway 2007-08-29 21:24:37 +00:00
parent f4fe6de2d5
commit df8622d30a
2 changed files with 41 additions and 1 deletions

35
fuse-2.7.0-openfix.patch Normal file
View File

@ -0,0 +1,35 @@
diff -up fuse-2.7.0/lib/fuse.c.patch1 fuse-2.7.0/lib/fuse.c
--- fuse-2.7.0/lib/fuse.c.patch1 2007-07-02 07:33:08.000000000 -0400
+++ fuse-2.7.0/lib/fuse.c 2007-08-29 17:16:54.000000000 -0400
@@ -628,16 +628,15 @@ static int fuse_compat_open(struct fuse_
{
int err;
if (!fs->compat || fs->compat >= 25)
- err = fs->op.open(path, fi);
+ err = (fs->op.open)(path, fi);
else if (fs->compat == 22) {
struct fuse_file_info_compat tmp;
memcpy(&tmp, fi, sizeof(tmp));
- err = ((struct fuse_operations_compat22 *) &fs->op)->open(path, &tmp);
+ err = (((struct fuse_operations_compat22 *) &fs->op)->open)(path, &tmp);
memcpy(fi, &tmp, sizeof(tmp));
fi->fh = tmp.fh;
} else
- err = ((struct fuse_operations_compat2 *) &fs->op)
- ->open(path, fi->flags);
+ err = (((struct fuse_operations_compat2 *) &fs->op)->open)(path, fi->flags);
return err;
}
diff -up fuse-2.7.0/lib/fuse_lowlevel.c.patch1 fuse-2.7.0/lib/fuse_lowlevel.c
--- fuse-2.7.0/lib/fuse_lowlevel.c.patch1 2007-08-29 17:17:13.000000000 -0400
+++ fuse-2.7.0/lib/fuse_lowlevel.c 2007-08-29 17:17:26.000000000 -0400
@@ -601,7 +601,7 @@ static void do_open(fuse_req_t req, fuse
fi.flags = arg->flags;
if (req->f->op.open)
- req->f->op.open(req, nodeid, &fi);
+ (req->f->op.open)(req, nodeid, &fi);
else
fuse_reply_open(req, &fi);
}

View File

@ -1,6 +1,6 @@
Name: fuse
Version: 2.7.0
Release: 4%{?dist}
Release: 5%{?dist}
Summary: File System in Userspace (FUSE) utilities
Group: System Environment/Base
@ -12,6 +12,7 @@ Source2: fuse-makedev.d-fuse
Source3: fuse-README.fedora
Patch0: fuse-udev_rules.patch
Patch1: fuse-2.7.0-openfix.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Requires: kernel >= 2.6.14
Requires(pre): %{_sbindir}/groupadd
@ -57,6 +58,7 @@ pgk-config) to develop FUSE based applications/filesystems.
#disable device creation during build/install
sed -i 's|mknod|echo Disabled: mknod |g' util/Makefile.in
%patch0 -b .patch0
%patch1 -p1 -b .patch1
cp %{SOURCE3} README.fedora
%build
@ -142,6 +144,9 @@ fi
%{_includedir}/fuse
%changelog
* Wed Aug 29 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2.7.0-5
- fix open issue (bz 265321)
* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 2.7.0-4
- Rebuild for selinux ppc32 issue.