Fuse 2.7.2
This commit is contained in:
parent
b11d4cfb04
commit
db640e045e
@ -1 +1 @@
|
||||
fuse-2.7.0.tar.gz
|
||||
fuse-2.7.2.tar.gz
|
||||
|
36
fuse-2.7.2-openfix.patch
Normal file
36
fuse-2.7.2-openfix.patch
Normal file
@ -0,0 +1,36 @@
|
||||
diff -up fuse-2.7.2/lib/fuse.c.BAD fuse-2.7.2/lib/fuse.c
|
||||
--- fuse-2.7.2/lib/fuse.c.BAD 2008-01-21 09:55:42.000000000 -0500
|
||||
+++ fuse-2.7.2/lib/fuse.c 2008-01-21 09:57:20.000000000 -0500
|
||||
@@ -633,17 +633,15 @@ static int fuse_compat_open(struct fuse_
|
||||
{
|
||||
int err;
|
||||
if (!fs->compat || fs->compat >= 25)
|
||||
- err = fs->op.open(path, fi);
|
||||
+ err = (fs->op.open)(path, fi);
|
||||
else if (fs->compat == 22) {
|
||||
struct fuse_file_info_compat tmp;
|
||||
memcpy(&tmp, fi, sizeof(tmp));
|
||||
- err = ((struct fuse_operations_compat22 *) &fs->op)->open(path,
|
||||
- &tmp);
|
||||
+ err = (((struct fuse_operations_compat22 *) &fs->op)->open)(path, &tmp);
|
||||
memcpy(fi, &tmp, sizeof(tmp));
|
||||
fi->fh = tmp.fh;
|
||||
} else
|
||||
- err = ((struct fuse_operations_compat2 *) &fs->op)
|
||||
- ->open(path, fi->flags);
|
||||
+ err = (((struct fuse_operations_compat2 *) &fs->op)->open)(path, fi->flags);
|
||||
return err;
|
||||
}
|
||||
|
||||
diff -up fuse-2.7.2/lib/fuse_lowlevel.c.BAD fuse-2.7.2/lib/fuse_lowlevel.c
|
||||
--- fuse-2.7.2/lib/fuse_lowlevel.c.BAD 2008-01-21 09:57:52.000000000 -0500
|
||||
+++ fuse-2.7.2/lib/fuse_lowlevel.c 2008-01-21 09:58:15.000000000 -0500
|
||||
@@ -605,7 +605,7 @@ static void do_open(fuse_req_t req, fuse
|
||||
fi.flags = arg->flags;
|
||||
|
||||
if (req->f->op.open)
|
||||
- req->f->op.open(req, nodeid, &fi);
|
||||
+ (req->f->op.open)(req, nodeid, &fi);
|
||||
else
|
||||
fuse_reply_open(req, &fi);
|
||||
}
|
20
fuse.spec
20
fuse.spec
@ -1,10 +1,10 @@
|
||||
Name: fuse
|
||||
Version: 2.7.0
|
||||
Release: 8%{?dist}
|
||||
Version: 2.7.2
|
||||
Release: 1%{?dist}
|
||||
Summary: File System in Userspace (FUSE) utilities
|
||||
|
||||
Group: System Environment/Base
|
||||
License: GPL
|
||||
License: GPL+
|
||||
URL: http://fuse.sf.net
|
||||
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
||||
Source1: fuse-udev.nodes
|
||||
@ -12,7 +12,8 @@ Source2: fuse-makedev.d-fuse
|
||||
Source3: fuse-README.fedora
|
||||
|
||||
Patch0: fuse-udev_rules.patch
|
||||
Patch1: fuse-2.7.0-openfix.patch
|
||||
Patch1: fuse-2.7.2-openfix.patch
|
||||
Patch2: fuse-2.7.0-chkconfig.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Requires: kernel >= 2.6.14
|
||||
Requires: which
|
||||
@ -34,7 +35,7 @@ Note: For security reasons only members of the group "fuse" are allowed to
|
||||
%package libs
|
||||
Summary: File System in Userspace (FUSE) libraries
|
||||
Group: System Environment/Libraries
|
||||
License: LGPL
|
||||
License: LGPLv2+
|
||||
|
||||
%description libs
|
||||
Devel With FUSE it is possible to implement a fully functional filesystem in a
|
||||
@ -46,7 +47,7 @@ Summary: File System in Userspace (FUSE) devel files
|
||||
Group: Development/Libraries
|
||||
Requires: %{name}-libs = %{version}-%{release}
|
||||
Requires: pkgconfig
|
||||
License: LGPL
|
||||
License: LGPLv2+
|
||||
|
||||
%description devel
|
||||
With FUSE it is possible to implement a fully functional filesystem in a
|
||||
@ -60,6 +61,7 @@ pgk-config) to develop FUSE based applications/filesystems.
|
||||
sed -i 's|mknod|echo Disabled: mknod |g' util/Makefile.in
|
||||
%patch0 -b .patch0
|
||||
%patch1 -p1 -b .patch1
|
||||
%patch2 -p1
|
||||
cp %{SOURCE3} README.fedora
|
||||
|
||||
%build
|
||||
@ -145,6 +147,12 @@ fi
|
||||
%{_includedir}/fuse
|
||||
|
||||
%changelog
|
||||
* Mon Jan 21 2008 Tom "spot" Callaway <tcallawa@redhat.com> 2.7.2-1
|
||||
- bump to 2.7.2
|
||||
- fix license tag
|
||||
|
||||
* Sun Nov 4 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2.7.0-9
|
||||
- fix initscript to work with chkconfig
|
||||
|
||||
* Mon Oct 1 2007 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-8
|
||||
- Added Require: which (BZ#312511)
|
||||
|
Loading…
Reference in New Issue
Block a user