revert size check in passthrough_ll.c
This commit is contained in:
parent
3237ff5922
commit
af44b8019d
20
fuse-3.1.0-revert-size-check.patch
Normal file
20
fuse-3.1.0-revert-size-check.patch
Normal file
@ -0,0 +1,20 @@
|
||||
diff -up libfuse-fuse-3.1.0/example/passthrough_ll.c.revert libfuse-fuse-3.1.0/example/passthrough_ll.c
|
||||
--- libfuse-fuse-3.1.0/example/passthrough_ll.c.revert 2017-07-28 15:43:12.979509068 -0400
|
||||
+++ libfuse-fuse-3.1.0/example/passthrough_ll.c 2017-07-28 15:43:18.609373600 -0400
|
||||
@@ -51,6 +51,7 @@
|
||||
lo_dirp` elements as inodes. This means that we require uintptr_t
|
||||
and fuse_ino_t to have the same size. The following incantation
|
||||
defines a compile time assert for this requirement. */
|
||||
+/* Disable for now, check is not useful.
|
||||
#if defined(__GNUC__) && (__GNUC__ > 4 || __GNUC__ == 4 && __GNUC_MINOR__ >= 6) && !defined __cplusplus
|
||||
_Static_assert(sizeof(fuse_ino_t) == sizeof(uintptr_t), "fuse: off_t must be 64bit");
|
||||
#else
|
||||
@@ -58,7 +59,7 @@ struct _uintptr_to_must_hold_fuse_ino_t_
|
||||
{ unsigned _uintptr_to_must_hold_fuse_ino_t:
|
||||
((sizeof(fuse_ino_t) == sizeof(uintptr_t)) ? 1 : -1); };
|
||||
#endif
|
||||
-
|
||||
+*/
|
||||
|
||||
/* Compat stuff. Doesn't make it work, just makes it compile. */
|
||||
#ifndef HAVE_FSTATAT
|
@ -18,6 +18,8 @@ Patch1: fuse-3.0.0-More-parentheses.patch
|
||||
Patch2: fuse-0001-More-parentheses.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=970768
|
||||
Patch3: fuse-2.9.2-namespace-conflict-fix.patch
|
||||
# https://github.com/libfuse/libfuse/issues/185
|
||||
Patch4: fuse-3.1.0-revert-size-check.patch
|
||||
|
||||
Requires: which
|
||||
Conflicts: filesystem < 3
|
||||
@ -107,6 +109,7 @@ pushd lib%{name}-%{name}-%{fuse3ver}
|
||||
#disable device creation during build/install
|
||||
sed -i 's|mknod|echo Disabled: mknod |g' util/Makefile.in
|
||||
%patch1 -p1 -b .add_parentheses
|
||||
%patch4 -p1 -b .revert
|
||||
popd
|
||||
|
||||
# fuse 2
|
||||
@ -124,7 +127,7 @@ pushd lib%{name}-%{name}-%{fuse3ver}
|
||||
# Can't pass --disable-static here, or else the utils don't build
|
||||
export MOUNT_FUSE_PATH="%{_sbindir}"
|
||||
CFLAGS="%{optflags} -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64" %configure
|
||||
make %{?_smp_mflags}
|
||||
make %{?_smp_mflags} V=1
|
||||
popd
|
||||
|
||||
# fuse 2
|
||||
|
Loading…
Reference in New Issue
Block a user