import fuse-2.9.9-15.el9
This commit is contained in:
commit
a43d8a7e60
1
.fuse.metadata
Normal file
1
.fuse.metadata
Normal file
@ -0,0 +1 @@
|
||||
943ba651b14bc4a3c6fd959ed4b8c04f4a59032d SOURCES/fuse-2.9.9.tar.gz
|
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/fuse-2.9.9.tar.gz
|
44
SOURCES/fuse2-0001-More-parentheses.patch
Normal file
44
SOURCES/fuse2-0001-More-parentheses.patch
Normal file
@ -0,0 +1,44 @@
|
||||
From: Peter Lemenkov <lemenkov@gmail.com>
|
||||
Date: Mon, 9 Aug 2010 12:10:40 +0400
|
||||
Subject: [PATCH] More parentheses
|
||||
|
||||
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
|
||||
|
||||
diff --git a/lib/fuse.c b/lib/fuse.c
|
||||
index d1d873a..ca1709c 100644
|
||||
--- a/lib/fuse.c
|
||||
+++ b/lib/fuse.c
|
||||
@@ -1529,17 +1529,15 @@ static int fuse_compat_open(struct fuse_fs *fs, const char *path,
|
||||
{
|
||||
int err;
|
||||
if (!fs->compat || fs->compat >= 25)
|
||||
- err = fs->op.open(path, fi);
|
||||
+ err = (fs->op.open)(path, fi);
|
||||
else if (fs->compat == 22) {
|
||||
struct fuse_file_info_compat tmp;
|
||||
memcpy(&tmp, fi, sizeof(tmp));
|
||||
- err = ((struct fuse_operations_compat22 *) &fs->op)->open(path,
|
||||
- &tmp);
|
||||
+ err = (((struct fuse_operations_compat22 *) &fs->op)->open)(path, &tmp);
|
||||
memcpy(fi, &tmp, sizeof(tmp));
|
||||
fi->fh = tmp.fh;
|
||||
} else
|
||||
- err = ((struct fuse_operations_compat2 *) &fs->op)
|
||||
- ->open(path, fi->flags);
|
||||
+ err = (((struct fuse_operations_compat2 *) &fs->op)->open)(path, fi->flags);
|
||||
return err;
|
||||
}
|
||||
|
||||
diff --git a/lib/fuse_lowlevel.c b/lib/fuse_lowlevel.c
|
||||
index ff03c63..255f733 100644
|
||||
--- a/lib/fuse_lowlevel.c
|
||||
+++ b/lib/fuse_lowlevel.c
|
||||
@@ -1211,7 +1211,7 @@ static void do_open(fuse_req_t req, fuse_ino_t nodeid, const void *inarg)
|
||||
fi.flags = arg->flags;
|
||||
|
||||
if (req->f->op.open)
|
||||
- req->f->op.open(req, nodeid, &fi);
|
||||
+ (req->f->op.open)(req, nodeid, &fi);
|
||||
else
|
||||
fuse_reply_open(req, &fi);
|
||||
}
|
@ -0,0 +1,28 @@
|
||||
From: Tom Callaway <spot@fedoraproject.org>
|
||||
Date: Wed, 26 Jun 2013 09:34:52 -0400
|
||||
Subject: [PATCH] add fix for namespace conflict in fuse_kernel.h
|
||||
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=970768
|
||||
|
||||
diff --git a/include/fuse_kernel.h b/include/fuse_kernel.h
|
||||
index c632b58..9e02fe3 100644
|
||||
--- a/include/fuse_kernel.h
|
||||
+++ b/include/fuse_kernel.h
|
||||
@@ -88,12 +88,16 @@
|
||||
#ifndef _LINUX_FUSE_H
|
||||
#define _LINUX_FUSE_H
|
||||
|
||||
-#include <sys/types.h>
|
||||
+#ifdef __linux__
|
||||
+#include <linux/types.h>
|
||||
+#else
|
||||
+#include <stdint.h>
|
||||
#define __u64 uint64_t
|
||||
#define __s64 int64_t
|
||||
#define __u32 uint32_t
|
||||
#define __s32 int32_t
|
||||
#define __u16 uint16_t
|
||||
+#endif
|
||||
|
||||
/*
|
||||
* Version negotiation:
|
@ -0,0 +1,42 @@
|
||||
From: Carlos Maiolino <cmaiolino-H+wXaHxf7aLQT0dZR+AlfA@public.gmane.org>
|
||||
Date: Thu, 20 Apr 2017 14:53:01 +0200
|
||||
Subject: [PATCH] make buffer size match kernel max transfer size
|
||||
|
||||
Currently libfuse has a hardcoded buffer limit to 128kib, while fuse
|
||||
kernel module has a limit up to 32 pages.
|
||||
|
||||
This patch changes buffer limit to match the current page size, instead
|
||||
of assuming 4096 bytes pages, enabling architectures with bigger pages
|
||||
to use larger buffers, improving performance.
|
||||
|
||||
Also, add a new macro (HEADER_SIZE) to specify the space needed to
|
||||
accommodate the header, making it easier to understand why those extra
|
||||
4096 bytes are needed
|
||||
|
||||
Signed-off-by: Carlos Maiolino <cmaiolino-H+wXaHxf7aLQT0dZR+AlfA@public.gmane.org>
|
||||
|
||||
diff --git a/lib/fuse_kern_chan.c b/lib/fuse_kern_chan.c
|
||||
index 4a9beb8..640b91a 100644
|
||||
--- a/lib/fuse_kern_chan.c
|
||||
+++ b/lib/fuse_kern_chan.c
|
||||
@@ -83,7 +83,10 @@ static void fuse_kern_chan_destroy(struct fuse_chan *ch)
|
||||
close(fd);
|
||||
}
|
||||
|
||||
-#define MIN_BUFSIZE 0x21000
|
||||
+#define KERNEL_BUF_PAGES 32
|
||||
+
|
||||
+/* room needed in buffer to accommodate header */
|
||||
+#define HEADER_SIZE 0x1000
|
||||
|
||||
struct fuse_chan *fuse_kern_chan_new(int fd)
|
||||
{
|
||||
@@ -92,7 +95,6 @@ struct fuse_chan *fuse_kern_chan_new(int fd)
|
||||
.send = fuse_kern_chan_send,
|
||||
.destroy = fuse_kern_chan_destroy,
|
||||
};
|
||||
- size_t bufsize = getpagesize() + 0x1000;
|
||||
- bufsize = bufsize < MIN_BUFSIZE ? MIN_BUFSIZE : bufsize;
|
||||
+ size_t bufsize = KERNEL_BUF_PAGES * getpagesize() + HEADER_SIZE;
|
||||
return fuse_chan_new(&op, fd, bufsize, NULL);
|
||||
}
|
@ -0,0 +1,20 @@
|
||||
From: Peter Lemenkov <lemenkov@gmail.com>
|
||||
Date: Wed, 3 Apr 2019 12:23:56 +0300
|
||||
Subject: [PATCH] Whitelist SMB2 found on some NAS devices
|
||||
|
||||
* https://bugzilla.redhat.com/1694552#c7
|
||||
|
||||
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
|
||||
|
||||
diff --git a/util/fusermount.c b/util/fusermount.c
|
||||
index 4b799d9..ef9d1ed 100644
|
||||
--- a/util/fusermount.c
|
||||
+++ b/util/fusermount.c
|
||||
@@ -1046,6 +1046,7 @@ static int check_perm(const char **mntp, struct stat *stbuf, int *mountpoint_fd)
|
||||
0x5346544E /* NTFS_SB_MAGIC */,
|
||||
0x794C7630 /* OVERLAYFS_SUPER_MAGIC */,
|
||||
0x52654973 /* REISERFS_SUPER_MAGIC */,
|
||||
+ 0xFE534D42 /* SMB2_SUPER_MAGIC */,
|
||||
0x73717368 /* SQUASHFS_MAGIC */,
|
||||
0x01021994 /* TMPFS_MAGIC */,
|
||||
0x24051905 /* UBIFS_SUPER_MAGIC */,
|
60
SOURCES/fuse2-0005-remove-closefrom-function.patch
Normal file
60
SOURCES/fuse2-0005-remove-closefrom-function.patch
Normal file
@ -0,0 +1,60 @@
|
||||
From ae2352bca9b4e607538412da0cc2a9625cd8b692 Mon Sep 17 00:00:00 2001
|
||||
From: Sam James <sam@gentoo.org>
|
||||
Date: Sat, 24 Jul 2021 22:02:45 +0100
|
||||
Subject: [PATCH] util/ulockmgr_server.c: conditionally define closefrom (fix
|
||||
glibc-2.34+)
|
||||
|
||||
closefrom(3) has joined us in glibc-land from *BSD and Solaris. Since
|
||||
it's available in glibc 2.34+, we want to detect it and only define our
|
||||
fallback if the libc doesn't provide it.
|
||||
|
||||
Bug: https://bugs.gentoo.org/803923
|
||||
Signed-off-by: Sam James <sam@gentoo.org>
|
||||
---
|
||||
configure.ac | 1 +
|
||||
util/ulockmgr_server.c | 6 ++++++
|
||||
2 files changed, 7 insertions(+)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 9946a0efa..a2d481aa9 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -55,6 +55,7 @@ fi
|
||||
|
||||
AC_CHECK_FUNCS([fork setxattr fdatasync splice vmsplice utimensat])
|
||||
AC_CHECK_FUNCS([posix_fallocate])
|
||||
+AC_CHECK_FUNCS([closefrom])
|
||||
AC_CHECK_MEMBERS([struct stat.st_atim])
|
||||
AC_CHECK_MEMBERS([struct stat.st_atimespec])
|
||||
|
||||
diff --git a/util/ulockmgr_server.c b/util/ulockmgr_server.c
|
||||
index 273c7d923..a04dac5c6 100644
|
||||
--- a/util/ulockmgr_server.c
|
||||
+++ b/util/ulockmgr_server.c
|
||||
@@ -22,6 +22,10 @@
|
||||
#include <sys/socket.h>
|
||||
#include <sys/wait.h>
|
||||
|
||||
+#ifdef HAVE_CONFIG_H
|
||||
+ #include "config.h"
|
||||
+#endif
|
||||
+
|
||||
struct message {
|
||||
unsigned intr : 1;
|
||||
unsigned nofd : 1;
|
||||
@@ -124,6 +128,7 @@ static int receive_message(int sock, void *buf, size_t buflen, int *fdp,
|
||||
return res;
|
||||
}
|
||||
|
||||
+#if !defined(HAVE_CLOSEFROM)
|
||||
static int closefrom(int minfd)
|
||||
{
|
||||
DIR *dir = opendir("/proc/self/fd");
|
||||
@@ -141,6 +146,7 @@ static int closefrom(int minfd)
|
||||
}
|
||||
return 0;
|
||||
}
|
||||
+#endif
|
||||
|
||||
static void send_reply(int cfd, struct message *msg)
|
||||
{
|
470
SPECS/fuse.spec
Normal file
470
SPECS/fuse.spec
Normal file
@ -0,0 +1,470 @@
|
||||
Name: fuse
|
||||
Version: 2.9.9
|
||||
Release: 15%{?dist}
|
||||
Summary: File System in Userspace (FUSE) v2 utilities
|
||||
License: GPL+
|
||||
URL: http://fuse.sf.net
|
||||
Source0: https://github.com/libfuse/libfuse/releases/download/%{name}-%{version}/%{name}-%{version}.tar.gz
|
||||
|
||||
Patch1: fuse2-0001-More-parentheses.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=970768
|
||||
Patch2: fuse2-0002-add-fix-for-namespace-conflict-in-fuse_kernel.h.patch
|
||||
# https://github.com/libfuse/libfuse/commit/4f8f034a8969a48f210bf00be78a67cfb6964c72
|
||||
# backported for fuse2
|
||||
Patch3: fuse2-0003-make-buffer-size-match-kernel-max-transfer-size.patch
|
||||
# https://bugzilla.redhat.com/1694552#c7
|
||||
# https://github.com/libfuse/libfuse/pull/392
|
||||
# backported for fuse2
|
||||
Patch4: fuse2-0004-Whitelist-SMB2-found-on-some-NAS-devices.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1984778
|
||||
# https://github.com/libfuse/libfuse/pull/619
|
||||
# https://github.com/libfuse/libfuse/commit/ae2352bca9b4e607538412da0cc2a9625cd8b692.patch
|
||||
Patch5: fuse2-0005-remove-closefrom-function.patch
|
||||
|
||||
# Default to *do* run autoreconf, because in case any downstream patch touched
|
||||
# configure.ac or Makefile.am it may be necessary to do so - e.g Patch #5.
|
||||
%{!?enable_autotools: %global enable_autotools 1}
|
||||
|
||||
Requires: which
|
||||
Conflicts: filesystem < 3
|
||||
BuildRequires: libselinux-devel
|
||||
BuildRequires: autoconf, automake, libtool, gettext-devel, make
|
||||
BuildRequires: systemd-udev
|
||||
# fuse-common 3.4.2-3 and earlier included man pages
|
||||
Requires: fuse-common >= 3.4.2-4
|
||||
|
||||
%description
|
||||
With FUSE it is possible to implement a fully functional filesystem in a
|
||||
userspace program. This package contains the FUSE v2 userspace tools to
|
||||
mount a FUSE filesystem.
|
||||
|
||||
%package libs
|
||||
Summary: File System in Userspace (FUSE) v2 libraries
|
||||
License: LGPLv2+
|
||||
Conflicts: filesystem < 3
|
||||
|
||||
%description libs
|
||||
Devel With FUSE it is possible to implement a fully functional filesystem in a
|
||||
userspace program. This package contains the FUSE v2 libraries.
|
||||
|
||||
%package devel
|
||||
Summary: File System in Userspace (FUSE) v2 devel files
|
||||
Requires: %{name}-libs = %{version}-%{release}
|
||||
Requires: pkgconfig
|
||||
License: LGPLv2+
|
||||
Conflicts: filesystem < 3
|
||||
|
||||
%description devel
|
||||
With FUSE it is possible to implement a fully functional filesystem in a
|
||||
userspace program. This package contains development files (headers,
|
||||
pgk-config) to develop FUSE v2 based applications/filesystems.
|
||||
|
||||
%prep
|
||||
%setup
|
||||
|
||||
# ./makeconf.sh
|
||||
#disable device creation during build/install
|
||||
sed -i 's|mknod|echo Disabled: mknod |g' util/Makefile.in
|
||||
%patch1 -p1 -b .add_parentheses
|
||||
%patch2 -p1 -b .conflictfix
|
||||
%patch3 -p1 -b .buffer_size
|
||||
%patch4 -p1 -b .smb2_whitelist
|
||||
%patch5 -p1 -b .remove_closefrom
|
||||
|
||||
%build
|
||||
%if 0%{?enable_autotools}
|
||||
autoreconf -if
|
||||
%endif
|
||||
# Can't pass --disable-static here, or else the utils don't build
|
||||
export MOUNT_FUSE_PATH="%{_sbindir}"
|
||||
CFLAGS="%{optflags} -D_GNU_SOURCE" %configure
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
mkdir -p %{buildroot}/%{_libdir}/pkgconfig
|
||||
install -m 0755 lib/.libs/libfuse.so.%{version} %{buildroot}/%{_libdir}
|
||||
install -m 0755 lib/.libs/libulockmgr.so.1.0.1 %{buildroot}/%{_libdir}
|
||||
install -p fuse.pc %{buildroot}/%{_libdir}/pkgconfig/
|
||||
mkdir -p %{buildroot}/%{_bindir}
|
||||
install -m 0755 util/fusermount %{buildroot}/%{_bindir}
|
||||
mkdir -p %{buildroot}/%{_sbindir}
|
||||
install -m 0755 util/mount.fuse %{buildroot}/%{_sbindir}
|
||||
install -m 0755 util/ulockmgr_server %{buildroot}/%{_bindir}
|
||||
mkdir -p %{buildroot}/%{_includedir}/fuse
|
||||
install -p include/old/fuse.h %{buildroot}/%{_includedir}/
|
||||
install -p include/ulockmgr.h %{buildroot}/%{_includedir}/
|
||||
for i in cuse_lowlevel.h fuse_common_compat.h fuse_common.h fuse_compat.h fuse.h fuse_lowlevel_compat.h fuse_lowlevel.h fuse_opt.h; do
|
||||
install -p include/$i %{buildroot}/%{_includedir}/fuse/
|
||||
done
|
||||
mkdir -p %{buildroot}/%{_mandir}/man1/
|
||||
cp -a doc/fusermount.1 doc/ulockmgr_server.1 %{buildroot}/%{_mandir}/man1/
|
||||
mkdir -p %{buildroot}/%{_mandir}/man8/
|
||||
cp -a doc/mount.fuse.8 %{buildroot}/%{_mandir}/man8/
|
||||
pushd %{buildroot}/%{_libdir}
|
||||
ln -s libfuse.so.%{version} libfuse.so.2
|
||||
ln -s libfuse.so.%{version} libfuse.so
|
||||
ln -s libulockmgr.so.1.0.1 libulockmgr.so.1
|
||||
ln -s libulockmgr.so.1.0.1 libulockmgr.so
|
||||
popd
|
||||
|
||||
# Get rid of static libs
|
||||
rm -f %{buildroot}/%{_libdir}/*.a
|
||||
|
||||
%ldconfig_scriptlets libs
|
||||
|
||||
%files
|
||||
%license COPYING
|
||||
%doc AUTHORS ChangeLog NEWS README.md README.NFS
|
||||
%{_sbindir}/mount.fuse
|
||||
%attr(4755,root,root) %{_bindir}/fusermount
|
||||
%{_bindir}/ulockmgr_server
|
||||
%{_mandir}/man1/*
|
||||
%{_mandir}/man8/*
|
||||
|
||||
%files libs
|
||||
%license COPYING.LIB
|
||||
%{_libdir}/libfuse.so.*
|
||||
%{_libdir}/libulockmgr.so.*
|
||||
|
||||
%files devel
|
||||
%{_libdir}/libfuse.so
|
||||
%{_libdir}/libulockmgr.so
|
||||
%{_libdir}/pkgconfig/fuse.pc
|
||||
%{_includedir}/fuse.h
|
||||
%{_includedir}/ulockmgr.h
|
||||
%{_includedir}/fuse
|
||||
|
||||
%changelog
|
||||
* Tue Dec 07 2021 Pavel Reichl <preichl@redhat.com> - 2.9.9-15
|
||||
- Add gating.yaml file
|
||||
|
||||
* Thu Oct 07 2021 Pavel Reichl <preichl@redhat.com> - 2.9.9-14
|
||||
- Fix failure to build from source, fix wrong URL in Source0
|
||||
Related: rhbz#1984778
|
||||
|
||||
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 2.9.9-13
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
||||
* Thu Apr 15 2021 Mohan Boddu <mboddu@redhat.com> - 2.9.9-12
|
||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||
|
||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.9.9-11
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.9.9-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.9.9-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.9.9-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Wed May 01 2019 Dave Dykstra <dwd@fedoraproject.org> - 2.9.9-7
|
||||
- Update the Requires: fuse-common >= version to 3.4.2-4 because
|
||||
fuse-common > 3.4.2-3 is insufficient to force the new version
|
||||
|
||||
* Wed May 01 2019 Dave Dykstra <dwd@fedoraproject.org> - 2.9.9-6
|
||||
- Fix name of libfuse.so.2
|
||||
|
||||
* Wed May 01 2019 Dave Dykstra <dwd@fedoraproject.org> - 2.9.9-5
|
||||
- Update the Requires: fuse-common > version to 3.4.2-3
|
||||
|
||||
* Wed May 01 2019 Dave Dykstra <dwd@fedoraproject.org> - 2.9.9-4
|
||||
- Separate fuse3 out into its own package
|
||||
|
||||
* Tue Apr 16 2019 Adam Williamson <awilliam@redhat.com> - 2.9.9-3
|
||||
- Rebuild with Meson fix for #1699099
|
||||
|
||||
* Thu Apr 04 2019 Peter Lemenkov <lemenkov@gmail.com> - 2.9.9-2
|
||||
- Whitelist SMB2 (rhbz#1694552)
|
||||
|
||||
* Mon Mar 25 2019 Tom Callaway <spot@fedoraproject.org> - 2.9.9-1
|
||||
- update fuse to 2.9.9
|
||||
- update fuse3 to 3.4.2
|
||||
|
||||
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.9.7-17
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Tue Nov 27 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.9.7-16
|
||||
- Rebuild for tinyxml2 7.x
|
||||
|
||||
* Fri Nov 09 2018 Dan Horák <dan[at]danny.cz> - 2.9.7-15
|
||||
- backport buffer-size patch to fuse2
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.9.7-14
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Mon May 14 2018 Tom Callaway <spot@fedoraproject.org> - 2.9.7-13
|
||||
- update fuse3 to 3.2.3
|
||||
|
||||
* Mon Apr 2 2018 Tom Callaway <spot@fedoraproject.org> - 2.9.7-12
|
||||
- update fuse3 to 3.2.2
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.9.7-11
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Thu Nov 16 2017 Tom Callaway <spot@fedoraproject.org> 2.9.7-10
|
||||
- update fuse3 to 3.2.1
|
||||
|
||||
* Mon Aug 7 2017 Tom Callaway <spot@fedoraproject.org> 2.9.7-9
|
||||
- update fuse3 to 3.1.1
|
||||
|
||||
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.9.7-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Fri Jul 28 2017 Tom Callaway <spot@fedoraproject.org> - 2.9.7-7
|
||||
- use -D_FILE_OFFSET_BITS=64 to force off_t to be 64bit on 32bit arches
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.9.7-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Mon Jul 17 2017 Tom Callaway <spot@fedoraproject.org> - 3.1.0-5
|
||||
- update to 3.1.0
|
||||
|
||||
* Thu Jun 1 2017 Tom Callaway <spot@fedoraproject.org> - 3.0.2-4
|
||||
- update to 3.0.2
|
||||
|
||||
* Sun Mar 26 2017 Tom Callaway <spot@fedoraproject.org> - 3.0.0-3
|
||||
- update release to 3 to make clean upgrade
|
||||
|
||||
* Tue Mar 21 2017 Tom Callaway <spot@fedoraproject.org> - 3.0.0-1
|
||||
- update to 3.0.0
|
||||
- split out fuse3 packages
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.9.7-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Wed Jul 6 2016 Tom Callaway <spot@fedoraproject.org> - 2.9.7-1
|
||||
- update to 2.9.7
|
||||
|
||||
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.9.4-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Thu Oct 08 2015 Adam Williamson <awilliam@redhat.com> - 2.9.4-3
|
||||
- backport patch allowing setting SELinux context on FUSE mounts
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.9.4-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Fri May 22 2015 Tom Callaway <spot@fedoraproject.org> 2.9.4-1
|
||||
- update to 2.9.4
|
||||
- fixes CVE-2015-3202
|
||||
|
||||
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.9.3-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.9.3-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.9.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Sat Jul 6 2013 Tom Callaway <spot@fedoraproject.org> - 2.9.3-1
|
||||
- update to 2.9.3
|
||||
|
||||
* Wed Jun 26 2013 Tom Callaway <spot@fedoraproject.org> - 2.9.2-4
|
||||
- add fix for namespace conflict in fuse_kernel.h
|
||||
|
||||
* Sat May 18 2013 Peter Lemenkov <lemenkov@gmail.com> - 2.9.2-3
|
||||
- Removed pre-F12 stuff
|
||||
- Dropped ancient dependency on initscripts and chkconfig
|
||||
|
||||
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.9.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Thu Dec 06 2012 Adam Jackson <ajax@redhat.com>
|
||||
- Remove ancient Requires: kernel >= 2.6.14, FC6 was 2.6.18.
|
||||
|
||||
* Tue Oct 23 2012 Tom Callaway <spot@fedoraproject.org> - 2.9.2-1
|
||||
- update to 2.9.2
|
||||
|
||||
* Tue Aug 28 2012 Tom Callaway <spot@fedoraproject.org> - 2.9.1-1
|
||||
- update to 2.9.1
|
||||
|
||||
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.7-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Mon Apr 16 2012 Peter Lemenkov <lemenkov@gmail.com> - 2.8.7-1
|
||||
- Ver. 2.8.7
|
||||
|
||||
* Sun Apr 15 2012 Kay Sievers <kay@redhat.com> - 2.8.6-4
|
||||
- remove needless udev rule
|
||||
|
||||
* Wed Jan 25 2012 Harald Hoyer <harald@redhat.com> 2.8.6-3
|
||||
- install everything in /usr
|
||||
https://fedoraproject.org/wiki/Features/UsrMove
|
||||
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.6-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Thu Sep 22 2011 Peter Lemenkov <lemenkov@gmail.com> - 2.8.6-1
|
||||
- Ver. 2.8.6
|
||||
- Dropped patch 3 - fixed upstream
|
||||
|
||||
* Thu Mar 03 2011 Peter Lemenkov <lemenkov@gmail.com> - 2.8.5-5
|
||||
- Use noreplace for /etc/fuse.conf
|
||||
|
||||
* Tue Feb 15 2011 Peter Lemenkov <lemenkov@gmail.com> - 2.8.5-4
|
||||
- Provide /etc/fuse.conf (see rhbz #292811)
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.5-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Wed Oct 27 2010 Peter Lemenkov <lemenkov@gmail.com> 2.8.5-2
|
||||
- Fixed rhbz #622255
|
||||
|
||||
* Tue Oct 26 2010 Peter Lemenkov <lemenkov@gmail.com> 2.8.5-1
|
||||
- Ver. 2.8.5
|
||||
|
||||
* Tue Jun 8 2010 Peter Lemenkov <lemenkov@gmail.com> 2.8.4-1
|
||||
- Ver. 2.8.4
|
||||
- CVE-2009-3297 patch dropped (merged upstream)
|
||||
|
||||
* Tue Jan 26 2010 Peter Lemenkov <lemenkov@gmail.com> 2.8.1-4
|
||||
- Fixed CVE-2009-3297 (rhbz #558833)
|
||||
|
||||
* Thu Nov 19 2009 Peter Lemenkov <lemenkov@gmail.com> 2.8.1-3
|
||||
- Fixed udev rules (bz# 538606)
|
||||
|
||||
* Thu Nov 19 2009 Peter Lemenkov <lemenkov@gmail.com> 2.8.1-2
|
||||
- Removed support for MAKEDEV (bz# 511220)
|
||||
|
||||
* Thu Sep 17 2009 Peter Lemenkov <lemenkov@gmail.com> 2.8.1-1
|
||||
- Ver. 2.8.1
|
||||
|
||||
* Wed Aug 19 2009 Peter Lemenkov <lemenkov@gmail.com> 2.8.0-1
|
||||
- Ver. 2.8.0
|
||||
|
||||
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.7.4-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.7.4-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Wed Jan 28 2009 Peter Lemenkov <lemenkov@gmail.com> 2.7.4-2
|
||||
- Fixed BZ#479581
|
||||
|
||||
* Sat Aug 23 2008 Peter Lemenkov <lemenkov@gmail.com> 2.7.4-1
|
||||
- Ver. 2.7.4
|
||||
|
||||
* Sat Jul 12 2008 Peter Lemenkov <lemenkov@gmail.com> 2.7.3-3
|
||||
- Fixed initscripts (BZ#441284)
|
||||
|
||||
* Thu Feb 28 2008 Peter Lemenkov <lemenkov@gmail.com> 2.7.3-2
|
||||
- Fixed BZ#434881
|
||||
|
||||
* Wed Feb 20 2008 Peter Lemenkov <lemenkov@gmail.com> 2.7.3-1
|
||||
- Ver. 2.7.3
|
||||
- Removed usergroup fuse
|
||||
- Added chkconfig support (BZ#228088)
|
||||
|
||||
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.7.2-2
|
||||
- Autorebuild for GCC 4.3
|
||||
|
||||
* Mon Jan 21 2008 Tom "spot" Callaway <tcallawa@redhat.com> 2.7.2-1
|
||||
- bump to 2.7.2
|
||||
- fix license tag
|
||||
|
||||
* Sun Nov 4 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2.7.0-9
|
||||
- fix initscript to work with chkconfig
|
||||
|
||||
* Mon Oct 1 2007 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-8
|
||||
- Added Require: which (BZ#312511)
|
||||
|
||||
* Fri Sep 21 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2.7.0-7
|
||||
- revert udev rules change
|
||||
|
||||
* Thu Sep 20 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2.7.0-6
|
||||
- change udev rules so that /dev/fuse is chmod 666 (bz 298651)
|
||||
|
||||
* Wed Aug 29 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2.7.0-5
|
||||
- fix open issue (bz 265321)
|
||||
|
||||
* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 2.7.0-4
|
||||
- Rebuild for selinux ppc32 issue.
|
||||
|
||||
* Sun Jul 22 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2.7.0-3
|
||||
- put pkgconfig file in correct place
|
||||
- enable compat symlinks for files in /bin
|
||||
|
||||
* Sat Jul 21 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2.7.0-2
|
||||
- redefine exec_prefix to /
|
||||
- redefine bindir to /bin
|
||||
- redefine libdir to %%{_lib}
|
||||
- don't pass --disable-static to configure
|
||||
- manually rm generated static libs
|
||||
|
||||
* Wed Jul 18 2007 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-1
|
||||
- Version 2.7.0
|
||||
- Redefined exec_prefix due to demands from NTFS-3G
|
||||
|
||||
* Wed Jun 6 2007 Peter Lemenkov <lemenkov@gmail.com> 2.6.5-2
|
||||
- Add BR libselinux-devel (bug #235145)
|
||||
- Config files properly marked as config (bug #211122)
|
||||
|
||||
* Sat May 12 2007 Peter Lemenkov <lemenkov@gmail.com> 2.6.5-1
|
||||
- Version 2.6.5
|
||||
|
||||
* Thu Feb 22 2007 Peter Lemenkov <lemenkov@gmail.com> 2.6.3-2
|
||||
- Fixed bug #229642
|
||||
|
||||
* Wed Feb 7 2007 Peter Lemenkov <lemenkov@gmail.com> 2.6.3-1
|
||||
* Ver. 2.6.3
|
||||
|
||||
* Tue Dec 26 2006 Peter Lemenkov <lemenkov@gmail.com> 2.6.1-1
|
||||
- Ver. 2.6.1
|
||||
|
||||
* Sat Nov 25 2006 Peter Lemenkov <lemenkov@gmail.com> 2.6.0-2
|
||||
- fixed nasty typo (see bug #217075)
|
||||
|
||||
* Fri Nov 3 2006 Peter Lemenkov <lemenkov@gmail.com> 2.6.0-1
|
||||
- Ver. 2.6.0
|
||||
|
||||
* Sun Oct 29 2006 Peter Lemenkov <lemenkov@gmail.com> 2.5.3-5
|
||||
- Fixed udev-rule again
|
||||
|
||||
* Sat Oct 7 2006 Peter Lemenkov <lemenkov@gmail.com> 2.5.3-4
|
||||
- Fixed udev-rule
|
||||
|
||||
* Tue Sep 12 2006 Peter Lemenkov <lemenkov@gmail.com> 2.5.3-3%{?dist}
|
||||
- Rebuild for FC6
|
||||
|
||||
* Wed May 03 2006 Peter Lemenkov <lemenkov@newmail.ru> 2.5.3-1%{?dist}
|
||||
- Update to 2.5.3
|
||||
|
||||
* Thu Mar 30 2006 Peter Lemenkov <lemenkov@newmail.ru> 2.5.2-4%{?dist}
|
||||
- rebuild
|
||||
|
||||
* Mon Feb 13 2006 Peter Lemenkov <lemenkov@newmail.ru> - 2.5.2-3
|
||||
- Proper udev rule
|
||||
|
||||
* Mon Feb 13 2006 Peter Lemenkov <lemenkov@newmail.ru> - 2.5.2-2
|
||||
- Added missing requires
|
||||
|
||||
* Tue Feb 07 2006 Peter Lemenkov <lemenkov@newmail.ru> - 2.5.2-1
|
||||
- Update to 2.5.2
|
||||
- Dropped fuse-mount.fuse.patch
|
||||
|
||||
* Wed Nov 23 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.4.2-1
|
||||
- Use dist
|
||||
|
||||
* Wed Nov 23 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.4.2-1
|
||||
- Update to 2.4.2 (solves CVE-2005-3531)
|
||||
- Update README.fedora
|
||||
|
||||
* Sat Nov 12 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.4.1-3
|
||||
- Add README.fedora
|
||||
- Add hint to README.fedora and that you have to be member of the group "fuse"
|
||||
in the description
|
||||
- Use groupadd instead of fedora-groupadd
|
||||
|
||||
* Fri Nov 04 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.4.1-2
|
||||
- Rename packages a bit
|
||||
- use makedev.d/40-fuse.nodes
|
||||
- fix /sbin/mount.fuse
|
||||
- Use a fuse group to restict access to fuse-filesystems
|
||||
|
||||
* Fri Oct 28 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.4.1-1
|
||||
- Initial RPM release.
|
Loading…
Reference in New Issue
Block a user