Fixed BZ#479581
This commit is contained in:
parent
17b753546c
commit
753d4b77d5
@ -1,21 +0,0 @@
|
||||
--- util/init_script 2008-02-19 22:51:28.000000000 +0300
|
||||
+++ util/init_script 2008-07-12 09:49:00.000000000 +0400
|
||||
@@ -1,10 +1,15 @@
|
||||
#! /bin/sh
|
||||
+
|
||||
+# Startup script for fuse
|
||||
+#
|
||||
+# chkconfig: - 25 75
|
||||
+
|
||||
### BEGIN INIT INFO
|
||||
# Provides: fuse
|
||||
-# Required-Start:
|
||||
+# Required-Start:
|
||||
# Should-Start: udev
|
||||
-# Required-Stop:
|
||||
-# Default-Start: S
|
||||
+# Required-Stop:
|
||||
+# Default-Start:
|
||||
# Default-Stop:
|
||||
# Short-Description: Start and stop fuse.
|
||||
# Description: Load the fuse module and mount the fuse control
|
44
fuse.spec
44
fuse.spec
@ -1,25 +1,24 @@
|
||||
Name: fuse
|
||||
Version: 2.7.4
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: File System in Userspace (FUSE) utilities
|
||||
|
||||
Group: System Environment/Base
|
||||
License: GPL+
|
||||
URL: http://fuse.sf.net
|
||||
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
||||
Source1: fuse-udev.nodes
|
||||
Source2: fuse-makedev.d-fuse
|
||||
Source1: fuse-udev.nodes
|
||||
Source2: fuse-makedev.d-fuse
|
||||
|
||||
Patch0: fuse-udev_rules.patch
|
||||
Patch1: fuse-openfix.patch
|
||||
Patch2: fuse-chkconfig_support.diff
|
||||
Patch0: fuse-udev_rules.patch
|
||||
Patch1: fuse-openfix.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Requires: kernel >= 2.6.14
|
||||
Requires: which
|
||||
BuildRequires: libselinux-devel
|
||||
Requires: kernel >= 2.6.14
|
||||
Requires: which
|
||||
BuildRequires: libselinux-devel
|
||||
|
||||
Requires(post): /sbin/chkconfig
|
||||
Requires(post): /sbin/MAKEDEV
|
||||
Requires(post): /sbin/MAKEDEV
|
||||
Requires(preun): /sbin/chkconfig
|
||||
Requires(preun): /sbin/service
|
||||
Requires(postun):/sbin/service
|
||||
@ -42,8 +41,8 @@ userspace program. This package contains the FUSE libraries.
|
||||
%package devel
|
||||
Summary: File System in Userspace (FUSE) devel files
|
||||
Group: Development/Libraries
|
||||
Requires: %{name}-libs = %{version}-%{release}
|
||||
Requires: pkgconfig
|
||||
Requires: %{name}-libs = %{version}-%{release}
|
||||
Requires: pkgconfig
|
||||
License: LGPLv2+
|
||||
|
||||
%description devel
|
||||
@ -58,7 +57,6 @@ pgk-config) to develop FUSE based applications/filesystems.
|
||||
sed -i 's|mknod|echo Disabled: mknod |g' util/Makefile.in
|
||||
%patch0 -p0 -b .patch0
|
||||
%patch1 -p0 -b .patch1
|
||||
%patch2 -p0 -b .patch2
|
||||
|
||||
%build
|
||||
# Can't pass --disable-static here, or else the utils don't build
|
||||
@ -75,8 +73,8 @@ rm -rf $RPM_BUILD_ROOT
|
||||
make install DESTDIR=$RPM_BUILD_ROOT
|
||||
find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
|
||||
# FIXME change from 60 to 99
|
||||
install -D -p -m 644 %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/udev/makedev.d/99-fuse.nodes
|
||||
install -D -p -m 644 %{SOURCE2} $RPM_BUILD_ROOT/%{_sysconfdir}/makedev.d/z-fuse
|
||||
install -D -p -m 644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/udev/makedev.d/99-fuse.nodes
|
||||
install -D -p -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/makedev.d/z-fuse
|
||||
# change from 4755 to 0755 to allow stripping -- fixed later in files
|
||||
chmod 0755 $RPM_BUILD_ROOT/bin/fusermount
|
||||
# Put pc file in correct place
|
||||
@ -85,6 +83,7 @@ mv $RPM_BUILD_ROOT/%{_lib}/pkgconfig $RPM_BUILD_ROOT%{_libdir}
|
||||
|
||||
# Get rid of static libs
|
||||
rm -f $RPM_BUILD_ROOT/%{_lib}/*.a
|
||||
rm -f $RPM_BUILD_ROOT%{_sysconfdir}/init.d/fuse
|
||||
|
||||
# Compatibility symlinks
|
||||
mkdir -p $RPM_BUILD_ROOT%{_bindir}
|
||||
@ -97,18 +96,13 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%post
|
||||
/sbin/MAKEDEV fuse
|
||||
/sbin/chkconfig --add fuse
|
||||
|
||||
%preun
|
||||
if [ $1 = 0 ]; then
|
||||
/sbin/service fuse stop >/dev/null 2>&1
|
||||
/sbin/chkconfig --del fuse
|
||||
if [ -f /etc/init.d/fuse ] ; then
|
||||
/sbin/service fuse stop >/dev/null 2>&1
|
||||
/sbin/chkconfig --del fuse
|
||||
fi
|
||||
|
||||
%postun
|
||||
if [ "$1" -ge "1" ]; then
|
||||
/sbin/service fuse condrestart >/dev/null 2>&1 || :
|
||||
fi
|
||||
|
||||
%post libs -p /sbin/ldconfig
|
||||
|
||||
@ -120,7 +114,6 @@ fi
|
||||
/sbin/mount.fuse
|
||||
%attr(4755,root,root) /bin/fusermount
|
||||
/bin/ulockmgr_server
|
||||
%{_sysconfdir}/init.d/fuse
|
||||
%{_sysconfdir}/makedev.d/z-fuse
|
||||
# Compat symlinks
|
||||
%{_bindir}/fusermount
|
||||
@ -144,6 +137,9 @@ fi
|
||||
%{_includedir}/fuse
|
||||
|
||||
%changelog
|
||||
* Wed Jan 28 2009 Peter Lemenkov <lemenkov@gmail.com> 2.7.4-2
|
||||
- Fixed BZ#479581
|
||||
|
||||
* Sat Aug 23 2008 Peter Lemenkov <lemenkov@gmail.com> 2.7.4-1
|
||||
- Ver. 2.7.4
|
||||
|
||||
|
@ -1,2 +1,3 @@
|
||||
fuse-2_7_3-3_fc9:HEAD:fuse-2.7.3-3.fc9.src.rpm:1215842579
|
||||
fuse-2_7_4-1_fc9:HEAD:fuse-2.7.4-1.fc9.src.rpm:1222597934
|
||||
fuse-2_7_4-2_fc10:HEAD:fuse-2.7.4-2.fc10.src.rpm:1233157758
|
||||
|
Loading…
Reference in New Issue
Block a user