add fix for namespace conflict in fuse_kernel.h
This commit is contained in:
parent
fad9c75b79
commit
453d02b63f
21
fuse-2.9.2-namespace-conflict-fix.patch
Normal file
21
fuse-2.9.2-namespace-conflict-fix.patch
Normal file
@ -0,0 +1,21 @@
|
|||||||
|
diff -up fuse-2.9.2/include/fuse_kernel.h.conflictfix fuse-2.9.2/include/fuse_kernel.h
|
||||||
|
--- fuse-2.9.2/include/fuse_kernel.h.conflictfix 2013-06-26 09:31:57.862198038 -0400
|
||||||
|
+++ fuse-2.9.2/include/fuse_kernel.h 2013-06-26 09:32:19.679198365 -0400
|
||||||
|
@@ -88,12 +88,16 @@
|
||||||
|
#ifndef _LINUX_FUSE_H
|
||||||
|
#define _LINUX_FUSE_H
|
||||||
|
|
||||||
|
-#include <sys/types.h>
|
||||||
|
+#ifdef __linux__
|
||||||
|
+#include <linux/types.h>
|
||||||
|
+#else
|
||||||
|
+#include <stdint.h>
|
||||||
|
#define __u64 uint64_t
|
||||||
|
#define __s64 int64_t
|
||||||
|
#define __u32 uint32_t
|
||||||
|
#define __s32 int32_t
|
||||||
|
#define __u16 uint16_t
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
/*
|
||||||
|
* Version negotiation:
|
@ -1,6 +1,6 @@
|
|||||||
Name: fuse
|
Name: fuse
|
||||||
Version: 2.9.2
|
Version: 2.9.2
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
Summary: File System in Userspace (FUSE) utilities
|
Summary: File System in Userspace (FUSE) utilities
|
||||||
|
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
@ -10,6 +10,8 @@ Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.
|
|||||||
Source1: %{name}.conf
|
Source1: %{name}.conf
|
||||||
|
|
||||||
Patch1: fuse-0001-More-parentheses.patch
|
Patch1: fuse-0001-More-parentheses.patch
|
||||||
|
# https://bugzilla.redhat.com/show_bug.cgi?id=970768
|
||||||
|
Patch2: fuse-2.9.2-namespace-conflict-fix.patch
|
||||||
Requires: which
|
Requires: which
|
||||||
Conflicts: filesystem < 3
|
Conflicts: filesystem < 3
|
||||||
BuildRequires: libselinux-devel
|
BuildRequires: libselinux-devel
|
||||||
@ -49,6 +51,7 @@ pgk-config) to develop FUSE based applications/filesystems.
|
|||||||
#disable device creation during build/install
|
#disable device creation during build/install
|
||||||
sed -i 's|mknod|echo Disabled: mknod |g' util/Makefile.in
|
sed -i 's|mknod|echo Disabled: mknod |g' util/Makefile.in
|
||||||
%patch1 -p1 -b .add_parentheses
|
%patch1 -p1 -b .add_parentheses
|
||||||
|
%patch2 -p1 -b .conflictfix
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# Can't pass --disable-static here, or else the utils don't build
|
# Can't pass --disable-static here, or else the utils don't build
|
||||||
@ -100,6 +103,9 @@ rm -f %{buildroot}%{_sysconfdir}/udev/rules.d/99-fuse.rules
|
|||||||
%{_includedir}/fuse
|
%{_includedir}/fuse
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jun 26 2013 Tom Callaway <spot@fedoraproject.org> - 2.9.2-4
|
||||||
|
- add fix for namespace conflict in fuse_kernel.h
|
||||||
|
|
||||||
* Sat May 18 2013 Peter Lemenkov <lemenkov@gmail.com> - 2.9.2-3
|
* Sat May 18 2013 Peter Lemenkov <lemenkov@gmail.com> - 2.9.2-3
|
||||||
- Removed pre-F12 stuff
|
- Removed pre-F12 stuff
|
||||||
- Dropped ancient dependency on initscripts and chkconfig
|
- Dropped ancient dependency on initscripts and chkconfig
|
||||||
|
Loading…
Reference in New Issue
Block a user