3.1.1
This commit is contained in:
parent
83a6fc7ed5
commit
20640fd762
1
.gitignore
vendored
1
.gitignore
vendored
@ -10,3 +10,4 @@ fuse-2.8.4.tar.gz
|
||||
/fuse-3.0.0.tar.gz
|
||||
/fuse-3.0.2.tar.gz
|
||||
/fuse-3.1.0.tar.gz
|
||||
/fuse-3.1.1.tar.gz
|
||||
|
@ -1,20 +0,0 @@
|
||||
diff -up libfuse-fuse-3.1.0/example/passthrough_ll.c.revert libfuse-fuse-3.1.0/example/passthrough_ll.c
|
||||
--- libfuse-fuse-3.1.0/example/passthrough_ll.c.revert 2017-07-28 15:43:12.979509068 -0400
|
||||
+++ libfuse-fuse-3.1.0/example/passthrough_ll.c 2017-07-28 15:43:18.609373600 -0400
|
||||
@@ -51,6 +51,7 @@
|
||||
lo_dirp` elements as inodes. This means that we require uintptr_t
|
||||
and fuse_ino_t to have the same size. The following incantation
|
||||
defines a compile time assert for this requirement. */
|
||||
+/* Disable for now, check is not useful.
|
||||
#if defined(__GNUC__) && (__GNUC__ > 4 || __GNUC__ == 4 && __GNUC_MINOR__ >= 6) && !defined __cplusplus
|
||||
_Static_assert(sizeof(fuse_ino_t) == sizeof(uintptr_t), "fuse: off_t must be 64bit");
|
||||
#else
|
||||
@@ -58,7 +59,7 @@ struct _uintptr_to_must_hold_fuse_ino_t_
|
||||
{ unsigned _uintptr_to_must_hold_fuse_ino_t:
|
||||
((sizeof(fuse_ino_t) == sizeof(uintptr_t)) ? 1 : -1); };
|
||||
#endif
|
||||
-
|
||||
+*/
|
||||
|
||||
/* Compat stuff. Doesn't make it work, just makes it compile. */
|
||||
#ifndef HAVE_FSTATAT
|
12
fuse.spec
12
fuse.spec
@ -1,10 +1,10 @@
|
||||
%global fuse2ver 2.9.7
|
||||
%global fuse2sver 2
|
||||
%global fuse3ver 3.1.0
|
||||
%global fuse3ver 3.1.1
|
||||
|
||||
Name: fuse
|
||||
Version: %{fuse2ver}
|
||||
Release: 8%{?dist}
|
||||
Release: 9%{?dist}
|
||||
Summary: File System in Userspace (FUSE) v2 utilities
|
||||
License: GPL+
|
||||
URL: http://fuse.sf.net
|
||||
@ -18,8 +18,6 @@ Patch1: fuse-3.0.0-More-parentheses.patch
|
||||
Patch2: fuse-0001-More-parentheses.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=970768
|
||||
Patch3: fuse-2.9.2-namespace-conflict-fix.patch
|
||||
# https://github.com/libfuse/libfuse/issues/185
|
||||
Patch4: fuse-3.1.0-revert-size-check.patch
|
||||
|
||||
Requires: which
|
||||
Conflicts: filesystem < 3
|
||||
@ -109,7 +107,6 @@ pushd lib%{name}-%{name}-%{fuse3ver}
|
||||
#disable device creation during build/install
|
||||
sed -i 's|mknod|echo Disabled: mknod |g' util/Makefile.in
|
||||
%patch1 -p1 -b .add_parentheses
|
||||
%patch4 -p1 -b .revert
|
||||
popd
|
||||
|
||||
# fuse 2
|
||||
@ -126,7 +123,7 @@ popd
|
||||
pushd lib%{name}-%{name}-%{fuse3ver}
|
||||
# Can't pass --disable-static here, or else the utils don't build
|
||||
export MOUNT_FUSE_PATH="%{_sbindir}"
|
||||
CFLAGS="%{optflags} -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64" %configure
|
||||
CFLAGS="%{optflags} -D_GNU_SOURCE" %configure
|
||||
make %{?_smp_mflags} V=1
|
||||
popd
|
||||
|
||||
@ -229,6 +226,9 @@ rm -f %{buildroot}%{_libdir}/udev/rules.d/99-fuse3.rules
|
||||
%{_includedir}/fuse3/
|
||||
|
||||
%changelog
|
||||
* Mon Aug 7 2017 Tom Callaway <spot@fedoraproject.org> 2.9.7-9
|
||||
- update fuse3 to 3.1.1
|
||||
|
||||
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.9.7-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (fuse-2.9.7.tar.gz) = 960a576352663cfb730abd0020103c45f6fd8873d08ca40565a61421a7a80c110b31e88db5f45fc7e3d5e8b7a16a9e973483eda42c58c430dfb0599bc952800b
|
||||
SHA512 (fuse-3.1.0.tar.gz) = 498aefd5abf6f1c0a59b3ce8e53784c26eaa02cc06708f4a428ad11c4ad90a6ee9a55e5bde987f3dd2e83c97545ac1971cec0843297059a941a23b2acf17b239
|
||||
SHA512 (fuse-3.1.1.tar.gz) = 98424604f2ae3d3d0bf0c74612f2e7a1b87c3c2c96050f3ca08f5d33ab6a400301f3df79020ea8a865d9d35dd975e53f4c04712dc44649c570065849a1bb1e74
|
||||
|
Loading…
Reference in New Issue
Block a user