Extend the input line buffer and the argument storage buffer
This commit is contained in:
parent
071db6a8d9
commit
a93372c814
7
ftp.spec
7
ftp.spec
@ -1,7 +1,7 @@
|
||||
Summary: The standard UNIX FTP (File Transfer Protocol) client
|
||||
Name: ftp
|
||||
Version: 0.17
|
||||
Release: 57%{?dist}
|
||||
Release: 58%{?dist}
|
||||
License: BSD with advertising
|
||||
Group: Applications/Internet
|
||||
Source0: ftp://ftp.linux.org.uk/pub/linux/Networking/netkit/netkit-ftp-%{version}.tar.gz
|
||||
@ -34,6 +34,7 @@ Patch25: netkit-ftp-0.17-chkmalloc.patch
|
||||
Patch26: netkit-ftp-0.17-man.patch
|
||||
Patch27: netkit-ftp-0.17-acct_ovl.patch
|
||||
Patch28: netkit-ftp-0.17-remove-nested-include.patch
|
||||
Patch29: netkit-ftp-0.17-linelen.patch
|
||||
|
||||
BuildRequires: glibc-devel, readline-devel, ncurses-devel
|
||||
|
||||
@ -75,6 +76,7 @@ file transfers.
|
||||
%patch26 -p1 -b .man
|
||||
%patch27 -p1 -b .acct_ovl
|
||||
%patch28 -p1
|
||||
%patch29 -p1 -b .linelen
|
||||
|
||||
%build
|
||||
sh configure --with-c-compiler=gcc --enable-ipv6
|
||||
@ -107,6 +109,9 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%{_mandir}/man5/netrc.*
|
||||
|
||||
%changelog
|
||||
* Fri Aug 03 2012 Jan Synáček <jsynacek@redhat.com> - 0.17-58
|
||||
- Extend the input line buffer and the argument storage buffer
|
||||
|
||||
* Fri Jul 20 2012 Jan Synáček <jsynacek@redhat.com> - 0.17-57
|
||||
- Remove nested include (fix compilation in rawhide)
|
||||
|
||||
|
22
netkit-ftp-0.17-linelen.patch
Normal file
22
netkit-ftp-0.17-linelen.patch
Normal file
@ -0,0 +1,22 @@
|
||||
--- netkit-ftp-0.17-dist/ftp/ftp_var.h 2012-08-01 14:25:10.627248809 +0200
|
||||
+++ netkit-ftp-0.17-new/ftp/ftp_var.h 2012-08-01 14:29:51.756774406 +0200
|
||||
@@ -42,6 +42,7 @@
|
||||
|
||||
#include <setjmp.h>
|
||||
#include <sys/param.h>
|
||||
+#include <limits.h>
|
||||
#define NTRANS_MAX 64
|
||||
|
||||
/*
|
||||
@@ -108,9 +109,9 @@ Extern int ftp_port; /* htons'd port num
|
||||
|
||||
Extern sigjmp_buf toplevel; /* non-local goto stuff for cmd scanner */
|
||||
|
||||
-Extern char line[200]; /* input line buffer */
|
||||
+Extern char line[PATH_MAX + 200]; /* input line buffer */
|
||||
Extern char *stringbase; /* current scan point in line buffer */
|
||||
-Extern char argbuf[200]; /* argument storage buffer */
|
||||
+Extern char argbuf[PATH_MAX + 200]; /* argument storage buffer */
|
||||
Extern char *argbase; /* current storage point in arg buffer */
|
||||
Extern int cpend; /* flag: if != 0, then pending server reply */
|
||||
Extern int mflag; /* flag: if != 0, then active multi command */
|
Loading…
Reference in New Issue
Block a user