- changed bitrate from 1e+03 KBytes/sec to 1000 kBytes/sec
- Resolves: rhbz#430457
This commit is contained in:
parent
59d2027bf0
commit
9ff9fdd15e
8
ftp.spec
8
ftp.spec
@ -1,7 +1,7 @@
|
||||
Summary: The standard UNIX FTP (File Transfer Protocol) client
|
||||
Name: ftp
|
||||
Version: 0.17
|
||||
Release: 44%{?dist}
|
||||
Release: 45%{?dist}
|
||||
License: BSD with advertising
|
||||
Group: Applications/Internet
|
||||
Source0: ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/netkit-ftp-%{version}.tar.gz
|
||||
@ -27,6 +27,7 @@ Patch18: netkit-ftp-0.17-sigseg.patch
|
||||
Patch19: netkit-ftp-0.17-size.patch
|
||||
Patch20: netkit-ftp-0.17-fdleak.patch
|
||||
Patch21: netkit-ftp-0.17-fprintf.patch
|
||||
Patch22: netkit-ftp-0.17-bitrate.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: glibc-devel, readline-devel, ncurses-devel
|
||||
@ -62,6 +63,7 @@ file transfers.
|
||||
%patch19 -p1 -b .size
|
||||
%patch20 -p1 -b .fdleak
|
||||
%patch21 -p1 -b .fprintf
|
||||
%patch22 -p1 -b .bitrate
|
||||
|
||||
%build
|
||||
sh configure --with-c-compiler=gcc --enable-ipv6
|
||||
@ -95,6 +97,10 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%{_mandir}/man5/netrc.*
|
||||
|
||||
%changelog
|
||||
* Mon Jan 28 2008 Marcela Maslanova <mmaslano@redhat.com> - 0.17-45
|
||||
- changed bitrate from 1e+03 KBytes/sec to 1000 kBytes/sec
|
||||
- Resolves: rhbz#430457
|
||||
|
||||
* Thu Nov 15 2007 Marcela Maslanova <mmaslano@redhat.com> - 0.17-44
|
||||
- using fprintf instead of printf
|
||||
|
||||
|
14
netkit-ftp-0.17-bitrate.patch
Normal file
14
netkit-ftp-0.17-bitrate.patch
Normal file
@ -0,0 +1,14 @@
|
||||
diff -up netkit-ftp-0.17/ftp/ftp.c.old netkit-ftp-0.17/ftp/ftp.c
|
||||
--- netkit-ftp-0.17/ftp/ftp.c.old 2008-01-28 10:23:17.000000000 +0100
|
||||
+++ netkit-ftp-0.17/ftp/ftp.c 2008-01-28 10:32:01.000000000 +0100
|
||||
@@ -1609,8 +1609,8 @@ ptransfer(const char *direction, long lo
|
||||
s = td.tv_sec + (td.tv_usec / 1000000.);
|
||||
#define nz(x) ((x) == 0 ? 1 : (x))
|
||||
bs = bytes / nz(s);
|
||||
- printf("%lld bytes %s in %.3g secs (%.2g Kbytes/sec)\n",
|
||||
- bytes, direction, s, bs / 1024.0);
|
||||
+ printf("%lld bytes %s in %.3g secs (%.2f Kbytes/sec)\n",
|
||||
+ bytes, direction, s, bs / 1000.0);
|
||||
}
|
||||
}
|
||||
|
Loading…
Reference in New Issue
Block a user