- Call setlocale() so that readline works correctly (bug #142265).
This commit is contained in:
parent
0c3ef1e881
commit
77f41c212d
5
ftp.spec
5
ftp.spec
@ -11,6 +11,7 @@ Patch3: netkit-ftp.usagi-ipv6.patch
|
||||
Patch4: netkit-ftp-0.17-segv.patch
|
||||
Patch5: netkit-ftp-0.17-volatile.patch
|
||||
Patch6: netkit-ftp-0.17-runique_mget.patch
|
||||
Patch7: netkit-ftp-locale.patch
|
||||
BuildRoot: /var/tmp/%{name}-root
|
||||
BuildRequires: gcc, glibc-devel, readline-devel, ncurses-devel, perl
|
||||
|
||||
@ -30,6 +31,7 @@ file transfers.
|
||||
%patch4 -p1 -b .segv
|
||||
%patch5 -p1 -b .volatile
|
||||
%patch6 -p1 -b .runique_mget
|
||||
%patch7 -p1 -b .locale
|
||||
|
||||
%build
|
||||
sh configure --with-c-compiler=gcc --enable-ipv6
|
||||
@ -63,6 +65,9 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%{_mandir}/man5/netrc.*
|
||||
|
||||
%changelog
|
||||
* Wed Dec 15 2004 Tim Waugh <twaugh@redhat.com>
|
||||
- Call setlocale() so that readline works correctly (bug #142265).
|
||||
|
||||
* Tue Dec 7 2004 Thomas Woerner <twoerner@redhat.com> 0.17-23
|
||||
- fixed mget with runique (#79367)
|
||||
|
||||
|
18
netkit-ftp-locale.patch
Normal file
18
netkit-ftp-locale.patch
Normal file
@ -0,0 +1,18 @@
|
||||
--- netkit-ftp-0.17/ftp/main.c.locale 2004-12-15 16:52:14.504193752 +0000
|
||||
+++ netkit-ftp-0.17/ftp/main.c 2004-12-15 16:52:51.719133655 +0000
|
||||
@@ -51,6 +51,7 @@
|
||||
|
||||
/* #include <arpa/ftp.h> <--- unused? */
|
||||
|
||||
+#include <locale.h>
|
||||
#include <signal.h>
|
||||
#include <unistd.h>
|
||||
#include <string.h>
|
||||
@@ -109,6 +110,7 @@
|
||||
|
||||
tick = 0;
|
||||
|
||||
+ setlocale (LC_ALL, "");
|
||||
sp = getservbyname("ftp", "tcp");
|
||||
if (sp == 0) {
|
||||
fprintf(stderr, "ftp: ftp/tcp: unknown service\n");
|
Loading…
Reference in New Issue
Block a user