Comments/hints for C-Frame 121.
This commit is contained in:
parent
7a3d5f4c08
commit
2f28aa5eb3
10
ftp.spec
10
ftp.spec
@ -1,7 +1,7 @@
|
||||
Summary: The standard UNIX FTP (File Transfer Protocol) client.
|
||||
Name: ftp
|
||||
Version: 0.17
|
||||
Release: 29
|
||||
Release: 30
|
||||
License: BSD
|
||||
Group: Applications/Internet
|
||||
Source0: ftp://ftp.uk.linux.org/pub/linux/Networking/netkit-devel/netkit-ftp-%{version}.tar.bz2
|
||||
@ -15,6 +15,7 @@ Patch7: netkit-ftp-locale.patch
|
||||
Patch8: netkit-ftp-0.17-printf.patch
|
||||
Patch9: netkit-ftp-0.17-longint.patch
|
||||
Patch10: netkit-ftp-0.17-vsftp165083.patch
|
||||
Patch11: netkit-ftp-0.17-C-Frame121.patch
|
||||
BuildRoot: /var/tmp/%{name}-root
|
||||
BuildRequires: gcc, glibc-devel, readline-devel, ncurses-devel, perl
|
||||
|
||||
@ -38,6 +39,7 @@ file transfers.
|
||||
%patch8 -p1 -b .printf
|
||||
%patch9 -p1 -b .longint
|
||||
%patch10 -p1 -b .vsftp165083
|
||||
%patch11 -p1 -b .C-Frame121
|
||||
|
||||
%build
|
||||
sh configure --with-c-compiler=gcc --enable-ipv6
|
||||
@ -71,7 +73,13 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%{_mandir}/man5/netrc.*
|
||||
|
||||
%changelog
|
||||
* Wed Oct 26 2005 Petr Raszyk <praszyk@redhat.com> - 0.17-30
|
||||
- The patch netkit-ftp-0.17-C-Frame121.patch adds some
|
||||
comments/hints for C-Frame 121. It can be removed any time.
|
||||
|
||||
* Tue Aug 30 2005 Petr Raszyk <praszyk@redhat.com> - 0.17-29
|
||||
- rebuild
|
||||
|
||||
* Tue Aug 30 2005 Petr Raszyk <praszyk@redhat.com> - 0.17-28
|
||||
- This 'hack' will avoid a bug in ftp-server
|
||||
( < vsftpd-2.0.1-5 ). See #165083 (server prints the
|
||||
|
25
netkit-ftp-0.17-C-Frame121.patch
Normal file
25
netkit-ftp-0.17-C-Frame121.patch
Normal file
@ -0,0 +1,25 @@
|
||||
--- netkit-ftp-0.17/ftp/ftp.c.rasold 2005-10-26 16:56:09.000000000 +0200
|
||||
+++ netkit-ftp-0.17/ftp/ftp.c 2005-10-26 16:56:46.000000000 +0200
|
||||
@@ -1253,14 +1253,14 @@
|
||||
switch (data_addr.su_family) {
|
||||
case AF_INET:
|
||||
#if 0
|
||||
- if (try_epsv) {
|
||||
- result = command(pasvcmd = "EPSV 1");
|
||||
- if (code / 10 == 22 && code != 229) {
|
||||
- fprintf(stderr,
|
||||
- "wrong server: return code must be 229\n");
|
||||
- result = COMPLETE + 1;
|
||||
- }
|
||||
- } else {
|
||||
+/*@*/ if (try_epsv) {
|
||||
+/*@*/ result = command(pasvcmd = "EPSV 1");
|
||||
+/*@*/ if (code / 10 == 22 && code != 229) {
|
||||
+/*@*/ fprintf(stderr,
|
||||
+/*@*/ "wrong server: return code must be 229\n");
|
||||
+/*@*/ result = COMPLETE + 1;
|
||||
+/*@*/ }
|
||||
+/*@*/ } else {
|
||||
#endif
|
||||
result = COMPLETE + 1;
|
||||
|
Loading…
Reference in New Issue
Block a user