[tw] - fixed mget with runique (#79367)
This commit is contained in:
parent
7ef7941cc3
commit
0c3ef1e881
7
ftp.spec
7
ftp.spec
@ -1,7 +1,7 @@
|
||||
Summary: The standard UNIX FTP (File Transfer Protocol) client.
|
||||
Name: ftp
|
||||
Version: 0.17
|
||||
Release: 22
|
||||
Release: 23
|
||||
License: BSD
|
||||
Group: Applications/Internet
|
||||
Source0: ftp://ftp.uk.linux.org/pub/linux/Networking/netkit-devel/netkit-ftp-%{version}.tar.bz2
|
||||
@ -10,6 +10,7 @@ Patch2: netkit-ftp-0.17-acct.patch
|
||||
Patch3: netkit-ftp.usagi-ipv6.patch
|
||||
Patch4: netkit-ftp-0.17-segv.patch
|
||||
Patch5: netkit-ftp-0.17-volatile.patch
|
||||
Patch6: netkit-ftp-0.17-runique_mget.patch
|
||||
BuildRoot: /var/tmp/%{name}-root
|
||||
BuildRequires: gcc, glibc-devel, readline-devel, ncurses-devel, perl
|
||||
|
||||
@ -28,6 +29,7 @@ file transfers.
|
||||
%patch3 -p1 -b .ipv6
|
||||
%patch4 -p1 -b .segv
|
||||
%patch5 -p1 -b .volatile
|
||||
%patch6 -p1 -b .runique_mget
|
||||
|
||||
%build
|
||||
sh configure --with-c-compiler=gcc --enable-ipv6
|
||||
@ -61,6 +63,9 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%{_mandir}/man5/netrc.*
|
||||
|
||||
%changelog
|
||||
* Tue Dec 7 2004 Thomas Woerner <twoerner@redhat.com> 0.17-23
|
||||
- fixed mget with runique (#79367)
|
||||
|
||||
* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
|
13
netkit-ftp-0.17-runique_mget.patch
Normal file
13
netkit-ftp-0.17-runique_mget.patch
Normal file
@ -0,0 +1,13 @@
|
||||
--- netkit-ftp-0.17/ftp/ftp.c.runique_mget 2004-12-07 12:05:49.360133092 +0100
|
||||
+++ netkit-ftp-0.17/ftp/ftp.c 2004-12-07 12:06:48.480883902 +0100
|
||||
@@ -923,7 +923,9 @@
|
||||
return;
|
||||
}
|
||||
}
|
||||
- else if (runique && (local = gunique(local)) == NULL) {
|
||||
+ else if (runique && (strcmp(cmd, "NLST") != 0) &&
|
||||
+ (local = gunique(local)) == NULL)
|
||||
+ {
|
||||
(void) signal(SIGINT, oldintr);
|
||||
code = -1;
|
||||
return;
|
Loading…
Reference in New Issue
Block a user