New version 7.5.1
Enabling grpc, adding hostname for post scriptlet Moving files to libexec due to selinux issues
This commit is contained in:
parent
1cc2fcd604
commit
c0bc1c720a
1
.gitignore
vendored
1
.gitignore
vendored
@ -5,3 +5,4 @@
|
|||||||
/frr-7.3.1.tar.gz
|
/frr-7.3.1.tar.gz
|
||||||
/frr-7.4.tar.gz
|
/frr-7.4.tar.gz
|
||||||
/frr-7.5.tar.gz
|
/frr-7.5.tar.gz
|
||||||
|
/frr-7.5.1.tar.gz
|
||||||
|
17
0006-move-to-libexec.patch
Normal file
17
0006-move-to-libexec.patch
Normal file
@ -0,0 +1,17 @@
|
|||||||
|
diff --git a/tools/frr.service b/tools/frr.service
|
||||||
|
index aa45f42..402def8 100644
|
||||||
|
--- a/tools/frr.service
|
||||||
|
+++ b/tools/frr.service
|
||||||
|
@@ -17,9 +17,9 @@ WatchdogSec=60s
|
||||||
|
RestartSec=5
|
||||||
|
Restart=on-abnormal
|
||||||
|
LimitNOFILE=1024
|
||||||
|
-ExecStart=/usr/lib/frr/frrinit.sh start
|
||||||
|
-ExecStop=/usr/lib/frr/frrinit.sh stop
|
||||||
|
-ExecReload=/usr/lib/frr/frrinit.sh reload
|
||||||
|
+ExecStart=/usr/libexec/frr/frrinit.sh start
|
||||||
|
+ExecStop=/usr/libexec/frr/frrinit.sh stop
|
||||||
|
+ExecReload=/usr/libexec/frr/frrinit.sh reload
|
||||||
|
|
||||||
|
[Install]
|
||||||
|
WantedBy=multi-user.target
|
34
frr.spec
34
frr.spec
@ -1,19 +1,19 @@
|
|||||||
%global frrversion 7.5
|
%global frrversion 7.5.1
|
||||||
%global frr_libdir /usr/lib/frr
|
%global frr_libdir /usr/libexec/frr
|
||||||
|
|
||||||
%global _hardened_build 1
|
%global _hardened_build 1
|
||||||
%define _legacy_common_support 1
|
%define _legacy_common_support 1
|
||||||
|
|
||||||
Name: frr
|
Name: frr
|
||||||
Version: 7.5
|
Version: 7.5.1
|
||||||
Release: 4%{?checkout}%{?dist}
|
Release: 1%{?checkout}%{?dist}
|
||||||
Summary: Routing daemon
|
Summary: Routing daemon
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: http://www.frrouting.org
|
URL: http://www.frrouting.org
|
||||||
Source0: https://github.com/FRRouting/frr/releases/download/%{name}-%{frrversion}/%{name}-%{frrversion}.tar.gz
|
Source0: https://github.com/FRRouting/frr/releases/download/%{name}-%{frrversion}/%{name}-%{frrversion}.tar.gz
|
||||||
Source1: %{name}-tmpfiles.conf
|
Source1: %{name}-tmpfiles.conf
|
||||||
BuildRequires: perl-generators
|
BuildRequires: perl-generators
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc gcc-c++
|
||||||
BuildRequires: net-snmp-devel
|
BuildRequires: net-snmp-devel
|
||||||
BuildRequires: texinfo libcap-devel autoconf automake libtool patch groff
|
BuildRequires: texinfo libcap-devel autoconf automake libtool patch groff
|
||||||
BuildRequires: readline readline-devel ncurses ncurses-devel
|
BuildRequires: readline readline-devel ncurses ncurses-devel
|
||||||
@ -23,8 +23,10 @@ BuildRequires: python3-devel python3-sphinx python3-pytest
|
|||||||
BuildRequires: systemd systemd-devel
|
BuildRequires: systemd systemd-devel
|
||||||
BuildRequires: libyang-devel >= 0.16.74
|
BuildRequires: libyang-devel >= 0.16.74
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
|
BuildRequires: grpc-devel grpc-plugins
|
||||||
Requires: net-snmp ncurses
|
Requires: net-snmp ncurses
|
||||||
Requires(post): systemd /sbin/install-info
|
Requires(post): systemd /sbin/install-info
|
||||||
|
Requires(post): hostname
|
||||||
Requires(preun): systemd /sbin/install-info
|
Requires(preun): systemd /sbin/install-info
|
||||||
Requires(postun): systemd
|
Requires(postun): systemd
|
||||||
Provides: routingdaemon = %{version}-%{release}
|
Provides: routingdaemon = %{version}-%{release}
|
||||||
@ -36,6 +38,7 @@ Patch0002: 0002-enable-openssl.patch
|
|||||||
Patch0003: 0003-disable-eigrp-crypto.patch
|
Patch0003: 0003-disable-eigrp-crypto.patch
|
||||||
Patch0004: 0004-fips-mode.patch
|
Patch0004: 0004-fips-mode.patch
|
||||||
Patch0005: 0005-icc-options.patch
|
Patch0005: 0005-icc-options.patch
|
||||||
|
Patch0006: 0006-move-to-libexec.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
FRRouting is free software that manages TCP/IP based routing protocols. It takes
|
FRRouting is free software that manages TCP/IP based routing protocols. It takes
|
||||||
@ -74,7 +77,8 @@ autoreconf -ivf
|
|||||||
--disable-babeld \
|
--disable-babeld \
|
||||||
--with-moduledir=%{_libdir}/frr/modules \
|
--with-moduledir=%{_libdir}/frr/modules \
|
||||||
--with-crypto=openssl \
|
--with-crypto=openssl \
|
||||||
--enable-fpm
|
--enable-fpm \
|
||||||
|
--enable-grpc
|
||||||
|
|
||||||
%make_build MAKEINFO="makeinfo --no-split" PYTHON=%{__python3}
|
%make_build MAKEINFO="makeinfo --no-split" PYTHON=%{__python3}
|
||||||
|
|
||||||
@ -134,6 +138,13 @@ if [ ! -e %{_sysconfdir}/frr/frr.conf ]; then
|
|||||||
chmod 640 %{_sysconfdir}/frr/frr.conf
|
chmod 640 %{_sysconfdir}/frr/frr.conf
|
||||||
fi
|
fi
|
||||||
|
|
||||||
|
#still used by vtysh, this way no error is produced when using vtysh
|
||||||
|
if [ ! -e %{_sysconfdir}/frr/vtysh.conf ]; then
|
||||||
|
echo 'no service integrated-vtysh-config' > %{_sysconfdir}/frr/vtysh.conf
|
||||||
|
chmod 640 %{_sysconfdir}/frr/vtysh.conf
|
||||||
|
chown frr:frrvty %{_sysconfdir}/frr/vtysh.conf
|
||||||
|
fi
|
||||||
|
|
||||||
%postun
|
%postun
|
||||||
%systemd_postun_with_restart frr.service
|
%systemd_postun_with_restart frr.service
|
||||||
|
|
||||||
@ -183,6 +194,11 @@ make check PYTHON=%{__python3}
|
|||||||
%{_tmpfilesdir}/%{name}.conf
|
%{_tmpfilesdir}/%{name}.conf
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Mar 12 2021 Michal Ruprich <mruprich@redhat.com> - 7.5.1-1
|
||||||
|
- New version 7.5.1
|
||||||
|
- Enabling grpc, adding hostname for post scriptlet
|
||||||
|
- Moving files to libexec due to selinux issues
|
||||||
|
|
||||||
* Tue Mar 02 2021 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 7.5-4
|
* Tue Mar 02 2021 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 7.5-4
|
||||||
- Rebuilt for updated systemd-rpm-macros
|
- Rebuilt for updated systemd-rpm-macros
|
||||||
See https://pagure.io/fesco/issue/2583.
|
See https://pagure.io/fesco/issue/2583.
|
||||||
@ -205,14 +221,14 @@ make check PYTHON=%{__python3}
|
|||||||
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 7.3.1-3
|
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 7.3.1-3
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
* Thu Jun 18 2020 Michal Ruprich <michalruprich@gmail.com> - 7.3.1-1
|
* Thu Jun 18 2020 Michal Ruprich <mruprich@redhat.com> - 7.3.1-1
|
||||||
- New version 7.3.1
|
- New version 7.3.1
|
||||||
- Fixes a couple of bugs(#1832259, #1835039, #1830815, #1830808, #1830806, #1830800, #1830798, #1814773)
|
- Fixes a couple of bugs(#1832259, #1835039, #1830815, #1830808, #1830806, #1830800, #1830798, #1814773)
|
||||||
|
|
||||||
* Tue May 19 2020 Michal Ruprich <michalruprich@gmail.com> - 7.3-6
|
* Tue May 19 2020 Michal Ruprich <mruprich@redhat.com> - 7.3-6
|
||||||
- Removing texi2html, it is not available in Rawhide anymore
|
- Removing texi2html, it is not available in Rawhide anymore
|
||||||
|
|
||||||
* Mon May 18 2020 Michal Ruprich <michalruprich@gmail.com> - 7.3-5
|
* Mon May 18 2020 Michal Ruprich <mruprich@redhat.com> - 7.3-5
|
||||||
- Rebuild for new version of libyang
|
- Rebuild for new version of libyang
|
||||||
|
|
||||||
* Tue Apr 21 2020 Björn Esser <besser82@fedoraproject.org> - 7.3-4
|
* Tue Apr 21 2020 Björn Esser <besser82@fedoraproject.org> - 7.3-4
|
||||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (frr-7.5.tar.gz) = bfa47d901550aff6dae15ee73802f7d43809227767a2e4c1e5b3dd569320f6e9adcc8bdb4ff319266e606f087851ede5e3c606926777509d2425677bef2b7e9c
|
SHA512 (frr-7.5.1.tar.gz) = 1c27420594e52647090da3556e5c62d6f916903c4fa86e5110f1e86152f07d3ce4252bc859d36c9d218dc96a80b245c8b9eee97f370d818cb39be187b6c3546e
|
||||||
SHA512 (remove-babeld-ldpd.sh) = a5bf67a3722cb20d43cef1dac28f839db68df73a1b7d34d8438e4f9366da3b67d85c1f44281f93434e8dd8ebcb2d3dc258b77eaa5627475b7395d207f020839d
|
SHA512 (remove-babeld-ldpd.sh) = a5bf67a3722cb20d43cef1dac28f839db68df73a1b7d34d8438e4f9366da3b67d85c1f44281f93434e8dd8ebcb2d3dc258b77eaa5627475b7395d207f020839d
|
||||||
|
Loading…
Reference in New Issue
Block a user