New version 8.3.1
This commit is contained in:
parent
b2c9845f51
commit
6e63bc125e
25
0006-ospf-api.patch
Normal file
25
0006-ospf-api.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
diff --git a/ospfd/ospf_spf.c b/ospfd/ospf_spf.c
|
||||||
|
index 74a5674..aec9037 100644
|
||||||
|
--- a/ospfd/ospf_spf.c
|
||||||
|
+++ b/ospfd/ospf_spf.c
|
||||||
|
@@ -48,7 +48,10 @@
|
||||||
|
#include "ospfd/ospf_sr.h"
|
||||||
|
#include "ospfd/ospf_ti_lfa.h"
|
||||||
|
#include "ospfd/ospf_errors.h"
|
||||||
|
+
|
||||||
|
+#ifdef SUPPORT_OSPF_API
|
||||||
|
#include "ospfd/ospf_apiserver.h"
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
/* Variables to ensure a SPF scheduled log message is printed only once */
|
||||||
|
|
||||||
|
@@ -1897,7 +1900,9 @@ static void ospf_spf_calculate_schedule_worker(struct thread *thread)
|
||||||
|
/* Update all routers routing table */
|
||||||
|
ospf->oall_rtrs = ospf->all_rtrs;
|
||||||
|
ospf->all_rtrs = all_rtrs;
|
||||||
|
+#ifdef SUPPORT_OSPF_API
|
||||||
|
ospf_apiserver_notify_reachable(ospf->oall_rtrs, ospf->all_rtrs);
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
/* Free old ABR/ASBR routing table */
|
||||||
|
if (ospf->old_rtrs)
|
9
frr.spec
9
frr.spec
@ -6,8 +6,8 @@
|
|||||||
%bcond_without selinux
|
%bcond_without selinux
|
||||||
|
|
||||||
Name: frr
|
Name: frr
|
||||||
Version: 8.2.2
|
Version: 8.3.1
|
||||||
Release: 10%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Routing daemon
|
Summary: Routing daemon
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: http://www.frrouting.org
|
URL: http://www.frrouting.org
|
||||||
@ -24,7 +24,7 @@ Patch0002: 0002-enable-openssl.patch
|
|||||||
Patch0003: 0003-disable-eigrp-crypto.patch
|
Patch0003: 0003-disable-eigrp-crypto.patch
|
||||||
Patch0004: 0004-fips-mode.patch
|
Patch0004: 0004-fips-mode.patch
|
||||||
Patch0005: 0005-remove-grpc-test.patch
|
Patch0005: 0005-remove-grpc-test.patch
|
||||||
Patch0006: 0006-cve-2022-26126.patch
|
Patch0006: 0006-ospf-api.patch
|
||||||
|
|
||||||
BuildRequires: autoconf
|
BuildRequires: autoconf
|
||||||
BuildRequires: automake
|
BuildRequires: automake
|
||||||
@ -259,6 +259,9 @@ rm tests/lib/*grpc*
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Sep 06 2022 Michal Ruprich <mruprich@redhat.com> - 8.3.1-1
|
||||||
|
- New version 8.3.1
|
||||||
|
|
||||||
* Mon Aug 22 2022 Michal Ruprich <mruprich@redhat.com> - 8.2.2-10
|
* Mon Aug 22 2022 Michal Ruprich <mruprich@redhat.com> - 8.2.2-10
|
||||||
- Rebuilding for new abseil-cpp and grpc updates
|
- Rebuilding for new abseil-cpp and grpc updates
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user