New version 8.4
This commit is contained in:
parent
3905b5274d
commit
5301cdd961
1
.gitignore
vendored
1
.gitignore
vendored
@ -11,3 +11,4 @@
|
||||
/frr-8.2.tar.gz
|
||||
/frr-8.2.2.tar.gz
|
||||
/frr-8.3.1.tar.gz
|
||||
/frr-8.4.tar.gz
|
||||
|
@ -27,3 +27,29 @@ index 5be3264..33abc1d 100644
|
||||
lib/Makefile \
|
||||
nhrpd/Makefile \
|
||||
ospf6d/Makefile \
|
||||
diff --git a/tools/etc/frr/daemons b/tools/etc/frr/daemons
|
||||
index 8aa0887..c92dcca 100644
|
||||
--- a/tools/etc/frr/daemons
|
||||
+++ b/tools/etc/frr/daemons
|
||||
@@ -22,10 +22,8 @@ ripngd=no
|
||||
isisd=no
|
||||
pimd=no
|
||||
pim6d=no
|
||||
-ldpd=no
|
||||
nhrpd=no
|
||||
eigrpd=no
|
||||
-babeld=no
|
||||
sharpd=no
|
||||
pbrd=no
|
||||
bfdd=no
|
||||
@@ -48,10 +46,8 @@ ripngd_options=" -A ::1"
|
||||
isisd_options=" -A 127.0.0.1"
|
||||
pimd_options=" -A 127.0.0.1"
|
||||
pim6d_options=" -A ::1"
|
||||
-ldpd_options=" -A 127.0.0.1"
|
||||
nhrpd_options=" -A 127.0.0.1"
|
||||
eigrpd_options=" -A 127.0.0.1"
|
||||
-babeld_options=" -A 127.0.0.1"
|
||||
sharpd_options=" -A 127.0.0.1"
|
||||
pbrd_options=" -A 127.0.0.1"
|
||||
staticd_options="-A 127.0.0.1"
|
||||
|
@ -1,25 +0,0 @@
|
||||
diff --git a/ospfd/ospf_spf.c b/ospfd/ospf_spf.c
|
||||
index 74a5674..aec9037 100644
|
||||
--- a/ospfd/ospf_spf.c
|
||||
+++ b/ospfd/ospf_spf.c
|
||||
@@ -48,7 +48,10 @@
|
||||
#include "ospfd/ospf_sr.h"
|
||||
#include "ospfd/ospf_ti_lfa.h"
|
||||
#include "ospfd/ospf_errors.h"
|
||||
+
|
||||
+#ifdef SUPPORT_OSPF_API
|
||||
#include "ospfd/ospf_apiserver.h"
|
||||
+#endif
|
||||
|
||||
/* Variables to ensure a SPF scheduled log message is printed only once */
|
||||
|
||||
@@ -1897,7 +1900,9 @@ static void ospf_spf_calculate_schedule_worker(struct thread *thread)
|
||||
/* Update all routers routing table */
|
||||
ospf->oall_rtrs = ospf->all_rtrs;
|
||||
ospf->all_rtrs = all_rtrs;
|
||||
+#ifdef SUPPORT_OSPF_API
|
||||
ospf_apiserver_notify_reachable(ospf->oall_rtrs, ospf->all_rtrs);
|
||||
+#endif
|
||||
|
||||
/* Free old ABR/ASBR routing table */
|
||||
if (ospf->old_rtrs)
|
16
frr.spec
16
frr.spec
@ -6,8 +6,8 @@
|
||||
%bcond_without selinux
|
||||
|
||||
Name: frr
|
||||
Version: 8.3.1
|
||||
Release: 5%{?dist}
|
||||
Version: 8.4
|
||||
Release: 1%{?dist}
|
||||
Summary: Routing daemon
|
||||
License: GPLv2+
|
||||
URL: http://www.frrouting.org
|
||||
@ -24,7 +24,6 @@ Patch0002: 0002-enable-openssl.patch
|
||||
Patch0003: 0003-disable-eigrp-crypto.patch
|
||||
Patch0004: 0004-fips-mode.patch
|
||||
Patch0005: 0005-remove-grpc-test.patch
|
||||
Patch0006: 0006-ospf-api.patch
|
||||
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: automake
|
||||
@ -239,10 +238,14 @@ rm tests/lib/*grpc*
|
||||
%dir %attr(755,frr,frr) %{_localstatedir}/log/frr
|
||||
%dir %attr(755,frr,frr) /run/frr
|
||||
%{_infodir}/*info*
|
||||
%{_mandir}/man*/*
|
||||
%{_mandir}/man1/frr.1*
|
||||
%{_mandir}/man1/vtysh.1*
|
||||
%{_mandir}/man8/frr-*.8*
|
||||
%{_mandir}/man8/mtracebis.8*
|
||||
%dir %{frr_libdir}/
|
||||
%{frr_libdir}/*
|
||||
%{_bindir}/*
|
||||
%{_bindir}/mtracebis
|
||||
%{_bindir}/vtysh
|
||||
%dir %{_libdir}/frr
|
||||
%{_libdir}/frr/*.so.*
|
||||
%dir %{_libdir}/frr/modules
|
||||
@ -264,6 +267,9 @@ rm tests/lib/*grpc*
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Nov 10 2022 Michal Ruprich <mruprich@redhat.com> - 8.4-1
|
||||
- New version 8.4
|
||||
|
||||
* Fri Sep 16 2022 Michal Ruprich <mruprich@redhat.com> - 8.3.1-5
|
||||
- Adding SELinux rule to enable zebra to write to sysctl_net_t
|
||||
- Adding SELinux rule to enable bgpd to call name_connect to bgp_port_t
|
||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (frr-8.3.1.tar.gz) = a15b53c98c9739f316663c723c35954284b63ffd49cf88e22d3ac82e66a4b63ffc5f43a8d622f531d129436464fdbfcf103b2866240762510ec490c03563a8ae
|
||||
SHA512 (frr-8.4.tar.gz) = ad24fd13dfb22957c05fdd72d0624ba3d5722d072e64366906aaa634cb70a4797ed0ebe22419199c32442e71638f33e8183daf6b46abb06e0d8d1bfc332d3bab
|
||||
SHA512 (remove-babeld-ldpd.sh) = a5bf67a3722cb20d43cef1dac28f839db68df73a1b7d34d8438e4f9366da3b67d85c1f44281f93434e8dd8ebcb2d3dc258b77eaa5627475b7395d207f020839d
|
||||
|
Loading…
Reference in New Issue
Block a user