Resolves: #2069571 - the dynamic routing setup does not work any more
This commit is contained in:
parent
5abdfe64e1
commit
503becfa12
30
0005-inactive-paths.patch
Normal file
30
0005-inactive-paths.patch
Normal file
@ -0,0 +1,30 @@
|
||||
diff --git a/lib/routemap.c b/lib/routemap.c
|
||||
index 7f733c811..9afe18d10 100644
|
||||
--- a/lib/routemap.c
|
||||
+++ b/lib/routemap.c
|
||||
@@ -1799,12 +1799,11 @@ static struct list *route_map_get_index_list(struct route_node **rn,
|
||||
/*
|
||||
* This function returns the route-map index that best matches the prefix.
|
||||
*/
|
||||
-static struct route_map_index *route_map_get_index(struct route_map *map,
|
||||
- const struct prefix *prefix,
|
||||
- void *object,
|
||||
- uint8_t *match_ret)
|
||||
+static struct route_map_index *
|
||||
+route_map_get_index(struct route_map *map, const struct prefix *prefix,
|
||||
+ void *object, enum route_map_cmd_result_t *match_ret)
|
||||
{
|
||||
- int ret = 0;
|
||||
+ enum route_map_cmd_result_t ret = RMAP_NOMATCH;
|
||||
struct list *candidate_rmap_list = NULL;
|
||||
struct route_node *rn = NULL;
|
||||
struct listnode *ln = NULL, *nn = NULL;
|
||||
@@ -2559,7 +2558,7 @@ route_map_result_t route_map_apply_ext(struct route_map *map,
|
||||
if ((!map->optimization_disabled)
|
||||
&& (map->ipv4_prefix_table || map->ipv6_prefix_table)) {
|
||||
index = route_map_get_index(map, prefix, match_object,
|
||||
- (uint8_t *)&match_ret);
|
||||
+ &match_ret);
|
||||
if (index) {
|
||||
index->applied++;
|
||||
if (rmap_debug)
|
6
frr.spec
6
frr.spec
@ -5,7 +5,7 @@
|
||||
|
||||
Name: frr
|
||||
Version: 8.2.2
|
||||
Release: 1%{?checkout}%{?dist}
|
||||
Release: 2%{?checkout}%{?dist}
|
||||
Summary: Routing daemon
|
||||
License: GPLv2+
|
||||
URL: http://www.frrouting.org
|
||||
@ -55,6 +55,7 @@ Patch0000: 0000-remove-babeld-and-ldpd.patch
|
||||
Patch0002: 0002-enable-openssl.patch
|
||||
Patch0003: 0003-disable-eigrp-crypto.patch
|
||||
Patch0004: 0004-fips-mode.patch
|
||||
Patch0005: 0005-inactive-paths.patch
|
||||
|
||||
%description
|
||||
FRRouting is free software that manages TCP/IP based routing protocols. It takes
|
||||
@ -206,6 +207,9 @@ make check PYTHON=%{__python3}
|
||||
%{_tmpfilesdir}/%{name}.conf
|
||||
|
||||
%changelog
|
||||
* Mon May 02 2022 Michal Ruprich <mruprich@redhat.com> - 8.2.2-2
|
||||
- Resolves: #2069571 - the dynamic routing setup does not work any more
|
||||
|
||||
* Mon May 02 2022 Michal Ruprich <mruprich@redhat.com> - 8.2.2-1
|
||||
- Resolves: #2069563 - Rebase frr to version 8.2.2
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user