Resolves: #1997603 - ospfd not running with ospf opaque-lsa option used
This commit is contained in:
parent
ca09ec9041
commit
47ef98cc1f
28
0007-ospf-opaque-lsa.patch
Normal file
28
0007-ospf-opaque-lsa.patch
Normal file
@ -0,0 +1,28 @@
|
|||||||
|
From 57e4c21583a9fa4c9d34fa8263930c3a1d5c6cd9 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Igor Ryzhov <iryzhov@nfware.com>
|
||||||
|
Date: Tue, 31 Aug 2021 13:41:40 +0300
|
||||||
|
Subject: [PATCH] ospfd: correctly cleanup spf data
|
||||||
|
|
||||||
|
ospf_spf_cleanup frees the data so we need to reset the stale pointers.
|
||||||
|
|
||||||
|
Fixes #9523.
|
||||||
|
|
||||||
|
Signed-off-by: Igor Ryzhov <iryzhov@nfware.com>
|
||||||
|
---
|
||||||
|
ospfd/ospf_spf.c | 3 +++
|
||||||
|
1 file changed, 3 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/ospfd/ospf_spf.c b/ospfd/ospf_spf.c
|
||||||
|
index 6a51440266e..8b4d55984c8 100644
|
||||||
|
--- a/ospfd/ospf_spf.c
|
||||||
|
+++ b/ospfd/ospf_spf.c
|
||||||
|
@@ -1781,6 +1781,9 @@ void ospf_spf_calculate_area(struct ospf *ospf, struct ospf_area *area,
|
||||||
|
ospf->ti_lfa_protection_type);
|
||||||
|
|
||||||
|
ospf_spf_cleanup(area->spf, area->spf_vertex_list);
|
||||||
|
+
|
||||||
|
+ area->spf = NULL;
|
||||||
|
+ area->spf_vertex_list = NULL;
|
||||||
|
}
|
||||||
|
|
||||||
|
void ospf_spf_calculate_areas(struct ospf *ospf, struct route_table *new_table,
|
6
frr.spec
6
frr.spec
@ -5,7 +5,7 @@
|
|||||||
|
|
||||||
Name: frr
|
Name: frr
|
||||||
Version: 8.0
|
Version: 8.0
|
||||||
Release: 3%{?checkout}%{?dist}
|
Release: 4%{?checkout}%{?dist}
|
||||||
Summary: Routing daemon
|
Summary: Routing daemon
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: http://www.frrouting.org
|
URL: http://www.frrouting.org
|
||||||
@ -59,6 +59,7 @@ Patch0005: 0005-use-python3.patch
|
|||||||
#Adding a patch from frr after rebase
|
#Adding a patch from frr after rebase
|
||||||
#We would have hit this surely later, better apply the patch now
|
#We would have hit this surely later, better apply the patch now
|
||||||
Patch0006: 0006-prefix-list-duplication.patch
|
Patch0006: 0006-prefix-list-duplication.patch
|
||||||
|
Patch0007: 0007-ospf-opaque-lsa.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
FRRouting is free software that manages TCP/IP based routing protocols. It takes
|
FRRouting is free software that manages TCP/IP based routing protocols. It takes
|
||||||
@ -210,6 +211,9 @@ make check PYTHON=%{__python3}
|
|||||||
%{_tmpfilesdir}/%{name}.conf
|
%{_tmpfilesdir}/%{name}.conf
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Sep 01 2021 Michal Ruprich <mruprich@redhat.com> - 8.0-4
|
||||||
|
- Resolves: #1997603 - ospfd not running with ospf opaque-lsa option used
|
||||||
|
|
||||||
* Mon Aug 16 2021 Michal Ruprich <mruprich@redhat.com> - 8.0-3
|
* Mon Aug 16 2021 Michal Ruprich <mruprich@redhat.com> - 8.0-3
|
||||||
- Related: #1990858 - Fixing prefix-list duplication check
|
- Related: #1990858 - Fixing prefix-list duplication check
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user