Merged update from upstream sources
This is an automated DistroBaker update from upstream sources. If you do not know what this is about or would like to opt out, contact the OSCI team. Source: https://src.fedoraproject.org/rpms/frr.git#81310f26e9988b48379157c4349c0b81ccd3422d
This commit is contained in:
parent
844d1329e5
commit
2ec326a573
1
.gitignore
vendored
1
.gitignore
vendored
@ -5,3 +5,4 @@
|
||||
/frr-7.3.1.tar.gz
|
||||
/frr-7.4.tar.gz
|
||||
/frr-7.5.tar.gz
|
||||
/frr-7.5.1.tar.gz
|
||||
|
17
0006-move-to-libexec.patch
Normal file
17
0006-move-to-libexec.patch
Normal file
@ -0,0 +1,17 @@
|
||||
diff --git a/tools/frr.service b/tools/frr.service
|
||||
index aa45f42..402def8 100644
|
||||
--- a/tools/frr.service
|
||||
+++ b/tools/frr.service
|
||||
@@ -17,9 +17,9 @@ WatchdogSec=60s
|
||||
RestartSec=5
|
||||
Restart=on-abnormal
|
||||
LimitNOFILE=1024
|
||||
-ExecStart=/usr/lib/frr/frrinit.sh start
|
||||
-ExecStop=/usr/lib/frr/frrinit.sh stop
|
||||
-ExecReload=/usr/lib/frr/frrinit.sh reload
|
||||
+ExecStart=/usr/libexec/frr/frrinit.sh start
|
||||
+ExecStop=/usr/libexec/frr/frrinit.sh stop
|
||||
+ExecReload=/usr/libexec/frr/frrinit.sh reload
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
36
frr.spec
36
frr.spec
@ -1,19 +1,19 @@
|
||||
%global frrversion 7.5
|
||||
%global frr_libdir /usr/lib/frr
|
||||
%global frrversion 7.5.1
|
||||
%global frr_libdir /usr/libexec/frr
|
||||
|
||||
%global _hardened_build 1
|
||||
%define _legacy_common_support 1
|
||||
|
||||
Name: frr
|
||||
Version: 7.5
|
||||
Release: 3%{?checkout}%{?dist}
|
||||
Version: 7.5.1
|
||||
Release: 1%{?checkout}%{?dist}
|
||||
Summary: Routing daemon
|
||||
License: GPLv2+
|
||||
URL: http://www.frrouting.org
|
||||
Source0: https://github.com/FRRouting/frr/releases/download/%{name}-%{frrversion}/%{name}-%{frrversion}.tar.gz
|
||||
Source1: %{name}-tmpfiles.conf
|
||||
BuildRequires: perl-generators
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc gcc-c++
|
||||
BuildRequires: net-snmp-devel
|
||||
BuildRequires: texinfo libcap-devel autoconf automake libtool patch groff
|
||||
BuildRequires: readline readline-devel ncurses ncurses-devel
|
||||
@ -23,8 +23,9 @@ BuildRequires: python3-devel python3-sphinx python3-pytest
|
||||
BuildRequires: systemd systemd-devel
|
||||
BuildRequires: libyang-devel >= 0.16.74
|
||||
BuildRequires: make
|
||||
BuildRequires: grpc-devel grpc-plugins
|
||||
Requires: net-snmp ncurses
|
||||
Requires(post): systemd /sbin/install-info
|
||||
Requires(post): systemd /sbin/install-info hostname
|
||||
Requires(preun): systemd /sbin/install-info
|
||||
Requires(postun): systemd
|
||||
Provides: routingdaemon = %{version}-%{release}
|
||||
@ -36,6 +37,7 @@ Patch0002: 0002-enable-openssl.patch
|
||||
Patch0003: 0003-disable-eigrp-crypto.patch
|
||||
Patch0004: 0004-fips-mode.patch
|
||||
Patch0005: 0005-icc-options.patch
|
||||
Patch0006: 0006-move-to-libexec.patch
|
||||
|
||||
%description
|
||||
FRRouting is free software that manages TCP/IP based routing protocols. It takes
|
||||
@ -74,7 +76,8 @@ autoreconf -ivf
|
||||
--disable-babeld \
|
||||
--with-moduledir=%{_libdir}/frr/modules \
|
||||
--with-crypto=openssl \
|
||||
--enable-fpm
|
||||
--enable-fpm \
|
||||
--enable-grpc
|
||||
|
||||
%make_build MAKEINFO="makeinfo --no-split" PYTHON=%{__python3}
|
||||
|
||||
@ -134,6 +137,14 @@ if [ ! -e %{_sysconfdir}/frr/frr.conf ]; then
|
||||
chmod 640 %{_sysconfdir}/frr/frr.conf
|
||||
fi
|
||||
|
||||
#still used by vtysh, this way no error is produced when using vtysh
|
||||
if [ ! -e %{_sysconfdir}/frr/vtysh.conf ]; then
|
||||
echo 'no service integrated-vtysh-config' > %{_sysconfdir}/frr/vtysh.conf
|
||||
chmod 640 %{_sysconfdir}/frr/vtysh.conf
|
||||
chown frr:frrvty %{_sysconfdir}/frr/vtysh.conf
|
||||
fi
|
||||
|
||||
|
||||
%postun
|
||||
%systemd_postun_with_restart frr.service
|
||||
|
||||
@ -183,6 +194,11 @@ make check PYTHON=%{__python3}
|
||||
%{_tmpfilesdir}/%{name}.conf
|
||||
|
||||
%changelog
|
||||
* Tue Mar 16 2021 Michal Ruprich <mruprich@redhat.com> - 7.5.1-1
|
||||
- New version 7.5.1
|
||||
- Enabling grpc, adding hostname for post scriptlet
|
||||
- Moving files to libexec due to selinux issues
|
||||
|
||||
* Tue Feb 16 2021 Michal Ruprich <mruprich@redhat.com> - 7.5-3
|
||||
- Fixing FTBS - icc options are confusing the new gcc
|
||||
|
||||
@ -201,14 +217,14 @@ make check PYTHON=%{__python3}
|
||||
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 7.3.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Thu Jun 18 2020 Michal Ruprich <michalruprich@gmail.com> - 7.3.1-1
|
||||
* Thu Jun 18 2020 Michal Ruprich <mruprich@redhat.com> - 7.3.1-1
|
||||
- New version 7.3.1
|
||||
- Fixes a couple of bugs(#1832259, #1835039, #1830815, #1830808, #1830806, #1830800, #1830798, #1814773)
|
||||
|
||||
* Tue May 19 2020 Michal Ruprich <michalruprich@gmail.com> - 7.3-6
|
||||
* Tue May 19 2020 Michal Ruprich <mruprich@redhat.com> - 7.3-6
|
||||
- Removing texi2html, it is not available in Rawhide anymore
|
||||
|
||||
* Mon May 18 2020 Michal Ruprich <michalruprich@gmail.com> - 7.3-5
|
||||
* Mon May 18 2020 Michal Ruprich <mruprich@redhat.com> - 7.3-5
|
||||
- Rebuild for new version of libyang
|
||||
|
||||
* Tue Apr 21 2020 Björn Esser <besser82@fedoraproject.org> - 7.3-4
|
||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (frr-7.5.tar.gz) = bfa47d901550aff6dae15ee73802f7d43809227767a2e4c1e5b3dd569320f6e9adcc8bdb4ff319266e606f087851ede5e3c606926777509d2425677bef2b7e9c
|
||||
SHA512 (frr-7.5.1.tar.gz) = 1c27420594e52647090da3556e5c62d6f916903c4fa86e5110f1e86152f07d3ce4252bc859d36c9d218dc96a80b245c8b9eee97f370d818cb39be187b6c3546e
|
||||
SHA512 (remove-babeld-ldpd.sh) = a5bf67a3722cb20d43cef1dac28f839db68df73a1b7d34d8438e4f9366da3b67d85c1f44281f93434e8dd8ebcb2d3dc258b77eaa5627475b7395d207f020839d
|
||||
|
Loading…
Reference in New Issue
Block a user