New version 7.3.1
Fixes a couple of bugs(#1832259, #1835039, #1830815, #1830808, #1830806, #1830800, #1830798, #1814773)
This commit is contained in:
parent
69f43ae016
commit
0d34206229
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@
|
||||
/frr-7.2.tar.gz
|
||||
/frr-7.3.tar.gz
|
||||
/remove-babeld-ldpd.sh
|
||||
/frr-7.3.1.tar.gz
|
||||
|
@ -1,31 +0,0 @@
|
||||
diff --git a/bgpd/bgp_route.c b/bgpd/bgp_route.c
|
||||
index 5f4486b80..da57ffa83 100644
|
||||
--- a/bgpd/bgp_route.c
|
||||
+++ b/bgpd/bgp_route.c
|
||||
@@ -9922,7 +9922,7 @@ static int bgp_show_route_in_table(struct vty *vty, struct bgp *bgp,
|
||||
}
|
||||
} else if (safi == SAFI_EVPN) {
|
||||
struct bgp_node *longest_pfx;
|
||||
- bool is_exact_pfxlen_match = FALSE;
|
||||
+ bool is_exact_pfxlen_match = false;
|
||||
|
||||
for (rn = bgp_table_top(rib); rn; rn = bgp_route_next(rn)) {
|
||||
if (prd && memcmp(rn->p.u.val, prd->val, 8) != 0)
|
||||
@@ -9932,7 +9932,7 @@ static int bgp_show_route_in_table(struct vty *vty, struct bgp *bgp,
|
||||
continue;
|
||||
|
||||
longest_pfx = NULL;
|
||||
- is_exact_pfxlen_match = FALSE;
|
||||
+ is_exact_pfxlen_match = false;
|
||||
/*
|
||||
* Search through all the prefixes for a match. The
|
||||
* pfx's are enumerated in ascending order of pfxlens.
|
||||
@@ -9951,7 +9951,7 @@ static int bgp_show_route_in_table(struct vty *vty, struct bgp *bgp,
|
||||
int type5_pfxlen =
|
||||
bgp_evpn_get_type5_prefixlen(&rm->p);
|
||||
if (type5_pfxlen == match.prefixlen) {
|
||||
- is_exact_pfxlen_match = TRUE;
|
||||
+ is_exact_pfxlen_match = true;
|
||||
bgp_unlock_node(rm);
|
||||
break;
|
||||
}
|
23
0006-python-version.patch
Normal file
23
0006-python-version.patch
Normal file
@ -0,0 +1,23 @@
|
||||
diff --git a/m4/ax_python.m4 b/m4/ax_python.m4
|
||||
index d293da525..9f43ea0ab 100644
|
||||
--- a/m4/ax_python.m4
|
||||
+++ b/m4/ax_python.m4
|
||||
@@ -3,7 +3,7 @@ dnl 2019 David Lamparter for NetDEF, Inc.
|
||||
dnl SPDX-License-Identifier: GPL-2.0-or-later
|
||||
|
||||
dnl the _ at the beginning will be cut off (to support the empty version string)
|
||||
-m4_define_default([_FRR_PY_VERS], [_3 _ _2 _3.7 _3.6 _3.5 _3.4 _3.3 _3.2 _2.7])
|
||||
+m4_define_default([_FRR_PY_VERS], [_3 _3.10 _3.9 _3.8 _3.7 _3.6 _3.5 _3.4 _3.3 _3.2 _ _2 _2.7])
|
||||
|
||||
dnl check basic interpreter properties (py2/py3)
|
||||
dnl doubles as simple check whether the interpreter actually works
|
||||
@@ -186,7 +186,8 @@ AC_REQUIRE([PKG_PROG_PKG_CONFIG])dnl
|
||||
AC_MSG_RESULT([yes])
|
||||
|
||||
PYTHON_CFLAGS="`\"$pycfg\" --includes`"
|
||||
- if test x"${py_ver}" == x"3.8" || test x"{py_ver}" == x"3.9"; then
|
||||
+ minor_ver=${py_ver#*\.}
|
||||
+ if test $((minor_ver)) > 7; then
|
||||
PYTHON_LIBS="`\"$pycfg\" --ldflags --embed`"
|
||||
else
|
||||
PYTHON_LIBS="`\"$pycfg\" --ldflags`"
|
1
frr-tmpfiles.conf
Normal file
1
frr-tmpfiles.conf
Normal file
@ -0,0 +1 @@
|
||||
d /run/frr 0755 frr frr -
|
23
frr.spec
23
frr.spec
@ -1,16 +1,17 @@
|
||||
%global frrversion 7.3
|
||||
%global frrversion 7.3.1
|
||||
%global frr_libdir /usr/lib/frr
|
||||
|
||||
%global _hardened_build 1
|
||||
%define _legacy_common_support 1
|
||||
|
||||
Name: frr
|
||||
Version: 7.3
|
||||
Release: 6%{?checkout}%{?dist}
|
||||
Version: 7.3.1
|
||||
Release: 2%{?checkout}%{?dist}
|
||||
Summary: Routing daemon
|
||||
License: GPLv2+
|
||||
URL: http://www.frrouting.org
|
||||
Source0: https://github.com/FRRouting/frr/releases/download/%{name}-%{frrversion}/%{name}-%{frrversion}.tar.gz
|
||||
Source1: %{name}-tmpfiles.conf
|
||||
BuildRequires: perl-generators
|
||||
BuildRequires: gcc
|
||||
BuildRequires: net-snmp-devel
|
||||
@ -33,7 +34,7 @@ Patch0001: 0001-use-python3.patch
|
||||
Patch0002: 0002-enable-openssl.patch
|
||||
Patch0003: 0003-disable-eigrp-crypto.patch
|
||||
Patch0004: 0004-fips-mode.patch
|
||||
Patch0005: 0005-json-c-0.14.0.patch
|
||||
Patch0006: 0006-python-version.patch
|
||||
|
||||
%description
|
||||
FRRouting is free software that manages TCP/IP based routing protocols. It takes
|
||||
@ -86,12 +87,14 @@ mkdir -p %{buildroot}/etc/{frr,rc.d/init.d,sysconfig,logrotate.d,pam.d,default}
|
||||
%{buildroot}%{_unitdir}
|
||||
|
||||
mkdir -p -m 0755 %{buildroot}%{_libdir}/frr
|
||||
mkdir -p %{buildroot}%{_tmpfilesdir}
|
||||
|
||||
%make_install
|
||||
|
||||
# Remove this file, as it is uninstalled and causes errors when building on RH9
|
||||
rm -rf %{buildroot}/usr/share/info/dir
|
||||
|
||||
install -p -m 644 %{SOURCE1} %{buildroot}%{_tmpfilesdir}/%{name}.conf
|
||||
install -p -m 644 %{_builddir}/%{name}-%{frrversion}/tools/etc/frr/daemons %{buildroot}/etc/frr/daemons
|
||||
install -p -m 644 %{_builddir}/%{name}-%{frrversion}/tools/frr.service %{buildroot}%{_unitdir}/frr.service
|
||||
install -p -m 755 %{_builddir}/%{name}-%{frrversion}/tools/frrinit.sh %{buildroot}%{frr_libdir}/frr
|
||||
@ -158,24 +161,32 @@ make check PYTHON=%{__python3}
|
||||
%doc ripngd/ripngd.conf.sample
|
||||
%doc pimd/pimd.conf.sample
|
||||
%doc doc/mpls
|
||||
%dir %attr(755,frr,frr) %{_sysconfdir}/frr
|
||||
%dir %attr(640,frr,frr) %{_sysconfdir}/frr
|
||||
%dir %attr(755,frr,frr) /var/log/frr
|
||||
%dir %attr(755,frr,frr) /run/frr
|
||||
%{_infodir}/*info*
|
||||
%{_mandir}/man*/*
|
||||
%dir %{frr_libdir}/
|
||||
%{frr_libdir}/*
|
||||
%{_bindir}/*
|
||||
%dir %{_libdir}/frr
|
||||
%{_libdir}/frr/*.so.*
|
||||
%dir %{_libdir}/frr/modules
|
||||
%{_libdir}/frr/modules/*
|
||||
%config(noreplace) %attr(644,root,root) /etc/logrotate.d/frr
|
||||
%config(noreplace) /etc/frr/daemons
|
||||
%config(noreplace) %attr(644,frr,frr) /etc/frr/daemons
|
||||
%config(noreplace) /etc/pam.d/frr
|
||||
%{_unitdir}/*.service
|
||||
%dir /usr/share/yang
|
||||
/usr/share/yang/*.yang
|
||||
%{_tmpfilesdir}/%{name}.conf
|
||||
#%%{_libdir}/frr/frr/libyang_plugins/*
|
||||
|
||||
%changelog
|
||||
* Thu Jun 18 2020 Michal Ruprich <michalruprich@gmail.com> - 7.3.1-1
|
||||
- New version 7.3.1
|
||||
- Fixes a couple of bugs(#1832259, #1835039, #1830815, #1830808, #1830806, #1830800, #1830798, #1814773)
|
||||
|
||||
* Tue May 19 2020 Michal Ruprich <michalruprich@gmail.com> - 7.3-6
|
||||
- Removing texi2html, it is not available in Rawhide anymore
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (frr-7.3.tar.gz) = 51d41ea00c91a98ef4152c1650238fa0a6bdc45151917ed7a90f9441ddad8af2d206579b0c8693abcbe890379ec7d8eca47930f9a795e96d8e1cdc513e293237
|
||||
SHA512 (remove-babeld-ldpd.sh) = 9cf3040bfac3620d97c323cc64e35ce2afaf943f6398d0b4187af7756897f2a4e68afedf5dc495f735132e577479aa1c142e6c111575ea6cd931295a7f6f1557
|
||||
SHA512 (frr-7.3.1.tar.gz) = 844c3163cd27169db06236ef64b0fc9dff69b7de22d2b11f418af7fea889fcba1ea90d2b25fb0195072d1577f20c8201619d9ff9219c524265ea7451011ba113
|
||||
SHA512 (remove-babeld-ldpd.sh) = a5bf67a3722cb20d43cef1dac28f839db68df73a1b7d34d8438e4f9366da3b67d85c1f44281f93434e8dd8ebcb2d3dc258b77eaa5627475b7395d207f020839d
|
||||
|
Loading…
Reference in New Issue
Block a user