Resolves: #1958155 - Upgrading frr unconditionally creates /etc/frr/frr.conf, breaking existing configuration
This commit is contained in:
parent
9a3662fec6
commit
0caf6d3485
@ -27,3 +27,29 @@ index 5be3264..33abc1d 100644
|
|||||||
lib/Makefile \
|
lib/Makefile \
|
||||||
nhrpd/Makefile \
|
nhrpd/Makefile \
|
||||||
ospf6d/Makefile \
|
ospf6d/Makefile \
|
||||||
|
diff --git a/tools/etc/frr/daemons b/tools/etc/frr/daemons
|
||||||
|
index f6d512b..6d4831d 100644
|
||||||
|
--- a/tools/etc/frr/daemons
|
||||||
|
+++ b/tools/etc/frr/daemons
|
||||||
|
@@ -21,10 +21,8 @@ ripd=no
|
||||||
|
ripngd=no
|
||||||
|
isisd=no
|
||||||
|
pimd=no
|
||||||
|
-ldpd=no
|
||||||
|
nhrpd=no
|
||||||
|
eigrpd=no
|
||||||
|
-babeld=no
|
||||||
|
sharpd=no
|
||||||
|
pbrd=no
|
||||||
|
bfdd=no
|
||||||
|
@@ -45,10 +43,8 @@ ripd_options=" -A 127.0.0.1"
|
||||||
|
ripngd_options=" -A ::1"
|
||||||
|
isisd_options=" -A 127.0.0.1"
|
||||||
|
pimd_options=" -A 127.0.0.1"
|
||||||
|
-ldpd_options=" -A 127.0.0.1"
|
||||||
|
nhrpd_options=" -A 127.0.0.1"
|
||||||
|
eigrpd_options=" -A 127.0.0.1"
|
||||||
|
-babeld_options=" -A 127.0.0.1"
|
||||||
|
sharpd_options=" -A 127.0.0.1"
|
||||||
|
pbrd_options=" -A 127.0.0.1"
|
||||||
|
staticd_options="-A 127.0.0.1"
|
||||||
|
17
frr.spec
17
frr.spec
@ -6,7 +6,7 @@
|
|||||||
|
|
||||||
Name: frr
|
Name: frr
|
||||||
Version: 7.5.1
|
Version: 7.5.1
|
||||||
Release: 3%{?checkout}%{?dist}
|
Release: 4%{?checkout}%{?dist}
|
||||||
Summary: Routing daemon
|
Summary: Routing daemon
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: http://www.frrouting.org
|
URL: http://www.frrouting.org
|
||||||
@ -129,10 +129,14 @@ if [ -f %{_infodir}/%{name}.inf* ]; then
|
|||||||
fi
|
fi
|
||||||
|
|
||||||
# Create dummy files if they don't exist so basic functions can be used.
|
# Create dummy files if they don't exist so basic functions can be used.
|
||||||
if [ ! -e %{_sysconfdir}/frr/frr.conf ]; then
|
# Only create frr.conf when first installing, otherwise it can change
|
||||||
echo "hostname `hostname`" > %{_sysconfdir}/frr/frr.conf
|
# the behavior of the package
|
||||||
chown frr:frr %{_sysconfdir}/frr/frr.conf
|
if [ $1 -eq 1 ]; then
|
||||||
chmod 640 %{_sysconfdir}/frr/frr.conf
|
if [ ! -e %{_sysconfdir}/frr/frr.conf ]; then
|
||||||
|
echo "hostname `hostname`" > %{_sysconfdir}/frr/frr.conf
|
||||||
|
chown frr:frr %{_sysconfdir}/frr/frr.conf
|
||||||
|
chmod 640 %{_sysconfdir}/frr/frr.conf
|
||||||
|
fi
|
||||||
fi
|
fi
|
||||||
|
|
||||||
#still used by vtysh, this way no error is produced when using vtysh
|
#still used by vtysh, this way no error is produced when using vtysh
|
||||||
@ -192,6 +196,9 @@ make check PYTHON=%{__python3}
|
|||||||
%{_tmpfilesdir}/%{name}.conf
|
%{_tmpfilesdir}/%{name}.conf
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jun 04 2021 Michal Ruprich <mruprich@redhat.com> - 7.5.1-4
|
||||||
|
- Resolves: #1958155 - Upgrading frr unconditionally creates /etc/frr/frr.conf, breaking existing configuration
|
||||||
|
|
||||||
* Fri Apr 23 2021 Michal Ruprich <mruprich@redhat.com> - 7.5.1-3
|
* Fri Apr 23 2021 Michal Ruprich <mruprich@redhat.com> - 7.5.1-3
|
||||||
- Resolves: #1939456 - /etc/frr permissions are bogus
|
- Resolves: #1939456 - /etc/frr permissions are bogus
|
||||||
- Resolves: #1951303 - FTBFS in CentOS Stream
|
- Resolves: #1951303 - FTBFS in CentOS Stream
|
||||||
|
Loading…
Reference in New Issue
Block a user