New upstream release.
This also contains a fix of the broken data in 1.0.14. Resolves: RHEL-36581
This commit is contained in:
parent
011e12784e
commit
db0e76f8ce
1
.gitignore
vendored
1
.gitignore
vendored
@ -12,3 +12,4 @@
|
||||
/fribidi-1.0.11.tar.xz
|
||||
/fribidi-1.0.12.tar.xz
|
||||
/fribidi-1.0.13.tar.xz
|
||||
/fribidi-1.0.14.tar.xz
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -pruN fribidi-1.0.13.orig/bin/Makefile.am fribidi-1.0.13/bin/Makefile.am
|
||||
--- fribidi-1.0.13.orig/bin/Makefile.am 2020-07-06 04:17:23.000000000 +0900
|
||||
+++ fribidi-1.0.13/bin/Makefile.am 2023-05-17 17:09:19.965214651 +0900
|
||||
diff -pruN fribidi-1.0.14.orig/bin/Makefile.am fribidi-1.0.14/bin/Makefile.am
|
||||
--- fribidi-1.0.14.orig/bin/Makefile.am 2020-07-06 04:17:23.000000000 +0900
|
||||
+++ fribidi-1.0.14/bin/Makefile.am 2024-05-07 21:40:04.500166714 +0900
|
||||
@@ -2,11 +2,9 @@ bin_PROGRAMS = fribidi
|
||||
|
||||
noinst_PROGRAMS = fribidi-benchmark fribidi-bidi-types fribidi-caprtl2utf8
|
||||
@ -15,9 +15,9 @@ diff -pruN fribidi-1.0.13.orig/bin/Makefile.am fribidi-1.0.13/bin/Makefile.am
|
||||
|
||||
AM_CPPFLAGS = \
|
||||
@FRIBIDI_CPPFLAGS@ \
|
||||
diff -pruN fribidi-1.0.13.orig/bin/getopt.c fribidi-1.0.13/bin/getopt.c
|
||||
--- fribidi-1.0.13.orig/bin/getopt.c 2015-08-05 03:49:07.000000000 +0900
|
||||
+++ fribidi-1.0.13/bin/getopt.c 1970-01-01 09:00:00.000000000 +0900
|
||||
diff -pruN fribidi-1.0.14.orig/bin/getopt.c fribidi-1.0.14/bin/getopt.c
|
||||
--- fribidi-1.0.14.orig/bin/getopt.c 2015-08-05 03:49:07.000000000 +0900
|
||||
+++ fribidi-1.0.14/bin/getopt.c 1970-01-01 09:00:00.000000000 +0900
|
||||
@@ -1,1268 +0,0 @@
|
||||
-/* Getopt for GNU.
|
||||
- NOTE: getopt is now part of the C library, so if you don't know what
|
||||
@ -1287,9 +1287,9 @@ diff -pruN fribidi-1.0.13.orig/bin/getopt.c fribidi-1.0.13/bin/getopt.c
|
||||
-}
|
||||
-
|
||||
-#endif /* TEST */
|
||||
diff -pruN fribidi-1.0.13.orig/bin/getopt.h fribidi-1.0.13/bin/getopt.h
|
||||
--- fribidi-1.0.13.orig/bin/getopt.h 2015-08-05 03:49:07.000000000 +0900
|
||||
+++ fribidi-1.0.13/bin/getopt.h 1970-01-01 09:00:00.000000000 +0900
|
||||
diff -pruN fribidi-1.0.14.orig/bin/getopt.h fribidi-1.0.14/bin/getopt.h
|
||||
--- fribidi-1.0.14.orig/bin/getopt.h 2015-08-05 03:49:07.000000000 +0900
|
||||
+++ fribidi-1.0.14/bin/getopt.h 1970-01-01 09:00:00.000000000 +0900
|
||||
@@ -1,187 +0,0 @@
|
||||
-/* Declarations for getopt.
|
||||
- Copyright (C) 1989-1994,1996-1999,2001,2003,2004
|
||||
@ -1478,9 +1478,9 @@ diff -pruN fribidi-1.0.13.orig/bin/getopt.h fribidi-1.0.13/bin/getopt.h
|
||||
-#undef __need_getopt
|
||||
-
|
||||
-#endif /* getopt.h */
|
||||
diff -pruN fribidi-1.0.13.orig/bin/getopt1.c fribidi-1.0.13/bin/getopt1.c
|
||||
--- fribidi-1.0.13.orig/bin/getopt1.c 2015-08-05 03:49:07.000000000 +0900
|
||||
+++ fribidi-1.0.13/bin/getopt1.c 1970-01-01 09:00:00.000000000 +0900
|
||||
diff -pruN fribidi-1.0.14.orig/bin/getopt1.c fribidi-1.0.14/bin/getopt1.c
|
||||
--- fribidi-1.0.14.orig/bin/getopt1.c 2015-08-05 03:49:07.000000000 +0900
|
||||
+++ fribidi-1.0.14/bin/getopt1.c 1970-01-01 09:00:00.000000000 +0900
|
||||
@@ -1,213 +0,0 @@
|
||||
-/* getopt_long and getopt_long_only entry points for GNU getopt.
|
||||
- Copyright (C) 1987,88,89,90,91,92,93,94,96,97,98,2004
|
||||
@ -1695,9 +1695,9 @@ diff -pruN fribidi-1.0.13.orig/bin/getopt1.c fribidi-1.0.13/bin/getopt1.c
|
||||
-}
|
||||
-
|
||||
-#endif /* TEST */
|
||||
diff -pruN fribidi-1.0.13.orig/bin/getopt_int.h fribidi-1.0.13/bin/getopt_int.h
|
||||
--- fribidi-1.0.13.orig/bin/getopt_int.h 2015-08-05 03:49:07.000000000 +0900
|
||||
+++ fribidi-1.0.13/bin/getopt_int.h 1970-01-01 09:00:00.000000000 +0900
|
||||
diff -pruN fribidi-1.0.14.orig/bin/getopt_int.h fribidi-1.0.14/bin/getopt_int.h
|
||||
--- fribidi-1.0.14.orig/bin/getopt_int.h 2015-08-05 03:49:07.000000000 +0900
|
||||
+++ fribidi-1.0.14/bin/getopt_int.h 1970-01-01 09:00:00.000000000 +0900
|
||||
@@ -1,145 +0,0 @@
|
||||
-/* Internal declarations for getopt.
|
||||
- Copyright (C) 1989-1994,1996-1999,2001,2003,2004
|
||||
@ -1844,23 +1844,26 @@ diff -pruN fribidi-1.0.13.orig/bin/getopt_int.h fribidi-1.0.13/bin/getopt_int.h
|
||||
-);
|
||||
-
|
||||
-#endif /* getopt_int.h */
|
||||
diff -pruN fribidi-1.0.13.orig/bin/gettext.h fribidi-1.0.13/bin/gettext.h
|
||||
--- fribidi-1.0.13.orig/bin/gettext.h 2015-08-05 03:49:07.000000000 +0900
|
||||
+++ fribidi-1.0.13/bin/gettext.h 1970-01-01 09:00:00.000000000 +0900
|
||||
diff -pruN fribidi-1.0.14.orig/bin/gettext.h fribidi-1.0.14/bin/gettext.h
|
||||
--- fribidi-1.0.14.orig/bin/gettext.h 2015-08-05 03:49:07.000000000 +0900
|
||||
+++ fribidi-1.0.14/bin/gettext.h 1970-01-01 09:00:00.000000000 +0900
|
||||
@@ -1,2 +0,0 @@
|
||||
-#undef gettext
|
||||
-#define gettext
|
||||
diff -pruN fribidi-1.0.13.orig/bin/meson.build fribidi-1.0.13/bin/meson.build
|
||||
--- fribidi-1.0.13.orig/bin/meson.build 2023-05-17 03:47:48.000000000 +0900
|
||||
+++ fribidi-1.0.13/bin/meson.build 2023-05-17 17:11:43.178425907 +0900
|
||||
@@ -1,12 +1,12 @@
|
||||
diff -pruN fribidi-1.0.14.orig/bin/meson.build fribidi-1.0.14/bin/meson.build
|
||||
--- fribidi-1.0.14.orig/bin/meson.build 2024-03-18 03:10:09.000000000 +0900
|
||||
+++ fribidi-1.0.14/bin/meson.build 2024-05-07 21:40:55.573086578 +0900
|
||||
@@ -1,7 +1,7 @@
|
||||
# The fribidi binary is used by the test setup, so if bin=false we still
|
||||
# need to build it for internal usage, we just won't install it.
|
||||
fribidi = executable('fribidi',
|
||||
- 'fribidi-main.c', 'getopt.c', 'getopt1.c', fribidi_unicode_version_h,
|
||||
+ 'fribidi-main.c', fribidi_unicode_version_h,
|
||||
c_args: ['-DHAVE_CONFIG_H'] + fribidi_static_cargs,
|
||||
include_directories: incs,
|
||||
link_with: libfribidi,
|
||||
install: true)
|
||||
@@ -12,7 +12,7 @@ if not get_option('bin')
|
||||
endif
|
||||
|
||||
executable('fribidi-benchmark',
|
||||
- 'fribidi-benchmark.c', 'getopt.c', 'getopt1.c', fribidi_unicode_version_h,
|
||||
|
14
fribidi.spec
14
fribidi.spec
@ -1,7 +1,7 @@
|
||||
Summary: Library implementing the Unicode Bidirectional Algorithm
|
||||
Name: fribidi
|
||||
Version: 1.0.13
|
||||
Release: 4%{?dist}
|
||||
Version: 1.0.14
|
||||
Release: 2%{?dist}
|
||||
URL: https://github.com/fribidi/fribidi/
|
||||
Source: https://github.com/%{name}/%{name}/releases/download/v%{version}/%{name}-%{version}.tar.xz
|
||||
License: LGPL-2.1-or-later AND Unicode-DFS-2016
|
||||
@ -32,6 +32,10 @@ FriBidi.
|
||||
%if 0%{?rhel} && 0%{?rhel} <= 8
|
||||
autoreconf -i
|
||||
%endif
|
||||
# Clean up older file in archive
|
||||
(cd lib;
|
||||
rm arabic-shaping.tab.i bidi-type.tab.i brackets*.tab.i joining-type.tab.i mirroring.tab.i fribidi-unicode-version.h
|
||||
)
|
||||
|
||||
%build
|
||||
%if 0%{?rhel} && 0%{?rhel} <= 8
|
||||
@ -84,6 +88,11 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
|
||||
#%%{_mandir}/man3/*.gz
|
||||
|
||||
%changelog
|
||||
* Wed Jun 5 2024 Akira TAGOH <tagoh@redhat.com> - 1.0.14-2
|
||||
- New upstream release.
|
||||
- Fix broken data in fribidi.
|
||||
Resolves: RHEL-36581
|
||||
|
||||
* Wed Jan 24 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.13-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||
|
||||
@ -360,4 +369,3 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
|
||||
|
||||
* Fri May 16 2003 Jeremy Katz <katzj@redhat.com> 0.10.4-2
|
||||
- Initial build in Red Hat Linux
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (fribidi-1.0.13.tar.xz) = 09357d842ff9e05b918f826e28e4a25ad996e17f73242ee9ce53fae9f37ec6c639f9cae4271577f6e0269f34265afc893858225c4a94610f0a6ee7580fb1fe07
|
||||
SHA512 (fribidi-1.0.14.tar.xz) = 70270826625767a916156c9d752d8ad02c71b33d532060981680942c5121746bb9b0272a3f2188b9019e841c642d1ad686bbc3e7ba54a2f951baa532b01b059a
|
||||
|
Loading…
Reference in New Issue
Block a user