multi arch devel

This commit is contained in:
Caolan McNamara 2006-05-02 10:06:41 +00:00
parent 4e88b9872b
commit 714453566e
2 changed files with 58 additions and 1 deletions

View File

@ -0,0 +1,47 @@
--- fribidi-0.10.7.orig/fribidi_config.h.in 2006-05-02 10:45:43.000000000 +0100
+++ fribidi-0.10.7/fribidi_config.h.in 2006-05-02 10:49:34.000000000 +0100
@@ -41,6 +41,12 @@
#define FALSE FRIBIDI_FALSE
#endif /* FALSE */
-#define FRIBIDI_SIZEOF_SHORT @SIZEOF_SHORT@
-#define FRIBIDI_SIZEOF_INT @SIZEOF_INT@
-#define FRIBIDI_SIZEOF_LONG @SIZEOF_LONG@
+#include <bits/wordsize.h>
+
+#if __WORDSIZE == 32
+# include "fribidi_config-32.h"
+#elif __WORDSIZE == 64
+# include "fribidi_config-64.h"
+#else
+# error "unexpected value for __WORDSIZE macro"
+#endif
--- /dev/null 2006-04-29 13:38:37.035974750 +0100
+++ fribidi-0.10.7/fribidi_config-64.h 2006-05-02 10:48:14.000000000 +0100
@@ -0,0 +1,6 @@
+#ifndef FRIBIDI_CONFIG_SIXFOUR_H
+#define FRIBIDI_CONFIG-SIXFOUR_H
+#define FRIBIDI_SIZEOF_SHORT 2
+#define FRIBIDI_SIZEOF_INT 4
+#define FRIBIDI_SIZEOF_LONG 8
+#endif
--- /dev/null 2006-04-29 13:38:37.035974750 +0100
+++ fribidi-0.10.7/fribidi_config-32.h 2006-05-02 10:47:54.000000000 +0100
@@ -0,0 +1,6 @@
+#ifndef FRIBIDI_CONFIG_THREETWO_H
+#define FRIBIDI_CONFIG_THREETWO_H
+#define FRIBIDI_SIZEOF_SHORT 2
+#define FRIBIDI_SIZEOF_INT 4
+#define FRIBIDI_SIZEOF_LONG 4
+#endif
--- fribidi-0.10.7.orig/Makefile.am 2006-05-02 10:52:33.000000000 +0100
+++ fribidi-0.10.7/Makefile.am 2006-05-02 10:52:55.000000000 +0100
@@ -59,6 +59,8 @@
$(libfribidi_charsets_h) \
$(libfribidi_charsets_extra_h) \
fribidi_config.h \
+ fribidi_config-32.h \
+ fribidi_config-64.h \
fribidi_mem.h
GETOPT_SRC = \

View File

@ -1,12 +1,14 @@
Summary: Library implementing the Unicode Bidirectional Algorithm
Name: fribidi
Version: 0.10.7
Release: 1
Release: 2
URL: http://fribidi.org
Source0: %{name}-%{version}.tar.gz
Patch0: fribidi-0.10.7-multiarchdevel.patch
License: LGPL
Group: System Environment/Libraries
BuildRoot: %{_tmppath}/%{name}-root
BuildRequires: automake, autoconf
%description
A library to handle bidirectional scripts (eg. hebrew, arabic), so that
@ -24,8 +26,12 @@ fribidi.
%prep
%setup -q
%patch0 -p1 -b .multiarchdevel
%build
aclocal
autoconf
automake
%configure
make
@ -56,6 +62,10 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/pkgconfig/*.pc
%changelog
* Tue May 02 2006 Caolan McNamara <caolanm@redhat.com> 0.10.7-2
- base fribidi-config on pkg-config output
- allow fribidi_config.h to be the same on 32 and 64 bit
* Mon Mar 27 2006 Caolan McNamara <caolanm@redhat.com> 0.10.7-1
- latest version