New upstream release.

Resolves: rhbz#1809478
This commit is contained in:
Akira TAGOH 2020-03-05 18:16:21 +09:00
parent f2aef242bb
commit 29d4c9cf1c
5 changed files with 9 additions and 55 deletions

1
.gitignore vendored
View File

@ -7,3 +7,4 @@
/fribidi-1.0.6.tar.gz
/fribidi-1.0.7.tar.bz2
/fribidi-1.0.8.tar.bz2
/fribidi-1.0.9.tar.xz

View File

@ -1,12 +0,0 @@
diff -pruN fribidi-1.0.6.orig/gen.tab/Makefile.am fribidi-1.0.6/gen.tab/Makefile.am
--- fribidi-1.0.6.orig/gen.tab/Makefile.am 2019-09-27 14:03:47.000000000 +0900
+++ fribidi-1.0.6/gen.tab/Makefile.am 2019-09-27 17:42:00.196295996 +0900
@@ -25,7 +25,7 @@ gen_brackets_type_tab_CPPFLAGS = $(AM_CP
CFLAGS_FOR_BUILD += -DHAVE_CONFIG_H -I$(top_builddir) -I$(top_builddir)/lib -I$(top_srcdir)/lib
CC = $(CC_FOR_BUILD)
-CFLAGS = $(CFLAGS_FOR_BUILD)
+AM_CFLAGS = $(CFLAGS_FOR_BUILD)
CLEANFILES = $(EXTRA_PROGRAMS)
DISTCLEANFILES =

View File

@ -1,38 +0,0 @@
From c4d0f2f85b9023b386011b4ca978cf908d8e9a96 Mon Sep 17 00:00:00 2001
From: Dov Grobgeld <dov.grobgeld@gmail.com>
Date: Sat, 21 Dec 2019 22:01:43 +0100
Subject: [PATCH 1/4] Restored mistakenly removed deprecated function
fribidi_log2vis_get_embedding_levels()
- Issue #134
---
lib/fribidi-deprecated.c | 13 +++++++++++++
1 file changed, 13 insertions(+)
diff --git a/lib/fribidi-deprecated.c b/lib/fribidi-deprecated.c
index 7a97292..bc0b8e2 100644
--- a/lib/fribidi-deprecated.c
+++ b/lib/fribidi-deprecated.c
@@ -76,6 +76,19 @@ fribidi_reorder_nsm_status (
+FRIBIDI_ENTRY FriBidiLevel
+fribidi_log2vis_get_embedding_levels (
+ const FriBidiCharType *bidi_types, /* input list of bidi types as returned by
+ fribidi_get_bidi_types() */
+ const FriBidiStrIndex len, /* input string length of the paragraph */
+ FriBidiParType *pbase_dir, /* requested and resolved paragraph
+ * base direction */
+ FriBidiLevel *embedding_levels /* output list of embedding levels */
+)
+{
+ return fribidi_get_par_embedding_levels_ex (bidi_types, NULL, len, pbase_dir, embedding_levels);
+}
+
FRIBIDI_ENTRY FriBidiCharType
fribidi_get_type (
FriBidiChar ch /* input character */
--
2.24.1

View File

@ -1,9 +1,9 @@
Summary: Library implementing the Unicode Bidirectional Algorithm
Name: fribidi
Version: 1.0.8
Release: 3%{?dist}
Version: 1.0.9
Release: 1%{?dist}
URL: https://github.com/fribidi/fribidi/
Source: https://github.com/%{name}/%{name}/releases/download/v%{version}/%{name}-%{version}.tar.bz2
Source: https://github.com/%{name}/%{name}/releases/download/v%{version}/%{name}-%{version}.tar.xz
License: LGPLv2+ and UCD
BuildRequires: gcc
%if 0%{?rhel} && 0%{?rhel} <= 8
@ -12,8 +12,6 @@ BuildRequires: automake autoconf libtool
BuildRequires: meson
%endif
Patch0: %{name}-drop-bundled-gnulib.patch
Patch1: %{name}-automake.patch
Patch2: %{name}-restore-deprecated-api.patch
%description
A library to handle bidirectional scripts (for example Hebrew, Arabic),
@ -85,6 +83,10 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
#%%{_mandir}/man3/*.gz
%changelog
* Thu Mar 05 2020 Akira TAGOH <tagoh@redhat.com> - 1.0.9-1
- New upstream release.
Resolves: rhbz#1809478
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.8-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

View File

@ -1 +1,2 @@
SHA512 (fribidi-1.0.8.tar.bz2) = d66b1524b26d227fd6a628f438efb875c023ae3be708acaaad11f1f62d0902de0a5f57124458291ef2b0fcd89356c52ab8ae5559b0b5a93fa435b92f1d098ba2
SHA512 (fribidi-1.0.9.tar.xz) = e66989830941172fa003c8b9376719282fa1039592a1e158e975cab81ce8dcb2755453c64906a8464c047f9e9154e012d9bd37256b1f463e235648a13e4601ed