rh#192669# fribidi-config on pkg-config
This commit is contained in:
parent
714453566e
commit
10f9743827
@ -45,3 +45,95 @@
|
||||
fribidi_mem.h
|
||||
|
||||
GETOPT_SRC = \
|
||||
--- fribidi-0.10.7.orig/configure.in 2006-05-02 10:52:33.000000000 +0100
|
||||
+++ fribidi-0.10.7/configure.in 2006-05-23 08:29:08.000000000 +0100
|
||||
@@ -199,7 +199,6 @@
|
||||
AC_OUTPUT([
|
||||
Makefile
|
||||
fribidi_config.h
|
||||
-fribidi-config
|
||||
fribidi.pc
|
||||
fribidi.spec
|
||||
],[case "$CONFIG_FILES" in
|
||||
--- /dev/null 2006-05-21 20:51:02.793468250 +0100
|
||||
+++ fribidi-0.10.7/fribidi-config 2006-05-23 08:28:36.000000000 +0100
|
||||
@@ -0,0 +1,79 @@
|
||||
+#!/bin/sh
|
||||
+
|
||||
+prefix=`pkg-config --variable prefix fribidi`
|
||||
+exec_prefix=`pkg-config --variable exec_prefix fribidi`
|
||||
+exec_prefix_set=no
|
||||
+
|
||||
+usage()
|
||||
+{
|
||||
+ cat <<EOF
|
||||
+Usage: fribidi-config [OPTIONS] [LIBRARIES]
|
||||
+Options:
|
||||
+ [--prefix[=DIR]]
|
||||
+ [--exec-prefix[=DIR]]
|
||||
+ [--version]
|
||||
+ [--libs]
|
||||
+ [--cflags]
|
||||
+EOF
|
||||
+ exit $1
|
||||
+}
|
||||
+
|
||||
+if test $# -eq 0; then
|
||||
+ usage 1 1>&2
|
||||
+fi
|
||||
+
|
||||
+while test $# -gt 0; do
|
||||
+ case "$1" in
|
||||
+ -*=*) optarg=`echo "$1" | sed 's/[-_a-zA-Z0-9]*=//'` ;;
|
||||
+ *) optarg= ;;
|
||||
+ esac
|
||||
+
|
||||
+ case $1 in
|
||||
+ --prefix=*)
|
||||
+ prefix=$optarg
|
||||
+ if test $exec_prefix_set = no ; then
|
||||
+ exec_prefix=$optarg
|
||||
+ fi
|
||||
+ ;;
|
||||
+ --prefix)
|
||||
+ echo_prefix=yes
|
||||
+ ;;
|
||||
+ --exec-prefix=*)
|
||||
+ exec_prefix=$optarg
|
||||
+ exec_prefix_set=yes
|
||||
+ ;;
|
||||
+ --exec-prefix)
|
||||
+ echo_exec_prefix=yes
|
||||
+ ;;
|
||||
+ --version)
|
||||
+ pkg-config --modversion fribidi
|
||||
+ ;;
|
||||
+ --cflags)
|
||||
+ echo_cflags=yes
|
||||
+ ;;
|
||||
+ --libs)
|
||||
+ echo_libs=yes
|
||||
+ ;;
|
||||
+ *)
|
||||
+ usage 1 1>&2
|
||||
+ ;;
|
||||
+ esac
|
||||
+ shift
|
||||
+done
|
||||
+
|
||||
+if test "$echo_prefix" = "yes"; then
|
||||
+ echo $prefix
|
||||
+fi
|
||||
+
|
||||
+if test "$echo_exec_prefix" = "yes"; then
|
||||
+ echo $exec_prefix
|
||||
+fi
|
||||
+
|
||||
+if test "$echo_cflags" = "yes"; then
|
||||
+ pkg-config --cflags fribidi
|
||||
+fi
|
||||
+
|
||||
+if test "$echo_libs" = "yes"; then
|
||||
+ pkg-config --libs fribidi
|
||||
+fi
|
||||
+
|
||||
|
@ -1,7 +1,7 @@
|
||||
Summary: Library implementing the Unicode Bidirectional Algorithm
|
||||
Name: fribidi
|
||||
Version: 0.10.7
|
||||
Release: 2
|
||||
Release: 3
|
||||
URL: http://fribidi.org
|
||||
Source0: %{name}-%{version}.tar.gz
|
||||
Patch0: fribidi-0.10.7-multiarchdevel.patch
|
||||
@ -62,6 +62,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_libdir}/pkgconfig/*.pc
|
||||
|
||||
%changelog
|
||||
* Tue May 23 2006 Caolan McNamara <caolanm@redhat.com> 0.10.7-3
|
||||
- rh#192669# clearly I didn't actually get around to basing fribidi-config
|
||||
of pkg-config output
|
||||
|
||||
* Tue May 02 2006 Caolan McNamara <caolanm@redhat.com> 0.10.7-2
|
||||
- base fribidi-config on pkg-config output
|
||||
- allow fribidi_config.h to be the same on 32 and 64 bit
|
||||
|
Loading…
Reference in New Issue
Block a user