frei0r-plugins/Bump-opencv-to-2.3-c-API.patch
2020-05-25 10:00:11 +02:00

45 lines
1.4 KiB
Diff

From fa445192a9e3091b837ad93fccca86075dab80b2 Mon Sep 17 00:00:00 2001
From: Nicolas Chauvet <kwizart@gmail.com>
Date: Mon, 25 May 2020 09:56:59 +0200
Subject: [PATCH 4/4] Bump opencv to 2.3 (c++ API)
---
configure.ac | 2 +-
src/Makefile.am | 4 ++--
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/configure.ac b/configure.ac
index 42dd629..bd8b1cf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -94,7 +94,7 @@ AC_FUNC_MALLOC
AC_CHECK_FUNCS([floor memset pow sqrt])
HAVE_OPENCV=false
-PKG_CHECK_MODULES(OPENCV, opencv >= 1.0.0, [HAVE_OPENCV=true], [true])
+PKG_CHECK_MODULES(OPENCV, opencv >= 2.3, [HAVE_OPENCV=true], [true])
AM_CONDITIONAL([HAVE_OPENCV], [test x$HAVE_OPENCV = xtrue])
if test x$HAVE_OPENCV = xtrue; then
# OPENCV_CFLAGS="$OPENCV_CFLAGS -DOPENCV_PREFIX=`pkg-config opencv --variable=prefix`"
diff --git a/src/Makefile.am b/src/Makefile.am
index 9e8a9c4..c778312 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -156,11 +156,11 @@ endif
if HAVE_OPENCV
plugin_LTLIBRARIES += facebl0r.la
facebl0r_la_SOURCES = filter/facebl0r/facebl0r.cpp
-facebl0r_la_CFLAGS = @OPENCV_CFLAGS@ @CFLAGS@
+facebl0r_la_CFLAGS = @OPENCV_CXXFLAGS@ @CFLAGS@
facebl0r_la_LIBADD = @OPENCV_LIBS@
plugin_LTLIBRARIES += facedetect.la
facedetect_la_SOURCES = filter/facedetect/facedetect.cpp
-facedetect_la_CFLAGS = @OPENCV_CFLAGS@ @CFLAGS@
+facedetect_la_CFLAGS = @OPENCV_CXXFLAGS@ @CFLAGS@
facedetect_la_LIBADD = @OPENCV_LIBS@
endif
--
2.25.4