import freetype-2.9.1-4.el8

This commit is contained in:
CentOS Sources 2019-05-07 07:54:00 -04:00 committed by Andrew Lukoshko
commit 212164364d
11 changed files with 1439 additions and 0 deletions

3
.freetype.metadata Normal file
View File

@ -0,0 +1,3 @@
220c82062171c513e4017c523d196933c9de4a7d SOURCES/freetype-2.9.1.tar.bz2
bb6c973f9fef972ad4ecc03bc09ed676b8dc0d59 SOURCES/freetype-doc-2.9.1.tar.bz2
45704d7b75c4f9fdd6a9b3787918e8220b36aa77 SOURCES/ft2demos-2.9.1.tar.bz2

3
.gitignore vendored Normal file
View File

@ -0,0 +1,3 @@
SOURCES/freetype-2.9.1.tar.bz2
SOURCES/freetype-doc-2.9.1.tar.bz2
SOURCES/ft2demos-2.9.1.tar.bz2

View File

@ -0,0 +1,20 @@
--- freetype-2.2.1/modules.cfg.orig 2006-07-07 21:01:09.000000000 -0400
+++ freetype-2.2.1/modules.cfg 2006-07-07 21:01:54.000000000 -0400
@@ -110,7 +110,7 @@
# TrueType GX/AAT table validation. Needs `ftgxval.c' below.
#
# No FT_CONFIG_OPTION_PIC support.
-# AUX_MODULES += gxvalid
+AUX_MODULES += gxvalid
# Support for streams compressed with gzip (files with suffix .gz).
#
@@ -124,7 +124,7 @@
# OpenType table validation. Needs `ftotval.c' below.
#
# No FT_CONFIG_OPTION_PIC support.
-# AUX_MODULES += otvalid
+AUX_MODULES += otvalid
# Auxiliary PostScript driver component to share common code.
#

View File

@ -0,0 +1,11 @@
--- freetype-2.3.0/include/freetype/config/ftoption.h.spf 2007-01-18 14:27:34.000000000 -0500
+++ freetype-2.3.0/include/freetype/config/ftoption.h 2007-01-18 14:27:48.000000000 -0500
@@ -92,7 +92,7 @@
/* rendering technology that produces excellent output without LCD */
/* filtering. */
/* */
-/* #define FT_CONFIG_OPTION_SUBPIXEL_RENDERING */
+#define FT_CONFIG_OPTION_SUBPIXEL_RENDERING
/*************************************************************************/

View File

@ -0,0 +1,17 @@
--- ft2demos-2.5.2/Makefile
+++ ft2demos-2.5.2/Makefile
@@ -296,10 +296,10 @@ else
# The following programs are not compiled automatically; either comment
# out the affected line or use the program name as a Makefile target.
#
- # EXES += ftchkwd
- # EXES += ftmemchk
- # EXES += ftpatchk
- # EXES += fttimer
+ EXES += ftchkwd
+ EXES += ftmemchk
+ EXES += ftpatchk
+ EXES += fttimer
# EXES += testname
exes: $(EXES:%=$(BIN_DIR_2)/%$E)

View File

@ -0,0 +1,11 @@
--- freetype-2.8/builds/unix/freetype-config.in.orig 2017-03-30 12:20:23.000000001 +0200
+++ freetype-2.8/builds/unix/freetype-config.in 2017-05-16 13:25:39.223041128 +0200
@@ -205,7 +205,7 @@ if test "$echo_libs" = "yes" ; then
fi
if test "$echo_libtool" = "yes" ; then
- echo ${SYSROOT}$libdir/libfreetype.la
+ echo ""
fi
# EOF

View File

@ -0,0 +1,65 @@
--- freetype-2.9/builds/unix/freetype-config.in
+++ freetype-2.9/builds/unix/freetype-config.in
@@ -13,45 +13,25 @@ LC_ALL=C
export LC_ALL
-# if `pkg-config' is available, use values from `freetype2.pc'
-%PKG_CONFIG% --atleast-pkgconfig-version 0.24 >/dev/null 2>&1
-if test $? -eq 0 ; then
- # note that option `--variable' is not affected by the
- # PKG_CONFIG_SYSROOT_DIR environment variable
- if test "x$SYSROOT" != "x" ; then
- PKG_CONFIG_SYSROOT_DIR="$SYSROOT"
- export PKG_CONFIG_SYSROOT_DIR
- fi
-
- prefix=`%PKG_CONFIG% --variable prefix freetype2`
- exec_prefix=`%PKG_CONFIG% --variable exec_prefix freetype2`
-
- includedir=`%PKG_CONFIG% --variable includedir freetype2`
- libdir=`%PKG_CONFIG% --variable libdir freetype2`
-
- version=`%PKG_CONFIG% --modversion freetype2`
-
- cflags=`%PKG_CONFIG% --cflags freetype2`
- dynamic_libs=`%PKG_CONFIG% --libs freetype2`
- static_libs=`%PKG_CONFIG% --static --libs freetype2`
-else
- prefix="%prefix%"
- exec_prefix="%exec_prefix%"
-
- includedir="%includedir%"
- libdir="%libdir%"
-
- version=%ft_version%
-
- cflags="-I${SYSROOT}$includedir/freetype2"
- dynamic_libs="-lfreetype"
- static_libs="%LIBSSTATIC_CONFIG%"
- if test "${SYSROOT}$libdir" != "/usr/lib" &&
- test "${SYSROOT}$libdir" != "/usr/lib64" ; then
- libs_L="-L${SYSROOT}$libdir"
- fi
+# note that option `--variable' is not affected by the
+# PKG_CONFIG_SYSROOT_DIR environment variable
+if test "x$SYSROOT" != "x" ; then
+ PKG_CONFIG_SYSROOT_DIR="$SYSROOT"
+ export PKG_CONFIG_SYSROOT_DIR
fi
+prefix=`pkgconf --variable prefix freetype2`
+exec_prefix=`pkgconf --variable exec_prefix freetype2`
+
+includedir=`pkgconf --variable includedir freetype2`
+libdir=`pkgconf --variable libdir freetype2`
+
+version=`pkgconf --modversion freetype2`
+
+cflags=`pkgconf --cflags freetype2`
+dynamic_libs=`pkgconf --libs freetype2`
+static_libs=`pkgconf --static --libs freetype2`
+
orig_prefix=$prefix
orig_exec_prefix=$exec_prefix

View File

@ -0,0 +1,101 @@
--- a/src/smooth/ftsmooth.c
+++ b/src/smooth/ftsmooth.c
@@ -232,39 +232,13 @@
FT_UInt i, j;
unsigned int height = bitmap->rows;
- unsigned int width = bitmap->width;
+ unsigned int width = bitmap->width / 3;
int pitch = bitmap->pitch;
-
- /* Render 3 separate monochrome bitmaps, shifting the outline */
- /* by 1/3 pixel. */
- width /= 3;
-
- bitmap->buffer += width;
-
- error = render->raster_render( render->raster, &params );
- if ( error )
- goto Exit;
-
- FT_Outline_Translate( outline, -21, 0 );
- x_shift -= 21;
- bitmap->buffer += width;
-
error = render->raster_render( render->raster, &params );
if ( error )
goto Exit;
- FT_Outline_Translate( outline, 42, 0 );
- x_shift += 42;
- bitmap->buffer -= 2 * width;
-
- error = render->raster_render( render->raster, &params );
- if ( error )
- goto Exit;
-
- /* XXX: Rearrange the bytes according to FT_PIXEL_MODE_LCD. */
- /* XXX: It is more efficient to render every third byte above. */
-
if ( FT_ALLOC( temp, (FT_ULong)pitch ) )
goto Exit;
@@ -272,11 +246,7 @@
{
line = bitmap->buffer + i * (FT_ULong)pitch;
for ( j = 0; j < width; j++ )
- {
- temp[3 * j ] = line[j];
- temp[3 * j + 1] = line[j + width];
- temp[3 * j + 2] = line[j + width + width];
- }
+ temp[3 * j] = temp[3 * j + 1] = temp[3 * j + 2] = line[j];
FT_MEM_COPY( line, temp, pitch );
}
@@ -284,35 +254,23 @@
}
else if ( vmul ) /* lcd_v */
{
- int pitch = bitmap->pitch;
-
+ FT_Byte* line;
+ FT_UInt i;
+ int original_pitch = bitmap->pitch;
- /* Render 3 separate monochrome bitmaps, shifting the outline */
- /* by 1/3 pixel. Triple the pitch to render on each third row. */
bitmap->pitch *= 3;
bitmap->rows /= 3;
- bitmap->buffer += pitch;
-
- error = render->raster_render( render->raster, &params );
- if ( error )
- goto Exit;
-
- FT_Outline_Translate( outline, 0, 21 );
- y_shift += 21;
- bitmap->buffer += pitch;
-
error = render->raster_render( render->raster, &params );
if ( error )
goto Exit;
- FT_Outline_Translate( outline, 0, -42 );
- y_shift -= 42;
- bitmap->buffer -= 2 * pitch;
-
- error = render->raster_render( render->raster, &params );
- if ( error )
- goto Exit;
+ for ( i = 0; i < bitmap->rows; i++ )
+ {
+ line = bitmap->buffer + i * bitmap->pitch;
+ FT_MEM_COPY( line + original_pitch, line, bitmap->width );
+ FT_MEM_COPY( line + 2 * original_pitch, line, bitmap->width );
+ }
bitmap->pitch /= 3;
bitmap->rows *= 3;

View File

@ -0,0 +1,178 @@
--- freetype-2.9.1/builds/unix/freetype-config.in
+++ freetype-2.9.1/builds/unix/freetype-config.in
@@ -32,9 +32,6 @@ cflags=`%PKG_CONFIG% --cflags freetype2`
dynamic_libs=`pkgconf --libs freetype2`
static_libs=`pkgconf --static --libs freetype2`
-orig_prefix=$prefix
-orig_exec_prefix=$exec_prefix
-
orig_includedir=$includedir
orig_libdir=$libdir
--- freetype-2.9.1/ft2demos-2.9.1/src/ftbench.c
+++ freetype-2.9.1/ft2demos-2.9.1/src/ftbench.c
@@ -749,6 +749,7 @@
{
fprintf( stderr,
"couldn't allocate memory to pre-load font file\n" );
+ fclose( file );
return 1;
}
@@ -758,9 +759,12 @@
fprintf( stderr, "read error\n" );
free( memory_file );
memory_file = NULL;
+ fclose( file );
return 1;
}
+
+ fclose( file );
}
error = FT_New_Memory_Face( lib,
--- freetype-2.9.1/ft2demos-2.9.1/src/ftchkwd.c
+++ freetype-2.9.1/ft2demos-2.9.1/src/ftchkwd.c
@@ -118,8 +118,8 @@
FT_Library library;
int i, file_index;
- char filename[1024 + 4];
- char alt_filename[1024 + 4];
+ char filename[1024 + 5];
+ char alt_filename[1024 + 5];
char* execname;
char* fname;
@@ -169,8 +169,8 @@
#ifndef macintosh
if ( i >= 0 )
{
- strncpy( filename + strlen( filename ), ".ttf", 4 );
- strncpy( alt_filename + strlen( alt_filename ), ".ttc", 4 );
+ strncpy( filename + strlen( filename ), ".ttf", 5 );
+ strncpy( alt_filename + strlen( alt_filename ), ".ttc", 5 );
}
#endif
--- freetype-2.9.1/ft2demos-2.9.1/src/ftcommon.c
+++ freetype-2.9.1/ft2demos-2.9.1/src/ftcommon.c
@@ -110,7 +110,10 @@
if ( mode != gr_pixel_mode_gray &&
mode != gr_pixel_mode_rgb24 )
+ {
+ free( display );
return NULL;
+ }
grInitDevices();
--- freetype-2.9.1/ft2demos-2.9.1/src/ftdump.c
+++ freetype-2.9.1/ft2demos-2.9.1/src/ftdump.c
@@ -775,8 +775,8 @@
char* argv[] )
{
int i, file;
- char filename[1024 + 4];
- char alt_filename[1024 + 4];
+ char filename[1024 + 5];
+ char alt_filename[1024 + 5];
char* execname;
int num_faces;
int option;
@@ -872,8 +872,8 @@
if ( i >= 0 )
{
- strncpy( filename + strlen( filename ), ".ttf", 4 );
- strncpy( alt_filename + strlen( alt_filename ), ".ttc", 4 );
+ strncpy( filename + strlen( filename ), ".ttf", 5 );
+ strncpy( alt_filename + strlen( alt_filename ), ".ttc", 5 );
}
#endif
--- freetype-2.9.1/ft2demos-2.9.1/src/ftgrid.c
+++ freetype-2.9.1/ft2demos-2.9.1/src/ftgrid.c
@@ -662,6 +662,7 @@
break;
default:
+ free( t );
return;
}
--- freetype-2.9.1/ft2demos-2.9.1/src/ftlint.c
+++ freetype-2.9.1/ft2demos-2.9.1/src/ftlint.c
@@ -62,8 +62,8 @@
{
int i, file_index;
unsigned int id;
- char filename[1024 + 4];
- char alt_filename[1024 + 4];
+ char filename[1024 + 5];
+ char alt_filename[1024 + 5];
char* execname;
char* fname;
@@ -119,8 +119,8 @@
#ifndef macintosh
if ( i >= 0 )
{
- strncpy( filename + strlen( filename ), ".ttf", 4 );
- strncpy( alt_filename + strlen( alt_filename ), ".ttc", 4 );
+ strncpy( filename + strlen( filename ), ".ttf", 5 );
+ strncpy( alt_filename + strlen( alt_filename ), ".ttc", 5 );
}
#endif
i = (int)strlen( filename );
--- freetype-2.9.1/ft2demos-2.9.1/src/ftmemchk.c
+++ freetype-2.9.1/ft2demos-2.9.1/src/ftmemchk.c
@@ -227,8 +227,8 @@ int main( int argc, char** argv )
{
int i, file_index;
unsigned int id;
- char filename[1024 + 4];
- char alt_filename[1024 + 4];
+ char filename[1024 + 5];
+ char alt_filename[1024 + 5];
char* execname;
char* fname;
@@ -270,8 +270,8 @@ int main( int argc, char** argv )
#ifndef macintosh
if ( i >= 0 )
{
- strncpy( filename + strlen( filename ), ".ttf", 4 );
- strncpy( alt_filename + strlen( alt_filename ), ".ttc", 4 );
+ strncpy( filename + strlen( filename ), ".ttf", 5 );
+ strncpy( alt_filename + strlen( alt_filename ), ".ttc", 5 );
}
#endif
i = strlen( filename );
--- freetype-2.9.1/ft2demos-2.9.1/src/fttimer.c
+++ freetype-2.9.1/ft2demos-2.9.1/src/fttimer.c
@@ -162,8 +162,8 @@
char** argv )
{
int i, total, base, rendered_glyphs;
- char filename[1024 + 4];
- char alt_filename[1024 + 4];
+ char filename[1024 + 5];
+ char alt_filename[1024 + 5];
long t, t0, tz0;
@@ -230,8 +230,8 @@
if ( i >= 0 )
{
- strncpy( filename + strlen( filename ), ".ttf", 4 );
- strncpy( alt_filename + strlen( alt_filename ), ".ttc", 4 );
+ strncpy( filename + strlen( filename ), ".ttf", 5 );
+ strncpy( alt_filename + strlen( alt_filename ), ".ttc", 5 );
}
/* Initialize engine */

14
SOURCES/ftconfig.h Normal file
View File

@ -0,0 +1,14 @@
#ifndef __FTCONFIG_H__MULTILIB
#define __FTCONFIG_H__MULTILIB
#include <bits/wordsize.h>
#if __WORDSIZE == 32
# include "ftconfig-32.h"
#elif __WORDSIZE == 64
# include "ftconfig-64.h"
#else
# error "unexpected value for __WORDSIZE macro"
#endif
#endif

1016
SPECS/freetype.spec Normal file

File diff suppressed because it is too large Load Diff