Backport fix for bug 816692

This commit is contained in:
Mads Kiilerich 2012-04-27 01:13:41 +02:00
parent 3be4509dbc
commit 7b868394f2
2 changed files with 59 additions and 1 deletions

View File

@ -0,0 +1,53 @@
From c10866db66c0d462ea7c2c38bb01740bcfb4fcb4 Mon Sep 17 00:00:00 2001
From: Slava Dubrovskiy <dubrsl@altlinux.org>
Date: Tue, 14 Feb 2012 13:44:00 -0500
Subject: [PATCH] Fix not linked with libpulse (issue 418)
Signed-off-by: Slava Dubrovskiy <dubrsl@altlinux.org>
---
channels/drdynvc/audin/pulse/CMakeLists.txt | 2 +-
channels/drdynvc/tsmf/pulse/CMakeLists.txt | 2 +-
channels/rdpsnd/pulse/CMakeLists.txt | 2 +-
3 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/channels/drdynvc/audin/pulse/CMakeLists.txt b/channels/drdynvc/audin/pulse/CMakeLists.txt
index 10d6afe..fd6e25e 100644
--- a/channels/drdynvc/audin/pulse/CMakeLists.txt
+++ b/channels/drdynvc/audin/pulse/CMakeLists.txt
@@ -28,7 +28,7 @@ add_library(audin_pulse ${AUDIN_PULSE_SRCS})
set_target_properties(audin_pulse PROPERTIES PREFIX "")
target_link_libraries(audin_pulse freerdp-utils)
-target_link_libraries(audin_pulse ${PULSE_LIBRARIES})
+target_link_libraries(audin_pulse ${PULSEAUDIO_LIBRARY})
install(TARGETS audin_pulse DESTINATION ${FREERDP_PLUGIN_PATH})
diff --git a/channels/drdynvc/tsmf/pulse/CMakeLists.txt b/channels/drdynvc/tsmf/pulse/CMakeLists.txt
index 373d4d3..144b5ff 100644
--- a/channels/drdynvc/tsmf/pulse/CMakeLists.txt
+++ b/channels/drdynvc/tsmf/pulse/CMakeLists.txt
@@ -28,7 +28,7 @@ add_library(tsmf_pulse ${TSMF_PULSE_SRCS})
set_target_properties(tsmf_pulse PROPERTIES PREFIX "")
target_link_libraries(tsmf_pulse freerdp-utils)
-target_link_libraries(tsmf_pulse ${PULSE_LIBRARIES})
+target_link_libraries(tsmf_pulse ${PULSEAUDIO_LIBRARY})
install(TARGETS tsmf_pulse DESTINATION ${FREERDP_PLUGIN_PATH})
diff --git a/channels/rdpsnd/pulse/CMakeLists.txt b/channels/rdpsnd/pulse/CMakeLists.txt
index 4460daf..bac3e51 100644
--- a/channels/rdpsnd/pulse/CMakeLists.txt
+++ b/channels/rdpsnd/pulse/CMakeLists.txt
@@ -28,6 +28,6 @@ add_library(rdpsnd_pulse ${RDPSND_PULSE_SRCS})
set_target_properties(rdpsnd_pulse PROPERTIES PREFIX "")
target_link_libraries(rdpsnd_pulse freerdp-utils)
-target_link_libraries(rdpsnd_pulse ${PULSE_LIBRARIES})
+target_link_libraries(rdpsnd_pulse ${PULSEAUDIO_LIBRARY})
install(TARGETS rdpsnd_pulse DESTINATION ${FREERDP_PLUGIN_PATH})
--
1.7.10

View File

@ -1,6 +1,6 @@
Name: freerdp
Version: 1.0.1
Release: 5%{?dist}
Release: 6%{?dist}
Summary: Remote Desktop Protocol client
Group: Applications/Communications
@ -9,6 +9,7 @@ URL: http://www.freerdp.com/
Source0: https://github.com/downloads/FreeRDP/FreeRDP/%{name}-%{version}.tar.gz
# https://github.com/FreeRDP/FreeRDP/commit/165d39a290a109c0af16a1d223d1426cb524a844 backport
Patch0: fastpath_send_input_pdu-sec_bytes.patch
Patch1: c10866db66c0d462ea7c2c38bb01740bcfb4fcb4.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: cmake
@ -75,6 +76,7 @@ developing applications that use %{name}-libs.
%setup -q
%patch0 -p1
%patch1 -p1
cat << EOF > xfreerdp.desktop
[Desktop Entry]
@ -164,6 +166,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%changelog
* Thu Apr 26 2012 Mads Kiilerich <mads@kiilerich.com> - 1.0.1-6
- Backport fix for bug 816692
* Wed Feb 29 2012 Mads Kiilerich <mads@kiilerich.com> - 1.0.1-5
- Use new upstream tar with standard naming
- Use _isa for subpackage dependencies