Disable FFmpeg support
Resolves: rhbz#2242028
This commit is contained in:
parent
018e161518
commit
6a5a200a45
@ -1,42 +0,0 @@
|
|||||||
From 7f55c97d60453738323e0ecafe6d357019528227 Mon Sep 17 00:00:00 2001
|
|
||||||
From: akallabeth <akallabeth@posteo.net>
|
|
||||||
Date: Tue, 14 Feb 2023 07:48:54 +0100
|
|
||||||
Subject: [PATCH] Fixed #8686: Update h264 to use new FFMPEG API
|
|
||||||
|
|
||||||
---
|
|
||||||
channels/tsmf/client/ffmpeg/tsmf_ffmpeg.c | 2 ++
|
|
||||||
libfreerdp/codec/h264_ffmpeg.c | 2 ++
|
|
||||||
2 files changed, 4 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/channels/tsmf/client/ffmpeg/tsmf_ffmpeg.c b/channels/tsmf/client/ffmpeg/tsmf_ffmpeg.c
|
|
||||||
index c14877b43ac..21533746438 100644
|
|
||||||
--- a/channels/tsmf/client/ffmpeg/tsmf_ffmpeg.c
|
|
||||||
+++ b/channels/tsmf/client/ffmpeg/tsmf_ffmpeg.c
|
|
||||||
@@ -235,8 +235,10 @@ static BOOL tsmf_ffmpeg_init_stream(ITSMFDecoder* decoder, const TS_AM_MEDIA_TYP
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
+#if LIBAVCODEC_VERSION_INT < AV_VERSION_INT(59, 18, 100)
|
|
||||||
if (mdecoder->codec->capabilities & AV_CODEC_CAP_TRUNCATED)
|
|
||||||
mdecoder->codec_context->flags |= AV_CODEC_FLAG_TRUNCATED;
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
return TRUE;
|
|
||||||
}
|
|
||||||
diff --git a/libfreerdp/codec/h264_ffmpeg.c b/libfreerdp/codec/h264_ffmpeg.c
|
|
||||||
index 4e3ba8f9282..9c445b8253a 100644
|
|
||||||
--- a/libfreerdp/codec/h264_ffmpeg.c
|
|
||||||
+++ b/libfreerdp/codec/h264_ffmpeg.c
|
|
||||||
@@ -529,10 +529,12 @@ static BOOL libavcodec_init(H264_CONTEXT* h264)
|
|
||||||
goto EXCEPTION;
|
|
||||||
}
|
|
||||||
|
|
||||||
+#if LIBAVCODEC_VERSION_INT < AV_VERSION_INT(59, 18, 100)
|
|
||||||
if (sys->codecDecoder->capabilities & AV_CODEC_CAP_TRUNCATED)
|
|
||||||
{
|
|
||||||
sys->codecDecoderContext->flags |= AV_CODEC_FLAG_TRUNCATED;
|
|
||||||
}
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
#ifdef WITH_VAAPI
|
|
||||||
|
|
16
freerdp.spec
16
freerdp.spec
@ -1,6 +1,8 @@
|
|||||||
# Can be rebuilt with OpenH264 support enabled by passing # "--with=openh264"
|
# Can be rebuilt with FFmpeg/OpenH264 support enabled by passing
|
||||||
# to mock/rpmbuild; or by globally setting the following variable:
|
# "--with=ffmpeg", or "--with=openh264" to mock/rpmbuild; or by globally
|
||||||
|
# setting these variables:
|
||||||
|
# https://bugzilla.redhat.com/show_bug.cgi?id=2242028
|
||||||
|
#global _with_ffmpeg 1
|
||||||
#global _with_openh264 1
|
#global _with_openh264 1
|
||||||
|
|
||||||
# Can be rebuilt with OpenCL support enabled by passing # "--with=opencl"
|
# Can be rebuilt with OpenCL support enabled by passing # "--with=opencl"
|
||||||
@ -22,13 +24,10 @@
|
|||||||
%if 0%{?fedora} || 0%{?rhel} >= 8
|
%if 0%{?fedora} || 0%{?rhel} >= 8
|
||||||
%global _with_lame 1
|
%global _with_lame 1
|
||||||
%endif
|
%endif
|
||||||
%if 0%{?fedora} >= 39
|
|
||||||
%global _with_ffmpeg 1
|
|
||||||
%endif
|
|
||||||
|
|
||||||
Name: freerdp
|
Name: freerdp
|
||||||
Version: 2.11.2
|
Version: 2.11.2
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
Summary: Free implementation of the Remote Desktop Protocol (RDP)
|
Summary: Free implementation of the Remote Desktop Protocol (RDP)
|
||||||
License: ASL 2.0
|
License: ASL 2.0
|
||||||
@ -293,6 +292,9 @@ find %{buildroot} -name "*.a" -delete
|
|||||||
%{_libdir}/pkgconfig/winpr-tools2.pc
|
%{_libdir}/pkgconfig/winpr-tools2.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Oct 25 2023 Ondrej Holy <oholy@redhat.com> - 2:2.11.2-3
|
||||||
|
- Disable FFmpeg support (#2242028).
|
||||||
|
|
||||||
* Mon Oct 09 2023 John Wiele <jwiele@redhat.com> - 2:2.11.2-2
|
* Mon Oct 09 2023 John Wiele <jwiele@redhat.com> - 2:2.11.2-2
|
||||||
- Enable optional build with OpenCL support.
|
- Enable optional build with OpenCL support.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user