ea6ff99048
Signed-off-by: Antonio Torres <antorres@redhat.com>
103 lines
2.7 KiB
Diff
103 lines
2.7 KiB
Diff
From e6f7c9d4c2af1cda7760ca8155166bb5d4d541d0 Mon Sep 17 00:00:00 2001
|
|
From: Alexander Scheel <ascheel@redhat.com>
|
|
Date: Wed, 8 May 2019 12:58:02 -0400
|
|
Subject: [PATCH] Don't generate certificates in reproducible builds
|
|
|
|
Signed-off-by: Alexander Scheel <ascheel@redhat.com>
|
|
---
|
|
Make.inc.in | 5 +++++
|
|
configure | 3 +++
|
|
configure.ac | 3 +++
|
|
raddb/all.mk | 4 ++++
|
|
4 files changed, 15 insertions(+)
|
|
|
|
diff --git a/Make.inc.in b/Make.inc.in
|
|
index 0b2cd74de8..8c623cf95c 100644
|
|
--- a/Make.inc.in
|
|
+++ b/Make.inc.in
|
|
@@ -174,6 +174,10 @@ else
|
|
TESTBIN = ./$(BUILD_DIR)/bin
|
|
endif
|
|
|
|
+#
|
|
+# With reproducible builds, do not generate certificates during installation
|
|
+#
|
|
+ENABLE_REPRODUCIBLE_BUILDS = @ENABLE_REPRODUCIBLE_BUILDS@
|
|
|
|
#
|
|
# For creating documentation via doc/all.mk
|
|
diff --git a/configure b/configure
|
|
index 5041ca264f..ed01ee2bdd 100755
|
|
--- a/configure
|
|
+++ b/configure
|
|
@@ -679,6 +679,7 @@ AUTOCONF
|
|
ACLOCAL
|
|
RUSERS
|
|
SNMPWALK
|
|
+ENABLE_REPRODUCIBLE_BUILDS
|
|
SNMPGET
|
|
openssl_version_check_config
|
|
WITH_DHCP
|
|
@@ -6976,6 +6977,7 @@ fi
|
|
|
|
|
|
# Check whether --enable-reproducible-builds was given.
|
|
+ENABLE_REPRODUCIBLE_BUILDS=yes
|
|
if test ${enable_reproducible_builds+y}
|
|
then :
|
|
enableval=$enable_reproducible_builds; case "$enableval" in
|
|
@@ -6987,6 +6989,7 @@ printf "%s\n" "#define ENABLE_REPRODUCIBLE_BUILDS 1" >>confdefs.h
|
|
;;
|
|
*)
|
|
reproducible_builds=no
|
|
+ ENABLE_REPRODUCIBLE_BUILDS=no
|
|
esac
|
|
|
|
fi
|
|
diff --git a/configure.ac b/configure.ac
|
|
index ce4d9b0ae5..790cbf02a0 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -697,6 +697,7 @@ AC_SUBST([openssl_version_check_config])
|
|
dnl #
|
|
dnl # extra argument: --enable-reproducible-builds
|
|
dnl #
|
|
+ENABLE_REPRODUCIBLE_BUILDS=yes
|
|
AC_ARG_ENABLE(reproducible-builds,
|
|
[AS_HELP_STRING([--enable-reproducible-builds],
|
|
[ensure the build does not change each time])],
|
|
@@ -708,8 +709,10 @@ AC_ARG_ENABLE(reproducible-builds,
|
|
;;
|
|
*)
|
|
reproducible_builds=no
|
|
+ ENABLE_REPRODUCIBLE_BUILDS=no
|
|
esac ]
|
|
)
|
|
+AC_SUBST(ENABLE_REPRODUCIBLE_BUILDS)
|
|
|
|
dnl #
|
|
dnl # Enable the -fsanitize=fuzzer and link in the address sanitizer
|
|
|
|
|
|
|
|
dnl #############################################################
|
|
diff --git a/raddb/all.mk b/raddb/all.mk
|
|
index c966edd657..c8e976a499 100644
|
|
--- a/raddb/all.mk
|
|
+++ b/raddb/all.mk
|
|
@@ -124,7 +124,11 @@ $(R)$(raddbdir)/users: $(R)$(modconfdir)/files/authorize
|
|
ifneq "$(LOCAL_CERT_PRODUCTS)" ""
|
|
$(LOCAL_CERT_PRODUCTS):
|
|
@echo BOOTSTRAP raddb/certs/
|
|
+ifeq "$(ENABLE_REPRODUCIBLE_BUILDS)" "yes"
|
|
+ @$(MAKE) -C $(R)$(raddbdir)/certs/ passwords.mk
|
|
+else
|
|
@$(MAKE) -C $(R)$(raddbdir)/certs/
|
|
+endif
|
|
|
|
# Bootstrap is special
|
|
$(R)$(raddbdir)/certs/bootstrap: | raddb/certs/bootstrap $(LOCAL_CERT_PRODUCTS)
|
|
--
|
|
2.21.0
|
|
|