Resolves: #689045 Using rlm_perl cause radiusd failed to start
Fix configure typo which caused lt_dladvise_* functions to be skipped. run autogen.sh because HAVE_LT_DLADVISE_INIT isn't in src/main/autogen.h Implemented by: freeradius-lt-dladvise.patch
This commit is contained in:
parent
efd9eca8b1
commit
f1e2286b0e
38
freeradius-lt-dladvise.patch
Normal file
38
freeradius-lt-dladvise.patch
Normal file
@ -0,0 +1,38 @@
|
||||
diff -r -u freeradius-server-2.1.10.orig/autogen.sh freeradius-server-2.1.10/autogen.sh
|
||||
--- freeradius-server-2.1.10.orig/autogen.sh 2010-09-28 07:03:56.000000000 -0400
|
||||
+++ freeradius-server-2.1.10/autogen.sh 2011-03-24 10:36:26.000000000 -0400
|
||||
@@ -16,6 +16,6 @@
|
||||
for F in $mysubdirs
|
||||
do
|
||||
echo "Configuring in $F..."
|
||||
- (cd $F && grep "^AC_CONFIG_HEADER" configure.in > /dev/null && autoheader -I$parentdir)
|
||||
+ (cd $F && grep "^AC_CONFIG_HEADER" configure.in > /dev/null || exit 0; autoheader -I$parentdir)
|
||||
(cd $F && autoconf -I$parentdir)
|
||||
done
|
||||
Only in freeradius-server-2.1.10: autogen.sh~
|
||||
diff -r -u freeradius-server-2.1.10.orig/configure freeradius-server-2.1.10/configure
|
||||
--- freeradius-server-2.1.10.orig/configure 2010-09-28 07:03:56.000000000 -0400
|
||||
+++ freeradius-server-2.1.10/configure 2011-03-23 18:09:45.000000000 -0400
|
||||
@@ -25121,7 +25121,7 @@
|
||||
if test $ac_cv_func_lt_dladvise_init = yes; then
|
||||
|
||||
cat >>confdefs.h <<\_ACEOF
|
||||
-#define HAVE_HAVE_LT_DLADVISE_INIT
|
||||
+#define HAVE_LT_DLADVISE_INIT
|
||||
_ACEOF
|
||||
|
||||
fi
|
||||
Only in freeradius-server-2.1.10: configure~
|
||||
diff -r -u freeradius-server-2.1.10.orig/configure.in freeradius-server-2.1.10/configure.in
|
||||
--- freeradius-server-2.1.10.orig/configure.in 2010-09-28 07:03:56.000000000 -0400
|
||||
+++ freeradius-server-2.1.10/configure.in 2011-03-23 18:09:33.000000000 -0400
|
||||
@@ -936,7 +936,7 @@
|
||||
|
||||
old_LIBS="$LIBS"
|
||||
LIBS="$LIBS $LIBLTDL"
|
||||
-AC_CHECK_FUNC(lt_dladvise_init, AC_DEFINE(HAVE_HAVE_LT_DLADVISE_INIT, [], [Do we have the lt_dladvise_init function]))
|
||||
+AC_CHECK_FUNC(lt_dladvise_init, AC_DEFINE(HAVE_LT_DLADVISE_INIT, [], [Do we have the lt_dladvise_init function]))
|
||||
LIBS="$old_LIBS"
|
||||
|
||||
dnl Check for libcrypt
|
||||
Only in freeradius-server-2.1.10: configure.in~
|
@ -1,7 +1,7 @@
|
||||
Summary: High-performance and highly configurable free RADIUS server
|
||||
Name: freeradius
|
||||
Version: 2.1.10
|
||||
Release: 6%{?dist}
|
||||
Release: 7%{?dist}
|
||||
License: GPLv2+ and LGPLv2+
|
||||
Group: System Environment/Daemons
|
||||
URL: http://www.freeradius.org/
|
||||
@ -13,6 +13,13 @@ Source103: freeradius-pam-conf
|
||||
|
||||
Patch1: freeradius-cert-config.patch
|
||||
Patch2: freeradius-radtest-ipv6.patch
|
||||
# WARNING, when the lt-dladvise patch is removed the autogen.sh in the
|
||||
# prep section should be removed as well, it's only necessary because
|
||||
# upstream did not regenerate headers via autoheader which caused the
|
||||
# newly added HAVE_LT_DLADVISE_INIT conditional to be omitted which is
|
||||
# necessary to turn on the lt_dladvise* functions which is necessary
|
||||
# to address bz #689045, (unresolved link errors for perl & python)
|
||||
Patch3: freeradius-lt-dladvise.patch
|
||||
|
||||
Obsoletes: freeradius-devel
|
||||
Obsoletes: freeradius-libs
|
||||
@ -144,8 +151,10 @@ This plugin provides the unixODBC support for the FreeRADIUS server project.
|
||||
%setup -q -n freeradius-server-%{version}
|
||||
%patch1 -p1 -b .cert-config
|
||||
%patch2 -p1 -b .radtest-ipv6
|
||||
%patch3 -p1 -b .lt-dladvise
|
||||
# Some source files mistakenly have execute permissions set
|
||||
find $RPM_BUILD_DIR/freeradius-server-%{version} \( -name '*.c' -o -name '*.h' \) -a -perm /0111 -exec chmod a-x {} +
|
||||
./autogen.sh
|
||||
|
||||
%build
|
||||
%ifarch s390 s390x
|
||||
@ -567,7 +576,12 @@ exit 0
|
||||
%{_libdir}/freeradius/rlm_sql_unixodbc-%{version}.so
|
||||
|
||||
%changelog
|
||||
=======
|
||||
* Wed Mar 23 2011 John Dennis <jdennis@redhat.com> - 2.1.10-7
|
||||
- Resolves: #689045 Using rlm_perl cause radiusd failed to start
|
||||
Fix configure typo which caused lt_dladvise_* functions to be skipped.
|
||||
run autogen.sh because HAVE_LT_DLADVISE_INIT isn't in src/main/autogen.h
|
||||
Implemented by: freeradius-lt-dladvise.patch
|
||||
|
||||
* Wed Mar 23 2011 John Dennis <jdennis@redhat.com> - 2.1.10-6
|
||||
- Resolves: #599528 - make radtest IPv6 compatible
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user