Update to 3.0.24
Signed-off-by: Antonio Torres <antorres@redhat.com>
This commit is contained in:
parent
07d2148621
commit
d5a8b5f69f
1
.gitignore
vendored
1
.gitignore
vendored
@ -36,3 +36,4 @@ freeradius-*.src.rpm
|
||||
/freeradius-server-3.0.21.tar.bz2
|
||||
/freeradius-server-3.0.22.tar.bz2
|
||||
/freeradius-server-3.0.23.tar.bz2
|
||||
/freeradius-server-3.0.24.tar.bz2
|
||||
|
@ -1,32 +0,0 @@
|
||||
commit 1ce4508c92493cf03ea1b3c42e83540b387884fa
|
||||
Author: Antonio Torres <antorres@redhat.com>
|
||||
Date: Fri Jul 2 07:12:48 2021 -0400
|
||||
Subject: [PATCH] debug: don't set resource hard limit to zero
|
||||
|
||||
Setting the resource hard limit to zero is irreversible, meaning if it
|
||||
is set to zero then there is no way to set it higher. This means
|
||||
enabling core dump is not possible, since setting a new resource limit
|
||||
for RLIMIT_CORE would fail. By only setting the soft limit to zero, we
|
||||
can disable and enable core dumps without failures.
|
||||
|
||||
This fix is present in both main and 3.0.x upstream branches.
|
||||
|
||||
Ticket in RHEL Bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id=1977572
|
||||
Signed-off-by: Antonio Torres antorres@redhat.com
|
||||
---
|
||||
src/lib/debug.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/lib/debug.c b/src/lib/debug.c
|
||||
index 576bcb2a65..6330c9cb66 100644
|
||||
--- a/src/lib/debug.c
|
||||
+++ b/src/lib/debug.c
|
||||
@@ -599,7 +599,7 @@ int fr_set_dumpable(bool allow_core_dumps)
|
||||
struct rlimit no_core;
|
||||
|
||||
no_core.rlim_cur = 0;
|
||||
- no_core.rlim_max = 0;
|
||||
+ no_core.rlim_max = core_limits.rlim_max;
|
||||
|
||||
if (setrlimit(RLIMIT_CORE, &no_core) < 0) {
|
||||
fr_strerror_printf("Failed disabling core dumps: %s", fr_syserror(errno));
|
@ -63,10 +63,10 @@ index c2c599c92b..3d4403a844 100755
|
||||
# Extract the first word of "perl", so it can be a program name with args.
|
||||
set dummy perl; ac_word=$2
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index a7abf0025a..35b013f4af 100644
|
||||
index ce4d9b0ae5..790cbf02a0 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -619,6 +619,7 @@ AC_SUBST([openssl_version_check_config])
|
||||
@@ -697,6 +697,7 @@ AC_SUBST([openssl_version_check_config])
|
||||
dnl #
|
||||
dnl # extra argument: --enable-reproducible-builds
|
||||
dnl #
|
||||
@ -74,7 +74,7 @@ index a7abf0025a..35b013f4af 100644
|
||||
AC_ARG_ENABLE(reproducible-builds,
|
||||
[AS_HELP_STRING([--enable-reproducible-builds],
|
||||
[ensure the build does not change each time])],
|
||||
@@ -630,8 +631,10 @@ AC_ARG_ENABLE(reproducible-builds,
|
||||
@@ -708,8 +709,10 @@ AC_ARG_ENABLE(reproducible-builds,
|
||||
;;
|
||||
*)
|
||||
reproducible_builds=no
|
||||
@ -83,6 +83,10 @@ index a7abf0025a..35b013f4af 100644
|
||||
)
|
||||
+AC_SUBST(ENABLE_REPRODUCIBLE_BUILDS)
|
||||
|
||||
dnl #
|
||||
dnl # Enable the -fsanitize=fuzzer and link in the address sanitizer
|
||||
|
||||
|
||||
|
||||
dnl #############################################################
|
||||
diff --git a/raddb/all.mk b/raddb/all.mk
|
||||
|
@ -1,7 +1,7 @@
|
||||
Summary: High-performance and highly configurable free RADIUS server
|
||||
Name: freeradius
|
||||
Version: 3.0.23
|
||||
Release: 7%{?dist}
|
||||
Version: 3.0.24
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+ and LGPLv2+
|
||||
URL: http://www.freeradius.org/
|
||||
|
||||
@ -25,7 +25,6 @@ Patch2: freeradius-Use-system-crypto-policy-by-default.patch
|
||||
Patch3: freeradius-bootstrap-create-only.patch
|
||||
Patch4: freeradius-no-buildtime-cert-gen.patch
|
||||
Patch5: freeradius-bootstrap-make-permissions.patch
|
||||
Patch6: freeradius-Fix-resource-hard-limit-error.patch
|
||||
|
||||
%global docdir %{?_pkgdocdir}%{!?_pkgdocdir:%{_docdir}/%{name}-%{version}}
|
||||
|
||||
@ -208,7 +207,6 @@ This plugin provides the REST support for the FreeRADIUS server project.
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
%patch6 -p1
|
||||
|
||||
%build
|
||||
# Force compile/link options, extra security for network facing daemon
|
||||
@ -438,6 +436,7 @@ exit 0
|
||||
%attr(640,root,radiusd) %config(noreplace) /etc/raddb/mods-config/preprocess/*
|
||||
|
||||
%dir %attr(750,root,radiusd) /etc/raddb/mods-config/sql
|
||||
%attr(640,root,radiusd) %config(noreplace) /etc/raddb/mods-config/sql/*
|
||||
%dir %attr(750,root,radiusd) /etc/raddb/mods-config/sql/counter
|
||||
%dir %attr(750,root,radiusd) /etc/raddb/mods-config/sql/cui
|
||||
%dir %attr(750,root,radiusd) /etc/raddb/mods-config/sql/ippool
|
||||
@ -896,6 +895,10 @@ exit 0
|
||||
%attr(640,root,radiusd) %config(noreplace) /etc/raddb/mods-available/rest
|
||||
|
||||
%changelog
|
||||
* Thu Sep 30 2021 Antonio Torres <antorres@redhat.com> - 3.0.24-1
|
||||
- Update to 3.0.24.
|
||||
Resolves: bz#2009036
|
||||
|
||||
* Tue Sep 14 2021 Sahana Prasad <sahana@redhat.com> - 3.0.23-7
|
||||
- Rebuilt with OpenSSL 3.0.0
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (freeradius-server-3.0.23.tar.bz2) = 2369378a448035706fac77b4eddd28b950fbb587edefb5be6cf579043435cdec911b4a5326cfeabd05c28bb964e53027bcd1cd8a6a56013836f041a10326ef1a
|
||||
SHA512 (freeradius-server-3.0.24.tar.bz2) = 12da42aa406d97ff15b423b7b279b7cc9dd4c317296b1b0fa019fb21988d9501507b58ad2d6753db4846651f06a6a67be8097cb0b564a65b1b1454777e090997
|
||||
|
Loading…
Reference in New Issue
Block a user