Remove helper SQL script from package
This script belongs to an unsupported feature (SQL) and requires a new dependency that is not available in RHEL10, so remove the script altogether. Resolves: RHEL-31745 Signed-off-by: Antonio Torres <antorres@redhat.com>
This commit is contained in:
parent
465934bd49
commit
8d655c5e18
@ -5,7 +5,7 @@ Subject: Remove Antora docs from sources
|
|||||||
These files are meant to be used for upstream web documentation, so we don't need them for
|
These files are meant to be used for upstream web documentation, so we don't need them for
|
||||||
distribution in RHEL.
|
distribution in RHEL.
|
||||||
|
|
||||||
Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=2238511
|
Resolves: https://issues.redhat.com/browse/RHEL-31184
|
||||||
Signed-off-by: Antonio Torres <antorres@redhat.com>
|
Signed-off-by: Antonio Torres <antorres@redhat.com>
|
||||||
---
|
---
|
||||||
doc/antora/antora.yml | 18 -
|
doc/antora/antora.yml | 18 -
|
||||||
|
31
freeradius-no-sql-scripts.patch
Normal file
31
freeradius-no-sql-scripts.patch
Normal file
@ -0,0 +1,31 @@
|
|||||||
|
From: Antonio Torres <antorres@redhat.com>
|
||||||
|
Date: Wed, 3 Apr 2024
|
||||||
|
Subject: Remove SQL helper script from package
|
||||||
|
|
||||||
|
This helper script is not needed in RHEL since we stopped supporting the
|
||||||
|
freeradius SQL subpackages.
|
||||||
|
|
||||||
|
Resolves: RHEL-31745
|
||||||
|
Signed-off-by: Antonio Torres <antorres@redhat.com>
|
||||||
|
---
|
||||||
|
scripts/all.mk | 5 +----
|
||||||
|
1 file changed, 1 insertion(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/scripts/all.mk b/scripts/all.mk
|
||||||
|
index a6e90aa3eb..2f7845a632 100644
|
||||||
|
--- a/scripts/all.mk
|
||||||
|
+++ b/scripts/all.mk
|
||||||
|
@@ -1,5 +1,5 @@
|
||||||
|
install: $(R)$(sbindir)/rc.radiusd $(R)$(sbindir)/raddebug \
|
||||||
|
- $(R)$(bindir)/radsqlrelay $(R)$(bindir)/radcrypt $(R)$(bindir)/rlm_sqlippool_tool
|
||||||
|
+ $(R)$(bindir)/radsqlrelay $(R)$(bindir)/radcrypt
|
||||||
|
|
||||||
|
$(R)$(sbindir)/rc.radiusd: scripts/rc.radiusd
|
||||||
|
@mkdir -p $(dir $@)
|
||||||
|
@@ -17,6 +17,3 @@ $(R)$(bindir)/radcrypt: scripts/cryptpasswd
|
||||||
|
@mkdir -p $(dir $@)
|
||||||
|
@$(INSTALL) -m 755 $< $@
|
||||||
|
|
||||||
|
-$(R)$(bindir)/rlm_sqlippool_tool: scripts/sql/rlm_sqlippool_tool
|
||||||
|
- @mkdir -p $(dir $@)
|
||||||
|
- @$(INSTALL) -m 755 $< $@
|
@ -1,7 +1,7 @@
|
|||||||
Summary: High-performance and highly configurable free RADIUS server
|
Summary: High-performance and highly configurable free RADIUS server
|
||||||
Name: freeradius
|
Name: freeradius
|
||||||
Version: 3.2.3
|
Version: 3.2.3
|
||||||
Release: 5%{?dist}
|
Release: 6%{?dist}
|
||||||
License: GPL-2.0-or-later AND LGPL-2.0-or-later
|
License: GPL-2.0-or-later AND LGPL-2.0-or-later
|
||||||
URL: http://www.freeradius.org/
|
URL: http://www.freeradius.org/
|
||||||
|
|
||||||
@ -30,6 +30,7 @@ Patch6: freeradius-ldap-infinite-timeout-on-starttls.patch
|
|||||||
Patch7: freeradius-ease-openssl-version-check.patch
|
Patch7: freeradius-ease-openssl-version-check.patch
|
||||||
Patch8: freeradius-configure-c99.patch
|
Patch8: freeradius-configure-c99.patch
|
||||||
Patch9: freeradius-no-antora-docs.patch
|
Patch9: freeradius-no-antora-docs.patch
|
||||||
|
Patch10: freeradius-no-sql-scripts.patch
|
||||||
|
|
||||||
%global docdir %{?_pkgdocdir}%{!?_pkgdocdir:%{_docdir}/%{name}-%{version}}
|
%global docdir %{?_pkgdocdir}%{!?_pkgdocdir:%{_docdir}/%{name}-%{version}}
|
||||||
|
|
||||||
@ -206,20 +207,24 @@ This plugin provides the REST support for the FreeRADIUS server project.
|
|||||||
%setup -q -n %{dist_base}
|
%setup -q -n %{dist_base}
|
||||||
# Note: We explicitly do not make patch backup files because 'make install'
|
# Note: We explicitly do not make patch backup files because 'make install'
|
||||||
# mistakenly includes the backup files, especially problematic for raddb config files.
|
# mistakenly includes the backup files, especially problematic for raddb config files.
|
||||||
%patch1 -p1
|
%patch 1 -p1
|
||||||
%patch2 -p1
|
%patch 2 -p1
|
||||||
%patch3 -p1
|
%patch 3 -p1
|
||||||
%patch4 -p1
|
%patch 4 -p1
|
||||||
%patch5 -p1
|
%patch 5 -p1
|
||||||
%patch6 -p1
|
%patch 6 -p1
|
||||||
%patch7 -p1
|
%patch 7 -p1
|
||||||
%patch8 -p1
|
%patch 8 -p1
|
||||||
%patch9 -p1
|
%patch 9 -p1
|
||||||
|
%patch 10 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# Force compile/link options, extra security for network facing daemon
|
# Force compile/link options, extra security for network facing daemon
|
||||||
%global _hardened_build 1
|
%global _hardened_build 1
|
||||||
|
|
||||||
|
# Enable FIPS support
|
||||||
|
%global build_cflags %{build_cflags} -DWITH_FIPS
|
||||||
|
|
||||||
%global build_ldflags %{build_ldflags} $(python3-config --embed --libs)
|
%global build_ldflags %{build_ldflags} $(python3-config --embed --libs)
|
||||||
export PY3_LIB_DIR="$(python3-config --configdir)"
|
export PY3_LIB_DIR="$(python3-config --configdir)"
|
||||||
export PY3_INC_DIR="$(python3 -c 'import sysconfig; print(sysconfig.get_config_var("INCLUDEPY"))')"
|
export PY3_INC_DIR="$(python3 -c 'import sysconfig; print(sysconfig.get_config_var("INCLUDEPY"))')"
|
||||||
@ -898,6 +903,10 @@ EOF
|
|||||||
%attr(640,root,radiusd) %config(noreplace) /etc/raddb/mods-available/rest
|
%attr(640,root,radiusd) %config(noreplace) /etc/raddb/mods-available/rest
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Apr 04 2024 Antonio Torres <antorres@redhat.com> - 3.2.3-6
|
||||||
|
- Remove SQL helper script from package
|
||||||
|
Resolves: RHEL-31745
|
||||||
|
|
||||||
* Tue Apr 02 2024 Antonio Torres <antorres@redhat.com> - 3.2.3-5
|
* Tue Apr 02 2024 Antonio Torres <antorres@redhat.com> - 3.2.3-5
|
||||||
- Remove Antora docs from package
|
- Remove Antora docs from package
|
||||||
Resolves: RHEL-31184
|
Resolves: RHEL-31184
|
||||||
|
Loading…
Reference in New Issue
Block a user