Rebase to 3.2.0 upstream release
Resolves: #2077687 Signed-off-by: Antonio Torres <antorres@redhat.com>
This commit is contained in:
parent
fdb219a9d2
commit
39a371f96e
1
.gitignore
vendored
1
.gitignore
vendored
@ -38,3 +38,4 @@ freeradius-*.src.rpm
|
||||
/freeradius-server-3.0.23.tar.bz2
|
||||
/freeradius-server-3.0.24.tar.bz2
|
||||
/freeradius-server-3.0.25.tar.bz2
|
||||
/freeradius-server-3.2.0.tar.bz2
|
||||
|
@ -6,10 +6,10 @@ Subject: [PATCH] Don't generate certificates in reproducible builds
|
||||
Signed-off-by: Alexander Scheel <ascheel@redhat.com>
|
||||
---
|
||||
Make.inc.in | 5 +++++
|
||||
configure | 4 ++++
|
||||
configure | 3 +++
|
||||
configure.ac | 3 +++
|
||||
raddb/all.mk | 4 ++++
|
||||
4 files changed, 16 insertions(+)
|
||||
4 files changed, 15 insertions(+)
|
||||
|
||||
diff --git a/Make.inc.in b/Make.inc.in
|
||||
index 0b2cd74de8..8c623cf95c 100644
|
||||
@ -27,26 +27,26 @@ index 0b2cd74de8..8c623cf95c 100644
|
||||
#
|
||||
# For creating documentation via doc/all.mk
|
||||
diff --git a/configure b/configure
|
||||
index c2c599c92b..3d4403a844 100755
|
||||
index b9adc3be20..5bdb2f081b 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -654,6 +654,7 @@ ACLOCAL
|
||||
@@ -679,6 +679,7 @@ AUTOCONF
|
||||
ACLOCAL
|
||||
RUSERS
|
||||
SNMPWALK
|
||||
SNMPGET
|
||||
+ENABLE_REPRODUCIBLE_BUILDS
|
||||
SNMPGET
|
||||
openssl_version_check_config
|
||||
WITH_DHCP
|
||||
modconfdir
|
||||
@@ -5586,6 +5587,7 @@ else
|
||||
@@ -7031,6 +7032,7 @@ else
|
||||
fi
|
||||
|
||||
|
||||
+ENABLE_REPRODUCIBLE_BUILDS=yes
|
||||
# Check whether --enable-reproducible-builds was given.
|
||||
if test "${enable_reproducible_builds+set}" = set; then :
|
||||
enableval=$enable_reproducible_builds; case "$enableval" in
|
||||
@@ -5597,6 +5599,7 @@ $as_echo "#define ENABLE_REPRODUCIBLE_BUILDS 1" >>confdefs.h
|
||||
if test ${enable_reproducible_builds+y}
|
||||
then :
|
||||
@@ -7043,6 +7045,7 @@ printf "%s\n" "#define ENABLE_REPRODUCIBLE_BUILDS 1" >>confdefs.h
|
||||
;;
|
||||
*)
|
||||
reproducible_builds=no
|
||||
@ -54,14 +54,7 @@ index c2c599c92b..3d4403a844 100755
|
||||
esac
|
||||
|
||||
fi
|
||||
@@ -5604,6 +5607,7 @@ fi
|
||||
|
||||
|
||||
|
||||
+
|
||||
CHECKRAD=checkrad
|
||||
# Extract the first word of "perl", so it can be a program name with args.
|
||||
set dummy perl; ac_word=$2
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index ce4d9b0ae5..790cbf02a0 100644
|
||||
--- a/configure.ac
|
||||
|
@ -1,7 +1,7 @@
|
||||
Summary: High-performance and highly configurable free RADIUS server
|
||||
Name: freeradius
|
||||
Version: 3.0.25
|
||||
Release: 8%{?dist}
|
||||
Version: 3.2.0
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+ and LGPLv2+
|
||||
URL: http://www.freeradius.org/
|
||||
|
||||
@ -469,6 +469,8 @@ EOF
|
||||
%attr(640,root,radiusd) %config(noreplace) /etc/raddb/sites-available/totp
|
||||
%attr(640,root,radiusd) %config(noreplace) /etc/raddb/sites-available/channel_bindings
|
||||
%attr(640,root,radiusd) %config(noreplace) /etc/raddb/sites-available/challenge
|
||||
%attr(640,root,radiusd) %config(noreplace) /etc/raddb/sites-available/google-ldap-auth
|
||||
%attr(640,root,radiusd) %config(noreplace) /etc/raddb/sites-available/tls-cache
|
||||
|
||||
# sites-enabled
|
||||
# symlink: /etc/raddb/sites-enabled/xxx -> ../sites-available/xxx
|
||||
@ -482,7 +484,7 @@ EOF
|
||||
%attr(640,root,radiusd) %config(noreplace) /etc/raddb/mods-available/always
|
||||
%attr(640,root,radiusd) %config(noreplace) /etc/raddb/mods-available/attr_filter
|
||||
%attr(640,root,radiusd) %config(noreplace) /etc/raddb/mods-available/cache
|
||||
%attr(640,root,radiusd) %config(noreplace) /etc/raddb/mods-available/cache_eap
|
||||
%attr(640,root,radiusd) %config(noreplace) /etc/raddb/mods-available/cache_auth
|
||||
%attr(640,root,radiusd) %config(noreplace) /etc/raddb/mods-available/chap
|
||||
%attr(640,root,radiusd) %config(noreplace) /etc/raddb/mods-available/counter
|
||||
%attr(640,root,radiusd) %config(noreplace) /etc/raddb/mods-available/cui
|
||||
@ -507,6 +509,8 @@ EOF
|
||||
%attr(640,root,radiusd) %config(noreplace) /etc/raddb/mods-available/idn
|
||||
%attr(640,root,radiusd) %config(noreplace) /etc/raddb/mods-available/inner-eap
|
||||
%attr(640,root,radiusd) %config(noreplace) /etc/raddb/mods-available/ippool
|
||||
%attr(640,root,radiusd) %config(noreplace) /etc/raddb/mods-available/json
|
||||
%attr(640,root,radiusd) %config(noreplace) /etc/raddb/mods-available/ldap_google
|
||||
%attr(640,root,radiusd) %config(noreplace) /etc/raddb/mods-available/linelog
|
||||
%attr(640,root,radiusd) %config(noreplace) /etc/raddb/mods-available/logintime
|
||||
%attr(640,root,radiusd) %config(noreplace) /etc/raddb/mods-available/mac2ip
|
||||
@ -514,7 +518,6 @@ EOF
|
||||
%attr(640,root,radiusd) %config(noreplace) /etc/raddb/mods-available/mschap
|
||||
%attr(640,root,radiusd) %config(noreplace) /etc/raddb/mods-available/ntlm_auth
|
||||
%attr(640,root,radiusd) %config(noreplace) /etc/raddb/mods-available/opendirectory
|
||||
%attr(640,root,radiusd) %config(noreplace) /etc/raddb/mods-available/otp
|
||||
%attr(640,root,radiusd) %config(noreplace) /etc/raddb/mods-available/pam
|
||||
%attr(640,root,radiusd) %config(noreplace) /etc/raddb/mods-available/pap
|
||||
%attr(640,root,radiusd) %config(noreplace) /etc/raddb/mods-available/passwd
|
||||
@ -547,7 +550,6 @@ EOF
|
||||
%dir %attr(750,root,radiusd) /etc/raddb/mods-enabled
|
||||
%config(missingok) /etc/raddb/mods-enabled/always
|
||||
%config(missingok) /etc/raddb/mods-enabled/attr_filter
|
||||
%config(missingok) /etc/raddb/mods-enabled/cache_eap
|
||||
%config(missingok) /etc/raddb/mods-enabled/chap
|
||||
%config(missingok) /etc/raddb/mods-enabled/date
|
||||
%config(missingok) /etc/raddb/mods-enabled/detail
|
||||
@ -621,7 +623,6 @@ EOF
|
||||
%{_libdir}/freeradius/rlm_cache_rbtree.so
|
||||
%{_libdir}/freeradius/rlm_chap.so
|
||||
%{_libdir}/freeradius/rlm_counter.so
|
||||
%{_libdir}/freeradius/rlm_cram.so
|
||||
%{_libdir}/freeradius/rlm_date.so
|
||||
%{_libdir}/freeradius/rlm_detail.so
|
||||
%{_libdir}/freeradius/rlm_dhcp.so
|
||||
@ -644,10 +645,10 @@ EOF
|
||||
%{_libdir}/freeradius/rlm_expr.so
|
||||
%{_libdir}/freeradius/rlm_files.so
|
||||
%{_libdir}/freeradius/rlm_ippool.so
|
||||
%{_libdir}/freeradius/rlm_json.so
|
||||
%{_libdir}/freeradius/rlm_linelog.so
|
||||
%{_libdir}/freeradius/rlm_logintime.so
|
||||
%{_libdir}/freeradius/rlm_mschap.so
|
||||
%{_libdir}/freeradius/rlm_otp.so
|
||||
%{_libdir}/freeradius/rlm_pam.so
|
||||
%{_libdir}/freeradius/rlm_pap.so
|
||||
%{_libdir}/freeradius/rlm_passwd.so
|
||||
@ -896,6 +897,10 @@ EOF
|
||||
%attr(640,root,radiusd) %config(noreplace) /etc/raddb/mods-available/rest
|
||||
|
||||
%changelog
|
||||
* Tue Jul 19 2022 Antonio Torres <antorres@redhat.com> - 3.2.0-1
|
||||
- Rebase to 3.2.0 upstream release
|
||||
Related: #2077687
|
||||
|
||||
* Wed Jun 29 2022 Antonio Torres <antorres@redhat.com> - 3.0.25-8
|
||||
- Use GID / UID 95 as it's reserved for FreeRADIUS (https://pagure.io/setup/blob/07f8debf03dfb0e5ed36051c13c86c8cd00cd241/f/uidgid#_107)
|
||||
Related: #2095741
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (freeradius-server-3.0.25.tar.bz2) = 984bb65c86c541c91708370340ac6157b4d4d89a4ae7cbc690a9f17ead0e63fb20180333cdc33093877f84b6d40445495d881ae677858cbf60fcfd990fb02ba4
|
||||
SHA512 (freeradius-server-3.2.0.tar.bz2) = e7aa7bfc5a6968cdb860bb565ebd45bc1b3f78a665a9888a8b8dacaa1c5256755468aed33bdffe39465f8678c1fb9d6f47f0dbcf0178dfdcb38d99e3bc4b747d
|
||||
|
Loading…
Reference in New Issue
Block a user