Fix C compatibility issue in configure script
Related to: <https://fedoraproject.org/wiki/Changes/PortingToModernC> <https://fedoraproject.org/wiki/Toolchain/PortingToModernC>
This commit is contained in:
parent
ea6ff99048
commit
1793f410aa
35
freeradius-configure-c99.patch
Normal file
35
freeradius-configure-c99.patch
Normal file
@ -0,0 +1,35 @@
|
||||
The backtrace_symbols function expects a pointer to an array of void *
|
||||
values, not a pointer to an array of a single element. Removing the
|
||||
address operator ensures that the right type is used.
|
||||
|
||||
This avoids an unconditional failure of this probe with compilers that
|
||||
treat incompatible pointer types as a compilation error.
|
||||
|
||||
Submitted upstream: <https://github.com/FreeRADIUS/freeradius-server/pull/5246>
|
||||
|
||||
diff --git a/configure b/configure
|
||||
index ed01ee2bdd912f63..1e6d2284779cdd58 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -13390,7 +13390,7 @@ main (void)
|
||||
{
|
||||
|
||||
void *sym[1];
|
||||
- backtrace_symbols(&sym, sizeof(sym))
|
||||
+ backtrace_symbols(sym, sizeof(sym))
|
||||
;
|
||||
return 0;
|
||||
}
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 76320213b51d7bb4..6a689711d6c90483 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -2168,7 +2168,7 @@ if test "x$ac_cv_header_execinfo_h" = "xyes"; then
|
||||
#include <execinfo.h>
|
||||
]], [[
|
||||
void *sym[1];
|
||||
- backtrace_symbols(&sym, sizeof(sym)) ]])],[
|
||||
+ backtrace_symbols(sym, sizeof(sym)) ]])],[
|
||||
AC_MSG_RESULT(yes)
|
||||
ac_cv_lib_execinfo_backtrace_symbols="yes"
|
||||
],[
|
@ -1,7 +1,7 @@
|
||||
Summary: High-performance and highly configurable free RADIUS server
|
||||
Name: freeradius
|
||||
Version: 3.2.3
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
License: GPL-2.0-or-later AND LGPL-2.0-or-later
|
||||
URL: http://www.freeradius.org/
|
||||
|
||||
@ -28,6 +28,7 @@ Patch4: freeradius-no-buildtime-cert-gen.patch
|
||||
Patch5: freeradius-bootstrap-make-permissions.patch
|
||||
Patch6: freeradius-ldap-infinite-timeout-on-starttls.patch
|
||||
Patch7: freeradius-ease-openssl-version-check.patch
|
||||
Patch8: freeradius-configure-c99.patch
|
||||
|
||||
%global docdir %{?_pkgdocdir}%{!?_pkgdocdir:%{_docdir}/%{name}-%{version}}
|
||||
|
||||
@ -211,6 +212,7 @@ This plugin provides the REST support for the FreeRADIUS server project.
|
||||
%patch5 -p1
|
||||
%patch6 -p1
|
||||
%patch7 -p1
|
||||
%patch8 -p1
|
||||
|
||||
%build
|
||||
# Force compile/link options, extra security for network facing daemon
|
||||
@ -894,6 +896,9 @@ EOF
|
||||
%attr(640,root,radiusd) %config(noreplace) /etc/raddb/mods-available/rest
|
||||
|
||||
%changelog
|
||||
* Tue Dec 19 2023 Florian Weimer <fweimer@redhat.com> - 3.2.3-2
|
||||
- Fix C compatibility issue in configure script
|
||||
|
||||
* Tue Oct 24 2023 Antonio Torres <antorres@redhat.com> - 3.2.3-1
|
||||
- Update to upstream release 3.2.3
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user