Import from AlmaLinux stable repository
This commit is contained in:
parent
f4ee89ef8e
commit
9531c0ac3f
@ -1 +0,0 @@
|
|||||||
d29c790fdc48be0970b875c06ccd2fbed2607be6 SOURCES/freeipmi-1.6.8.tar.gz
|
|
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
|||||||
SOURCES/freeipmi-1.6.8.tar.gz
|
SOURCES/freeipmi-1.6.14.tar.gz
|
||||||
|
@ -0,0 +1,41 @@
|
|||||||
|
From 373d445993d0700d0d3801b08696b56486b3083b Mon Sep 17 00:00:00 2001
|
||||||
|
From: Albert Chu <chu11@llnl.gov>
|
||||||
|
Date: Wed, 21 Feb 2024 09:37:17 -0800
|
||||||
|
Subject: [PATCH] ipmi-config: fix incorrect output of
|
||||||
|
IPv6_Dynamic_Address_Source_Type
|
||||||
|
|
||||||
|
---
|
||||||
|
ChangeLog | 6 ++++++
|
||||||
|
ipmi-config/ipmi-config-category-core-lan6-conf-section.c | 2 +-
|
||||||
|
2 files changed, 7 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/ChangeLog b/ChangeLog
|
||||||
|
index 6ed5c9739..c761c4854 100644
|
||||||
|
--- a/ChangeLog
|
||||||
|
+++ b/ChangeLog
|
||||||
|
@@ -1,3 +1,9 @@
|
||||||
|
+2024-02-21 Albert Chu <chu11@llnl.gov>
|
||||||
|
+
|
||||||
|
+ * ipmi-config/ipmi-config-category-core-lan6-conf-section.c
|
||||||
|
+ (ipv6_dynamic_address_source_type_checkout): Fix incorrect output
|
||||||
|
+ of IPv6_Dynamic_Address_Source_Type.
|
||||||
|
+
|
||||||
|
2024-01-27 Albert Chu <chu11@llnl.gov>
|
||||||
|
|
||||||
|
* configure.ac: Remove duplicate inb/outb declaration check. Could
|
||||||
|
diff --git a/ipmi-config/ipmi-config-category-core-lan6-conf-section.c b/ipmi-config/ipmi-config-category-core-lan6-conf-section.c
|
||||||
|
index 6d5e2943b..0b9db1d2d 100644
|
||||||
|
--- a/ipmi-config/ipmi-config-category-core-lan6-conf-section.c
|
||||||
|
+++ b/ipmi-config/ipmi-config-category-core-lan6-conf-section.c
|
||||||
|
@@ -1227,7 +1227,7 @@ ipv6_dynamic_address_source_type_checkout (ipmi_config_state_data_t *state_data,
|
||||||
|
|
||||||
|
if (ipmi_config_section_update_keyvalue_output (state_data,
|
||||||
|
kv,
|
||||||
|
- get_dynamic_address_source_type_string (ipv6_data.source)) < 0)
|
||||||
|
+ get_dynamic_address_source_type_string (ipv6_data.source_type)) < 0)
|
||||||
|
return (IPMI_CONFIG_ERR_FATAL_ERROR);
|
||||||
|
|
||||||
|
rv = IPMI_CONFIG_ERR_SUCCESS;
|
||||||
|
--
|
||||||
|
2.43.0
|
||||||
|
|
@ -2,8 +2,8 @@
|
|||||||
# Copyright (c) 2003 FreeIPMI Core Team
|
# Copyright (c) 2003 FreeIPMI Core Team
|
||||||
|
|
||||||
Name: freeipmi
|
Name: freeipmi
|
||||||
Version: 1.6.8
|
Version: 1.6.14
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: IPMI remote console and system management software
|
Summary: IPMI remote console and system management software
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
URL: http://www.gnu.org/software/freeipmi/
|
URL: http://www.gnu.org/software/freeipmi/
|
||||||
@ -11,6 +11,10 @@ Source0: http://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tar.gz
|
|||||||
Source1: bmc-watchdog.service
|
Source1: bmc-watchdog.service
|
||||||
Source2: ipmidetectd.service
|
Source2: ipmidetectd.service
|
||||||
Source3: ipmiseld.service
|
Source3: ipmiseld.service
|
||||||
|
|
||||||
|
# https://github.com/chu11/freeipmi-mirror/commit/41d0d70f09b4becfceef0517543cbf335c0e927a
|
||||||
|
Patch1: 0001-ipmi-config-fix-incorrect-output-of-IPv6_Dynamic_Add.patch
|
||||||
|
|
||||||
BuildRequires: libgcrypt-devel texinfo systemd
|
BuildRequires: libgcrypt-devel texinfo systemd
|
||||||
%{?systemd_requires}
|
%{?systemd_requires}
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
@ -353,6 +357,14 @@ fi
|
|||||||
%dir %{_localstatedir}/cache/ipmiseld
|
%dir %{_localstatedir}/cache/ipmiseld
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Feb 21 2024 Pavel Cahyna <pcahyna@redhat.com> - 1.6.14-2
|
||||||
|
- Apply upstream patch 41d0d70f
|
||||||
|
ipmi-config: fix incorrect output of IPv6_Dynamic_Address_Source_Type
|
||||||
|
|
||||||
|
* Tue Feb 20 2024 Pavel Cahyna <pcahyna@redhat.com> - 1.6.14-1
|
||||||
|
- Update to 1.6.14
|
||||||
|
Fixes segfault when exceeding 1024 file descriptors
|
||||||
|
|
||||||
* Mon Jun 28 2021 Pavel Cahyna <pcahyna@redhat.com> - 1.6.8-1
|
* Mon Jun 28 2021 Pavel Cahyna <pcahyna@redhat.com> - 1.6.8-1
|
||||||
- New upstream release 1.6.8 (#1923042)
|
- New upstream release 1.6.8 (#1923042)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user