parent
482be677f6
commit
1739ab8029
42
c99.patch
Normal file
42
c99.patch
Normal file
@ -0,0 +1,42 @@
|
|||||||
|
diff -ruN freeipmi-1.6.10/configure.ac freeipmi-1.6.10.new/configure.ac
|
||||||
|
--- freeipmi-1.6.10/configure.ac 2022-08-31 07:17:04.000000000 +0200
|
||||||
|
+++ freeipmi-1.6.10.new/configure.ac 2023-02-06 15:16:25.936054618 +0100
|
||||||
|
@@ -687,7 +687,7 @@
|
||||||
|
|
||||||
|
AM_CONDITIONAL(WITH_FREEIPMI_ARGP, test "$have_argp" = "no")
|
||||||
|
|
||||||
|
-AC_TRY_COMPILE([#include <stdlib.h>],
|
||||||
|
+AC_TRY_COMPILE([#include <stdio.h>],
|
||||||
|
[printf("%s\n", __FUNCTION__);],
|
||||||
|
[AC_DEFINE([HAVE_FUNCTION_MACRO], [1], [Define is you have __FUNCTION__])])
|
||||||
|
|
||||||
|
diff -ruN freeipmi-1.6.10/ipmi-sensors/ipmi-sensors-oem-intel.c freeipmi-1.6.10.new/ipmi-sensors/ipmi-sensors-oem-intel.c
|
||||||
|
--- freeipmi-1.6.10/ipmi-sensors/ipmi-sensors-oem-intel.c 2022-08-31 07:17:04.000000000 +0200
|
||||||
|
+++ freeipmi-1.6.10.new/ipmi-sensors/ipmi-sensors-oem-intel.c 2023-02-06 16:36:12.866440828 +0100
|
||||||
|
@@ -34,6 +34,7 @@
|
||||||
|
#include "ipmi-sensors-oem-intel.h"
|
||||||
|
#include "ipmi-sensors-oem-intel-s5500wb.h"
|
||||||
|
#include "ipmi-sensors-oem-intel-s2600jf.h"
|
||||||
|
+#include "ipmi-sensors-oem-intel-s2600wp.h"
|
||||||
|
#include "ipmi-sensors-oem-intel-quanta-qssc-s4r.h"
|
||||||
|
#include "ipmi-sensors-oem-intel-node-manager.h"
|
||||||
|
|
||||||
|
diff -ruN freeipmi-1.6.10/libfreeipmi/sel/ipmi-sel-string-supermicro-common.h freeipmi-1.6.10.new/libfreeipmi/sel/ipmi-sel-string-supermicro-common.h
|
||||||
|
--- freeipmi-1.6.10/libfreeipmi/sel/ipmi-sel-string-supermicro-common.h 2022-08-31 07:17:05.000000000 +0200
|
||||||
|
+++ freeipmi-1.6.10.new/libfreeipmi/sel/ipmi-sel-string-supermicro-common.h 2023-02-06 15:17:56.023720145 +0100
|
||||||
|
@@ -39,4 +39,15 @@
|
||||||
|
unsigned int *wlen,
|
||||||
|
struct ipmi_sel_system_event_record_data *system_event_record_data);
|
||||||
|
|
||||||
|
+int sel_string_output_supermicro_dimm_event_data2_event_data3 (ipmi_sel_ctx_t ctx,
|
||||||
|
+ struct ipmi_sel_entry *sel_entry,
|
||||||
|
+ uint8_t sel_record_type,
|
||||||
|
+ char *buf,
|
||||||
|
+ unsigned int buflen,
|
||||||
|
+ unsigned int flags,
|
||||||
|
+ unsigned int *wlen,
|
||||||
|
+ struct ipmi_sel_system_event_record_data *system_event_record_data,
|
||||||
|
+ int *oem_rv);
|
||||||
|
+
|
||||||
|
+
|
||||||
|
#endif /* IPMI_SEL_STRING_SUPERMICRO_COMMON_H */
|
@ -1,6 +1,6 @@
|
|||||||
Name: freeipmi
|
Name: freeipmi
|
||||||
Version: 1.6.10
|
Version: 1.6.10
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
Summary: IPMI remote console and system management software
|
Summary: IPMI remote console and system management software
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
URL: http://www.gnu.org/software/freeipmi/
|
URL: http://www.gnu.org/software/freeipmi/
|
||||||
@ -12,6 +12,12 @@ BuildRequires: libgcrypt-devel texinfo systemd
|
|||||||
%{?systemd_requires}
|
%{?systemd_requires}
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
|
BuildRequires: automake
|
||||||
|
BuildRequires: autoconf
|
||||||
|
BuildRequires: libtool
|
||||||
|
|
||||||
|
|
||||||
|
Patch0: c99.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The FreeIPMI project provides "Remote-Console" (out-of-band) and
|
The FreeIPMI project provides "Remote-Console" (out-of-band) and
|
||||||
@ -49,6 +55,7 @@ IPMI SEL syslog logging daemon.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%autosetup -p1
|
%autosetup -p1
|
||||||
|
autoreconf -f -v -i
|
||||||
|
|
||||||
%build
|
%build
|
||||||
export CFLAGS="-D_GNU_SOURCE $RPM_OPT_FLAGS"
|
export CFLAGS="-D_GNU_SOURCE $RPM_OPT_FLAGS"
|
||||||
|
Loading…
Reference in New Issue
Block a user