freeglut/common.patch
Petr Šabata f35f384a47 RHEL 9.0.0 Alpha bootstrap
The content of this branch was automatically imported from Fedora ELN
with the following as its source:
https://src.fedoraproject.org/rpms/freeglut#9a86d0a033b0faa875366277a36aedd3a8c6dcc0
2020-10-15 00:33:41 +02:00

12 lines
444 B
Diff

--- CMakeLists.txt~ 2019-09-25 15:43:34.000000000 -0500
+++ CMakeLists.txt 2020-01-31 09:26:24.104743210 -0600
@@ -302,7 +302,7 @@
ENDIF()
IF(CMAKE_COMPILER_IS_GNUCC)
- SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall")
+ SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -fcommon")
IF(NOT(ANDROID OR BLACKBERRY OR FREEGLUT_WAYLAND))
# not setting -ansi as EGL/KHR headers doesn't support it
SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -pedantic")