fix patch0 for the new release

This commit is contained in:
Tomas Smetana 2012-01-03 11:14:48 +01:00
parent 1a988fc3e1
commit 9ab285f427
3 changed files with 101 additions and 98 deletions

View File

@ -1,96 +0,0 @@
diff -up freeglut-2.6.0/progs/demos/CallbackMaker/Makefile.in.fixld freeglut-2.6.0/progs/demos/CallbackMaker/Makefile.in
--- freeglut-2.6.0/progs/demos/CallbackMaker/Makefile.in.fixld 2010-02-15 13:34:53.000000000 +0100
+++ freeglut-2.6.0/progs/demos/CallbackMaker/Makefile.in 2010-02-15 13:35:37.000000000 +0100
@@ -107,7 +107,7 @@ LDFLAGS = @LDFLAGS@
LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBRARY = @LIBRARY@
-LIBS = @LIBS@
+LIBS = @LIBS@ -lGL
LIBTOOL = @LIBTOOL@
LIBTOOL_DEPS = @LIBTOOL_DEPS@
LIBXI = @LIBXI@
diff -up freeglut-2.6.0/progs/demos/Fractals/Makefile.in.fixld freeglut-2.6.0/progs/demos/Fractals/Makefile.in
--- freeglut-2.6.0/progs/demos/Fractals/Makefile.in.fixld 2010-02-15 13:36:39.000000000 +0100
+++ freeglut-2.6.0/progs/demos/Fractals/Makefile.in 2010-02-15 13:36:51.000000000 +0100
@@ -107,7 +107,7 @@ LDFLAGS = @LDFLAGS@
LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBRARY = @LIBRARY@
-LIBS = @LIBS@
+LIBS = @LIBS@ -lGL
LIBTOOL = @LIBTOOL@
LIBTOOL_DEPS = @LIBTOOL_DEPS@
LIBXI = @LIBXI@
diff -up freeglut-2.6.0/progs/demos/Fractals_random/Makefile.in.fixld freeglut-2.6.0/progs/demos/Fractals_random/Makefile.in
--- freeglut-2.6.0/progs/demos/Fractals_random/Makefile.in.fixld 2010-02-15 13:37:00.000000000 +0100
+++ freeglut-2.6.0/progs/demos/Fractals_random/Makefile.in 2010-02-15 13:37:11.000000000 +0100
@@ -108,7 +108,7 @@ LDFLAGS = @LDFLAGS@
LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBRARY = @LIBRARY@
-LIBS = @LIBS@
+LIBS = @LIBS@ -lGL
LIBTOOL = @LIBTOOL@
LIBTOOL_DEPS = @LIBTOOL_DEPS@
LIBXI = @LIBXI@
diff -up freeglut-2.6.0/progs/demos/Lorenz/Makefile.in.fixld freeglut-2.6.0/progs/demos/Lorenz/Makefile.in
--- freeglut-2.6.0/progs/demos/Lorenz/Makefile.in.fixld 2010-02-15 13:37:26.000000000 +0100
+++ freeglut-2.6.0/progs/demos/Lorenz/Makefile.in 2010-02-15 13:37:37.000000000 +0100
@@ -107,7 +107,7 @@ LDFLAGS = @LDFLAGS@
LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBRARY = @LIBRARY@
-LIBS = @LIBS@
+LIBS = @LIBS@ -lGL -lm
LIBTOOL = @LIBTOOL@
LIBTOOL_DEPS = @LIBTOOL_DEPS@
LIBXI = @LIBXI@
diff -up freeglut-2.6.0/progs/demos/One/Makefile.in.fixld freeglut-2.6.0/progs/demos/One/Makefile.in
--- freeglut-2.6.0/progs/demos/One/Makefile.in.fixld 2010-02-15 13:37:43.000000000 +0100
+++ freeglut-2.6.0/progs/demos/One/Makefile.in 2010-02-15 13:37:54.000000000 +0100
@@ -107,7 +107,7 @@ LDFLAGS = @LDFLAGS@
LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBRARY = @LIBRARY@
-LIBS = @LIBS@
+LIBS = @LIBS@ -lGL
LIBTOOL = @LIBTOOL@
LIBTOOL_DEPS = @LIBTOOL_DEPS@
LIBXI = @LIBXI@
diff -up freeglut-2.6.0/progs/demos/shapes/Makefile.in.fixld freeglut-2.6.0/progs/demos/shapes/Makefile.in
--- freeglut-2.6.0/progs/demos/shapes/Makefile.in.fixld 2010-02-15 13:38:02.000000000 +0100
+++ freeglut-2.6.0/progs/demos/shapes/Makefile.in 2010-02-15 13:38:17.000000000 +0100
@@ -107,7 +107,7 @@ LDFLAGS = @LDFLAGS@
LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBRARY = @LIBRARY@
-LIBS = @LIBS@
+LIBS = @LIBS@ -lGL
LIBTOOL = @LIBTOOL@
LIBTOOL_DEPS = @LIBTOOL_DEPS@
LIBXI = @LIBXI@
diff -up freeglut-2.6.0/progs/demos/smooth_opengl3/Makefile.in.fixld freeglut-2.6.0/progs/demos/smooth_opengl3/Makefile.in
--- freeglut-2.6.0/progs/demos/smooth_opengl3/Makefile.in.fixld 2010-02-15 13:38:27.000000000 +0100
+++ freeglut-2.6.0/progs/demos/smooth_opengl3/Makefile.in 2010-02-15 13:38:38.000000000 +0100
@@ -107,7 +107,7 @@ LDFLAGS = @LDFLAGS@
LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBRARY = @LIBRARY@
-LIBS = @LIBS@
+LIBS = @LIBS@ -lGL
LIBTOOL = @LIBTOOL@
LIBTOOL_DEPS = @LIBTOOL_DEPS@
LIBXI = @LIBXI@
diff -up freeglut-2.6.0/progs/demos/spaceball/Makefile.in.fixld freeglut-2.6.0/progs/demos/spaceball/Makefile.in
--- freeglut-2.6.0/progs/demos/spaceball/Makefile.in.fixld 2010-02-15 13:40:44.000000000 +0100
+++ freeglut-2.6.0/progs/demos/spaceball/Makefile.in 2010-02-15 13:41:00.000000000 +0100
@@ -108,7 +108,7 @@ LDFLAGS = @LDFLAGS@
LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBRARY = @LIBRARY@
-LIBS = @LIBS@
+LIBS = @LIBS@ -lm -lGL
LIBTOOL = @LIBTOOL@
LIBTOOL_DEPS = @LIBTOOL_DEPS@
LIBXI = @LIBXI@

View File

@ -0,0 +1,96 @@
diff -up freeglut-2.8.0/progs/demos/CallbackMaker/Makefile.in.fixld freeglut-2.8.0/progs/demos/CallbackMaker/Makefile.in
--- freeglut-2.8.0/progs/demos/CallbackMaker/Makefile.in.fixld 2012-01-02 13:18:07.000000000 +0100
+++ freeglut-2.8.0/progs/demos/CallbackMaker/Makefile.in 2012-01-03 11:04:07.711906872 +0100
@@ -110,7 +110,7 @@ LDFLAGS = @LDFLAGS@
LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBRARY = @LIBRARY@
-LIBS = @LIBS@
+LIBS = @LIBS@ -lGL
LIBTOOL = @LIBTOOL@
LIBTOOL_DEPS = @LIBTOOL_DEPS@
LIBUSBHID = @LIBUSBHID@
diff -up freeglut-2.8.0/progs/demos/Fractals/Makefile.in.fixld freeglut-2.8.0/progs/demos/Fractals/Makefile.in
--- freeglut-2.8.0/progs/demos/Fractals/Makefile.in.fixld 2012-01-02 13:18:07.000000000 +0100
+++ freeglut-2.8.0/progs/demos/Fractals/Makefile.in 2012-01-03 11:04:07.711906872 +0100
@@ -110,7 +110,7 @@ LDFLAGS = @LDFLAGS@
LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBRARY = @LIBRARY@
-LIBS = @LIBS@
+LIBS = @LIBS@ -lGL
LIBTOOL = @LIBTOOL@
LIBTOOL_DEPS = @LIBTOOL_DEPS@
LIBUSBHID = @LIBUSBHID@
diff -up freeglut-2.8.0/progs/demos/Fractals_random/Makefile.in.fixld freeglut-2.8.0/progs/demos/Fractals_random/Makefile.in
--- freeglut-2.8.0/progs/demos/Fractals_random/Makefile.in.fixld 2012-01-02 13:18:07.000000000 +0100
+++ freeglut-2.8.0/progs/demos/Fractals_random/Makefile.in 2012-01-03 11:04:07.719906936 +0100
@@ -111,7 +111,7 @@ LDFLAGS = @LDFLAGS@
LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBRARY = @LIBRARY@
-LIBS = @LIBS@
+LIBS = @LIBS@ -lGL
LIBTOOL = @LIBTOOL@
LIBTOOL_DEPS = @LIBTOOL_DEPS@
LIBUSBHID = @LIBUSBHID@
diff -up freeglut-2.8.0/progs/demos/Lorenz/Makefile.in.fixld freeglut-2.8.0/progs/demos/Lorenz/Makefile.in
--- freeglut-2.8.0/progs/demos/Lorenz/Makefile.in.fixld 2012-01-02 13:18:07.000000000 +0100
+++ freeglut-2.8.0/progs/demos/Lorenz/Makefile.in 2012-01-03 11:04:07.720907364 +0100
@@ -110,7 +110,7 @@ LDFLAGS = @LDFLAGS@
LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBRARY = @LIBRARY@
-LIBS = @LIBS@
+LIBS = @LIBS@ -lGL -lm
LIBTOOL = @LIBTOOL@
LIBTOOL_DEPS = @LIBTOOL_DEPS@
LIBUSBHID = @LIBUSBHID@
diff -up freeglut-2.8.0/progs/demos/One/Makefile.in.fixld freeglut-2.8.0/progs/demos/One/Makefile.in
--- freeglut-2.8.0/progs/demos/One/Makefile.in.fixld 2012-01-02 13:18:07.000000000 +0100
+++ freeglut-2.8.0/progs/demos/One/Makefile.in 2012-01-03 11:04:07.721907192 +0100
@@ -109,7 +109,7 @@ LDFLAGS = @LDFLAGS@
LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBRARY = @LIBRARY@
-LIBS = @LIBS@
+LIBS = @LIBS@ -lGL
LIBTOOL = @LIBTOOL@
LIBTOOL_DEPS = @LIBTOOL_DEPS@
LIBUSBHID = @LIBUSBHID@
diff -up freeglut-2.8.0/progs/demos/shapes/Makefile.in.fixld freeglut-2.8.0/progs/demos/shapes/Makefile.in
--- freeglut-2.8.0/progs/demos/shapes/Makefile.in.fixld 2012-01-02 13:18:07.000000000 +0100
+++ freeglut-2.8.0/progs/demos/shapes/Makefile.in 2012-01-03 11:04:07.722907340 +0100
@@ -110,7 +110,7 @@ LDFLAGS = @LDFLAGS@
LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBRARY = @LIBRARY@
-LIBS = @LIBS@
+LIBS = @LIBS@ -lGL
LIBTOOL = @LIBTOOL@
LIBTOOL_DEPS = @LIBTOOL_DEPS@
LIBUSBHID = @LIBUSBHID@
diff -up freeglut-2.8.0/progs/demos/smooth_opengl3/Makefile.in.fixld freeglut-2.8.0/progs/demos/smooth_opengl3/Makefile.in
--- freeglut-2.8.0/progs/demos/smooth_opengl3/Makefile.in.fixld 2012-01-02 13:18:07.000000000 +0100
+++ freeglut-2.8.0/progs/demos/smooth_opengl3/Makefile.in 2012-01-03 11:04:07.723914882 +0100
@@ -110,7 +110,7 @@ LDFLAGS = @LDFLAGS@
LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBRARY = @LIBRARY@
-LIBS = @LIBS@
+LIBS = @LIBS@ -lGL
LIBTOOL = @LIBTOOL@
LIBTOOL_DEPS = @LIBTOOL_DEPS@
LIBUSBHID = @LIBUSBHID@
diff -up freeglut-2.8.0/progs/demos/spaceball/Makefile.in.fixld freeglut-2.8.0/progs/demos/spaceball/Makefile.in
--- freeglut-2.8.0/progs/demos/spaceball/Makefile.in.fixld 2012-01-02 13:18:07.000000000 +0100
+++ freeglut-2.8.0/progs/demos/spaceball/Makefile.in 2012-01-03 11:04:07.723914882 +0100
@@ -111,7 +111,7 @@ LDFLAGS = @LDFLAGS@
LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBRARY = @LIBRARY@
-LIBS = @LIBS@
+LIBS = @LIBS@ -lm -lGL
LIBTOOL = @LIBTOOL@
LIBTOOL_DEPS = @LIBTOOL_DEPS@
LIBUSBHID = @LIBUSBHID@

View File

@ -1,7 +1,7 @@
Summary: A freely licensed alternative to the GLUT library
Name: freeglut
Version: 2.8.0
Release: 1%{?dist}
Release: 2%{?dist}
URL: http://freeglut.sourceforge.net
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
# For the manpages
@ -21,7 +21,7 @@ Obsoletes: glut < 3.7
# Fix linking of the examples -- we don't package them, they just need to
# compile and link
Patch0: freeglut-2.6.0-fixld.patch
Patch0: freeglut-2.8.0-fixld.patch
%description
freeglut is a completely open source alternative to the OpenGL Utility Toolkit
@ -91,6 +91,9 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Tue Jan 03 2012 Tomas Smetana <tsmetana@redhat.com> - 2.8.0-2
- fix patch0 for the new release
* Tue Jan 03 2012 Tomas Smetana <tsmetana@redhat.com> - 2.8.0-1
- New upstream release