Fix FTBFS.
This commit is contained in:
parent
e14c26bfcd
commit
8973f5c895
11
common.patch
Normal file
11
common.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- CMakeLists.txt~ 2019-09-25 15:43:34.000000000 -0500
|
||||||
|
+++ CMakeLists.txt 2020-01-31 09:26:24.104743210 -0600
|
||||||
|
@@ -302,7 +302,7 @@
|
||||||
|
ENDIF()
|
||||||
|
|
||||||
|
IF(CMAKE_COMPILER_IS_GNUCC)
|
||||||
|
- SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall")
|
||||||
|
+ SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -fcommon")
|
||||||
|
IF(NOT(ANDROID OR BLACKBERRY OR FREEGLUT_WAYLAND))
|
||||||
|
# not setting -ansi as EGL/KHR headers doesn't support it
|
||||||
|
SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -pedantic")
|
@ -1,11 +1,12 @@
|
|||||||
Summary: A freely licensed alternative to the GLUT library
|
Summary: A freely licensed alternative to the GLUT library
|
||||||
Name: freeglut
|
Name: freeglut
|
||||||
Version: 3.2.1
|
Version: 3.2.1
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
URL: http://freeglut.sourceforge.net
|
URL: http://freeglut.sourceforge.net
|
||||||
Source0: https://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
Source0: https://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
||||||
# For the manpages
|
# For the manpages
|
||||||
Source1: https://downloads.sourceforge.net/openglut/openglut-0.6.3-doc.tar.gz
|
Source1: https://downloads.sourceforge.net/openglut/openglut-0.6.3-doc.tar.gz
|
||||||
|
Patch0: common.patch
|
||||||
License: MIT
|
License: MIT
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
@ -49,6 +50,7 @@ license.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -a 1
|
%setup -q -a 1
|
||||||
|
%patch0 -p0
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%{cmake} -DFREEGLUT_BUILD_STATIC_LIBS=OFF .
|
%{cmake} -DFREEGLUT_BUILD_STATIC_LIBS=OFF .
|
||||||
@ -78,6 +80,9 @@ install -p -m 644 doc/man/*.3 $RPM_BUILD_ROOT/%{_mandir}/man3
|
|||||||
%{_libdir}/cmake/FreeGLUT/*
|
%{_libdir}/cmake/FreeGLUT/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jan 31 2020 Gwyn Ciesla <gwync@protonmail.com> - 3.2.1-3
|
||||||
|
- Fix FTBFS
|
||||||
|
|
||||||
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.1-2
|
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.1-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user