- fix #565178: fix building of the examples

This commit is contained in:
Tomas Smetana 2010-02-15 16:05:06 +00:00
parent 1ce3dc04b9
commit 4ce95ee999
2 changed files with 105 additions and 2 deletions

View File

@ -0,0 +1,96 @@
diff -up freeglut-2.6.0/progs/demos/CallbackMaker/Makefile.in.fixld freeglut-2.6.0/progs/demos/CallbackMaker/Makefile.in
--- freeglut-2.6.0/progs/demos/CallbackMaker/Makefile.in.fixld 2010-02-15 13:34:53.000000000 +0100
+++ freeglut-2.6.0/progs/demos/CallbackMaker/Makefile.in 2010-02-15 13:35:37.000000000 +0100
@@ -107,7 +107,7 @@ LDFLAGS = @LDFLAGS@
LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBRARY = @LIBRARY@
-LIBS = @LIBS@
+LIBS = @LIBS@ -lGL
LIBTOOL = @LIBTOOL@
LIBTOOL_DEPS = @LIBTOOL_DEPS@
LIBXI = @LIBXI@
diff -up freeglut-2.6.0/progs/demos/Fractals/Makefile.in.fixld freeglut-2.6.0/progs/demos/Fractals/Makefile.in
--- freeglut-2.6.0/progs/demos/Fractals/Makefile.in.fixld 2010-02-15 13:36:39.000000000 +0100
+++ freeglut-2.6.0/progs/demos/Fractals/Makefile.in 2010-02-15 13:36:51.000000000 +0100
@@ -107,7 +107,7 @@ LDFLAGS = @LDFLAGS@
LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBRARY = @LIBRARY@
-LIBS = @LIBS@
+LIBS = @LIBS@ -lGL
LIBTOOL = @LIBTOOL@
LIBTOOL_DEPS = @LIBTOOL_DEPS@
LIBXI = @LIBXI@
diff -up freeglut-2.6.0/progs/demos/Fractals_random/Makefile.in.fixld freeglut-2.6.0/progs/demos/Fractals_random/Makefile.in
--- freeglut-2.6.0/progs/demos/Fractals_random/Makefile.in.fixld 2010-02-15 13:37:00.000000000 +0100
+++ freeglut-2.6.0/progs/demos/Fractals_random/Makefile.in 2010-02-15 13:37:11.000000000 +0100
@@ -108,7 +108,7 @@ LDFLAGS = @LDFLAGS@
LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBRARY = @LIBRARY@
-LIBS = @LIBS@
+LIBS = @LIBS@ -lGL
LIBTOOL = @LIBTOOL@
LIBTOOL_DEPS = @LIBTOOL_DEPS@
LIBXI = @LIBXI@
diff -up freeglut-2.6.0/progs/demos/Lorenz/Makefile.in.fixld freeglut-2.6.0/progs/demos/Lorenz/Makefile.in
--- freeglut-2.6.0/progs/demos/Lorenz/Makefile.in.fixld 2010-02-15 13:37:26.000000000 +0100
+++ freeglut-2.6.0/progs/demos/Lorenz/Makefile.in 2010-02-15 13:37:37.000000000 +0100
@@ -107,7 +107,7 @@ LDFLAGS = @LDFLAGS@
LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBRARY = @LIBRARY@
-LIBS = @LIBS@
+LIBS = @LIBS@ -lGL
LIBTOOL = @LIBTOOL@
LIBTOOL_DEPS = @LIBTOOL_DEPS@
LIBXI = @LIBXI@
diff -up freeglut-2.6.0/progs/demos/One/Makefile.in.fixld freeglut-2.6.0/progs/demos/One/Makefile.in
--- freeglut-2.6.0/progs/demos/One/Makefile.in.fixld 2010-02-15 13:37:43.000000000 +0100
+++ freeglut-2.6.0/progs/demos/One/Makefile.in 2010-02-15 13:37:54.000000000 +0100
@@ -107,7 +107,7 @@ LDFLAGS = @LDFLAGS@
LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBRARY = @LIBRARY@
-LIBS = @LIBS@
+LIBS = @LIBS@ -lGL
LIBTOOL = @LIBTOOL@
LIBTOOL_DEPS = @LIBTOOL_DEPS@
LIBXI = @LIBXI@
diff -up freeglut-2.6.0/progs/demos/shapes/Makefile.in.fixld freeglut-2.6.0/progs/demos/shapes/Makefile.in
--- freeglut-2.6.0/progs/demos/shapes/Makefile.in.fixld 2010-02-15 13:38:02.000000000 +0100
+++ freeglut-2.6.0/progs/demos/shapes/Makefile.in 2010-02-15 13:38:17.000000000 +0100
@@ -107,7 +107,7 @@ LDFLAGS = @LDFLAGS@
LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBRARY = @LIBRARY@
-LIBS = @LIBS@
+LIBS = @LIBS@ -lGL
LIBTOOL = @LIBTOOL@
LIBTOOL_DEPS = @LIBTOOL_DEPS@
LIBXI = @LIBXI@
diff -up freeglut-2.6.0/progs/demos/smooth_opengl3/Makefile.in.fixld freeglut-2.6.0/progs/demos/smooth_opengl3/Makefile.in
--- freeglut-2.6.0/progs/demos/smooth_opengl3/Makefile.in.fixld 2010-02-15 13:38:27.000000000 +0100
+++ freeglut-2.6.0/progs/demos/smooth_opengl3/Makefile.in 2010-02-15 13:38:38.000000000 +0100
@@ -107,7 +107,7 @@ LDFLAGS = @LDFLAGS@
LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBRARY = @LIBRARY@
-LIBS = @LIBS@
+LIBS = @LIBS@ -lGL
LIBTOOL = @LIBTOOL@
LIBTOOL_DEPS = @LIBTOOL_DEPS@
LIBXI = @LIBXI@
diff -up freeglut-2.6.0/progs/demos/spaceball/Makefile.in.fixld freeglut-2.6.0/progs/demos/spaceball/Makefile.in
--- freeglut-2.6.0/progs/demos/spaceball/Makefile.in.fixld 2010-02-15 13:40:44.000000000 +0100
+++ freeglut-2.6.0/progs/demos/spaceball/Makefile.in 2010-02-15 13:41:00.000000000 +0100
@@ -108,7 +108,7 @@ LDFLAGS = @LDFLAGS@
LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBRARY = @LIBRARY@
-LIBS = @LIBS@
+LIBS = @LIBS@ -lGL
LIBTOOL = @LIBTOOL@
LIBTOOL_DEPS = @LIBTOOL_DEPS@
LIBXI = @LIBXI@

View File

@ -1,7 +1,7 @@
Summary: A freely licensed alternative to the GLUT library Summary: A freely licensed alternative to the GLUT library
Name: freeglut Name: freeglut
Version: 2.6.0 Version: 2.6.0
Release: 1%{?dist} Release: 2%{?dist}
URL: http://freeglut.sourceforge.net URL: http://freeglut.sourceforge.net
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
# For the manpages # For the manpages
@ -19,6 +19,10 @@ BuildRequires: libXi-devel libICE-devel
Provides: glut = 3.7 Provides: glut = 3.7
Obsoletes: glut < 3.7 Obsoletes: glut < 3.7
# Fix linking of the examples -- we don't package them, they just need to
# compile and link
Patch0: freeglut-2.6.0-fixld.patch
%description %description
freeglut is a completely open source alternative to the OpenGL Utility Toolkit freeglut is a completely open source alternative to the OpenGL Utility Toolkit
(GLUT) library with an OSI approved free software license. GLUT was originally (GLUT) library with an OSI approved free software license. GLUT was originally
@ -48,7 +52,7 @@ license.
%prep %prep
%setup -q -a 1 %setup -q -a 1
%patch0 -p1 -b .fixld
%build %build
# --disable-warnings -> don't add -Werror to CFLAGS # --disable-warnings -> don't add -Werror to CFLAGS
@ -87,6 +91,9 @@ rm -rf $RPM_BUILD_ROOT
%changelog %changelog
* Mon Feb 15 2010 Tomas Smetana <tsmetana@redhat.com> 2.6.0-2
- fix #565178: fix building of the examples
* Sat Nov 28 2009 Tomas Smetana <tsmetana@redhat.com> 2.6.0-1 * Sat Nov 28 2009 Tomas Smetana <tsmetana@redhat.com> 2.6.0-1
- update to 2.6.0 final - update to 2.6.0 final