parent
1aae8438b5
commit
3ab7f04dc7
@ -42,7 +42,7 @@ diff -up freeglut-2.6.0/progs/demos/Lorenz/Makefile.in.fixld freeglut-2.6.0/prog
|
|||||||
LIBOBJS = @LIBOBJS@
|
LIBOBJS = @LIBOBJS@
|
||||||
LIBRARY = @LIBRARY@
|
LIBRARY = @LIBRARY@
|
||||||
-LIBS = @LIBS@
|
-LIBS = @LIBS@
|
||||||
+LIBS = @LIBS@ -lGL
|
+LIBS = @LIBS@ -lGL -lm
|
||||||
LIBTOOL = @LIBTOOL@
|
LIBTOOL = @LIBTOOL@
|
||||||
LIBTOOL_DEPS = @LIBTOOL_DEPS@
|
LIBTOOL_DEPS = @LIBTOOL_DEPS@
|
||||||
LIBXI = @LIBXI@
|
LIBXI = @LIBXI@
|
||||||
|
14
freeglut-2.6.0-noxwarn.patch
Normal file
14
freeglut-2.6.0-noxwarn.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
diff -up freeglut-2.6.0/src/freeglut_main.c.noxwarn freeglut-2.6.0/src/freeglut_main.c
|
||||||
|
--- freeglut-2.6.0/src/freeglut_main.c.noxwarn 2010-05-31 10:49:29.002037712 +0200
|
||||||
|
+++ freeglut-2.6.0/src/freeglut_main.c 2010-05-31 10:50:58.986037800 +0200
|
||||||
|
@@ -1413,7 +1413,9 @@ void FGAPIENTRY glutMainLoopEvent( void
|
||||||
|
break;
|
||||||
|
|
||||||
|
default:
|
||||||
|
- fgWarning ("Unknown X event type: %d\n", event.type);
|
||||||
|
+ /* Fedora patch: the unknown events seem to be quite frequent with
|
||||||
|
+ * the new xorg. Let's not spam the user with the messages */
|
||||||
|
+ /* fgWarning ("Unknown X event type: %d\n", event.type); */
|
||||||
|
break;
|
||||||
|
}
|
||||||
|
}
|
@ -1,7 +1,7 @@
|
|||||||
Summary: A freely licensed alternative to the GLUT library
|
Summary: A freely licensed alternative to the GLUT library
|
||||||
Name: freeglut
|
Name: freeglut
|
||||||
Version: 2.6.0
|
Version: 2.6.0
|
||||||
Release: 3%{?dist}
|
Release: 5%{?dist}
|
||||||
URL: http://freeglut.sourceforge.net
|
URL: http://freeglut.sourceforge.net
|
||||||
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
||||||
# For the manpages
|
# For the manpages
|
||||||
@ -22,6 +22,7 @@ Obsoletes: glut < 3.7
|
|||||||
# Fix linking of the examples -- we don't package them, they just need to
|
# Fix linking of the examples -- we don't package them, they just need to
|
||||||
# compile and link
|
# compile and link
|
||||||
Patch0: freeglut-2.6.0-fixld.patch
|
Patch0: freeglut-2.6.0-fixld.patch
|
||||||
|
Patch1: freeglut-2.6.0-noxwarn.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
freeglut is a completely open source alternative to the OpenGL Utility Toolkit
|
freeglut is a completely open source alternative to the OpenGL Utility Toolkit
|
||||||
@ -53,6 +54,7 @@ license.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -a 1
|
%setup -q -a 1
|
||||||
%patch0 -p1 -b .fixld
|
%patch0 -p1 -b .fixld
|
||||||
|
%patch1 -p1 -b .noxwarn
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# --disable-warnings -> don't add -Werror to CFLAGS
|
# --disable-warnings -> don't add -Werror to CFLAGS
|
||||||
@ -91,6 +93,12 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon May 31 2010 Tomas Smetana <tsmetana@redhat.com> 2.6.0-5
|
||||||
|
- fix #575885, #575885 - suppress the "Unknown X event type" warnings
|
||||||
|
|
||||||
|
* Fri May 7 2010 Josh Boyer <jwboyer@gmail.com> 2.6.0-4
|
||||||
|
- Add -lm to fix ppc build
|
||||||
|
|
||||||
* Mon Feb 15 2010 Tomas Smetana <tsmetana@redhat.com> 2.6.0-3
|
* Mon Feb 15 2010 Tomas Smetana <tsmetana@redhat.com> 2.6.0-3
|
||||||
- the patch for #565178 was incomplete
|
- the patch for #565178 was incomplete
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user