diff --git a/.cvsignore b/.cvsignore
index 5528c8a..bce97ea 100644
--- a/.cvsignore
+++ b/.cvsignore
@@ -1,3 +1,3 @@
-Omni-printers.tar.bz2
-foomatic-1.9-20020617.tar.bz2
-gimp-print.tar.bz2
+Omni-printers-0.7.1.tar.bz2
+foomatic-2.0.2.tar.gz
+gimp-print-foomatic-db-4.2.4.tar.bz2
diff --git a/foomatic.spec b/foomatic.spec
index e916b68..5a37797 100644
--- a/foomatic.spec
+++ b/foomatic.spec
@@ -1,9 +1,7 @@
Summary: Foomatic printer database.
Name: foomatic
-Version: 1.9
-%define release_date 20020617
-%define sub_release 6
-Release: 1.%{release_date}.%{sub_release}
+Version: 2.0.2
+Release: 5
License: GPL
Group: System Environment/Libraries
@@ -11,16 +9,13 @@ Group: System Environment/Libraries
# NOW=`date '+%Y%m%d'`
# cvs -d:pserver:anonymous@cvs.linuxprinting.org:/usr/local/cvs export -D $NOW foomatic
# tar cjf foomatic-1.9-$NOW.tar.bz2 foomatic
-Source0: foomatic-%{version}-%{release_date}.tar.bz2
+Source0: http://www.linuxprinting.org/download/foomatic/foomatic-%{version}.tar.gz
# Build Omni first to get this (you'll have to create the tarball by hand):
-Source1: Omni-printers.tar.bz2
+Source1: Omni-printers-0.7.1.tar.bz2
-# The foomatic-db info from gimp-print-4.2.1 (--with-ijs --with-foomatic)
-Source2: gimp-print.tar.bz2
-
-# Script for generating cups-drivers package
-Source3: gen-ppds
+# The foomatic-db info from gimp-print (--with-ijs --with-foomatic)
+Source2: gimp-print-foomatic-db-4.2.4.tar.bz2
# Look in /usr/local/bin last, not first, in lpdomatic (bug #57915).
Patch0: foomatic-1.9-20020517-path.patch
@@ -28,11 +23,17 @@ Patch0: foomatic-1.9-20020517-path.patch
# Allow libdir and bindir to be overridden.
Patch1: foomatic-1.9-20020517-libdir.patch
-# Fix autodetect information for HPLJ2100/2100M.
-Patch2: foomatic-1.9-20020617-67973.patch
+# Use libdir.
+Patch2: foomatic-2.0.2-libdir.patch
-# Fix autodetect information for HPDJ970C.
-Patch3: foomatic-1.9-20020617-970c.patch
+# Add autodetect information for HP DeskJet 990C.
+Patch3: foomatic-2.0.2-hp990c.patch
+
+# Add 'Generic PostScript' model.
+Patch4: foomatic-2.0.2-generic-postscript.patch
+
+# Fix Omni XML
+Patch5: Omni-printers-badxml.patch
Url: http://www.linuxprinting.org
BuildRequires: perl
@@ -67,55 +68,24 @@ queues (foomatic-configure) and to print files/manipulate jobs
The site http://www.linuxprinting.org/ is based on this database.
-%package -n cups-drivers
-Summary: Printer drivers for CUPS
-Requires: cups >= 1.1.10-3
-Requires: ghostscript
-Prereq: /sbin/service
-Group: System Environment/Daemons
-
-%description -n cups-drivers
-Printer drivers for the CUPS printing system
-
-%package -n cups-drivers-pnm2ppa
-Summary: CUPS drivers for PPA (HP-compatible GDI) printers
-Requires: pnm2ppa
-Requires: ghostscript
-Prereq: /sbin/service
-Group: System Environment/Daemons
-
-%description -n cups-drivers-pnm2ppa
-CUPS drivers for PPA (HP-compatible GDI) printers
-
-%package -n cups-drivers-hpijs
-Summary: CUPS drivers for HP printers using the optimized hpijs driver
-Requires: hpijs >= 1.1
-Requires: ghostscript >= 7.05
-Prereq: /sbin/service
-Group: System Environment/Daemons
-
-%description -n cups-drivers-hpijs
-CUPS drivers for HP printers using the optimized hpijs driver
-
%prep
-%setup -q -n foomatic
+%setup -q
%patch0 -p1 -b .path
%patch1 -p1 -b .libdir
-%patch2 -p1 -b .67973
-%patch3 -p1 -b .970c
+%patch2 -p1 -b .libdir2
+%patch3 -p1 -b .hp990c
+%patch4 -p1
# Omni printers
tar xjf %{SOURCE1}
+pushd Omni-printers
+%patch5 -p0
+popd
# Gimp-print-4.2.0 driver info
rm db/source/driver/stp.xml
( cd db/source; tar xjf %{SOURCE2} )
-# Whenever the recommended driver is gimp-print-ijs, change it to
-# gimp-print (this is already done upstream).
-perl -pi -e 's,gimp-print-ijs,gimp-print,' \
- db/source/printer/*.xml
-
./make_configure
%build
@@ -125,12 +95,12 @@ make PREFIX=%{_prefix} INSTALLPREFIX=%buildroot CFLAGS="$RPM_OPT_FLAGS"
%install
rm -rf $RPM_BUILD_ROOT
-eval `perl '-V:installsitelib'`
-mkdir -p $RPM_BUILD_ROOT/$installsitelib
-export INSTALLSITELIB=$RPM_BUILD_ROOT/$installsitelib
+eval `perl '-V:installvendorlib'`
+mkdir -p $RPM_BUILD_ROOT/$installvendorlib
+export INSTALLSITELIB=$RPM_BUILD_ROOT/$installvendorlib
make DESTDIR=%buildroot PREFIX=%{_prefix} \
INSTALLPREFIX=%buildroot \
- INSTALLSITELIB=$RPM_BUILD_ROOT/$installsitelib \
+ INSTALLSITELIB=$RPM_BUILD_ROOT/$installvendorlib \
install
# Remove drivers with no command line.
@@ -151,17 +121,9 @@ rm -f %{buildroot}%{_datadir}/foomatic/db/source/driver/{bj8pa06n,bjc6000a1,PM76
mkdir -p $RPM_BUILD_ROOT/var/cache/foomatic/{pcache,compiled}
-# cups-drivers packages
-mkdir -p $RPM_BUILD_DIR/%{name}/foomatic-cache
-export FOOMATIC_CACHEDIR="$RPM_BUILD_DIR/%{name}/foomatic-cache"
-export FOOMATIC_LIBDIR="%{buildroot}/%{_datadir}/foomatic"
-export FOOMATIC_BINDIR="%{buildroot}/%{_bindir}"
-export FOOMATIC_SBINDIR="%{buildroot}/%{_sbindir}"
-export FOOMATIC_PERLINC="%{buildroot}/$installsitelib"
-%{SOURCE3} "$RPM_BUILD_ROOT/%{_datadir}/cups/model/foomatic" \
- "$RPM_BUILD_DIR/%{name}"
-perl -pi -e "s,^$RPM_BUILD_ROOT,,g" $RPM_BUILD_DIR/%{name}/filelist.*
-perl -pi -e "s,^%dir $RPM_BUILD_ROOT,%dir ,g" $RPM_BUILD_DIR/%{name}/filelist.*
+# Remove things we don't ship.
+rm -rf $RPM_BUILD_ROOT%{_libdir}/perl5/site_perl \
+ $RPM_BUILD_ROOT%{_libdir}/ppr
%post
# zap the cache
@@ -173,9 +135,8 @@ if [ -x /usr/sbin/printconf-backend ] ; then
fi
# restart the print server if it is running now
-if /sbin/service lpd status >/dev/null 2>&1 ; then
- /sbin/service lpd restart >/dev/null 2>&1
-fi
+/sbin/service lpd condrestart >/dev/null 2>&1
+/sbin/service cups condrestart >/dev/null 2>&1
exit 0
@@ -185,41 +146,41 @@ rm -fr %buildroot $RPM_BUILD_DIR/%{name}
%files
%defattr(-,root,root)
%doc README USAGE ChangeLog
+%dir %{_sysconfdir}/foomatic
+%config(noreplace) %{_sysconfdir}/foomatic/filter.conf
%{_bindir}/*
%{_sbindir}/*
-%{_libdir}/perl5/site_perl/*/Foomatic
+%{_prefix}/lib*/perl5/vendor_perl/*/Foomatic
%dir %{_libdir}/cups
%{_libdir}/cups/*
%dir /var/cache/foomatic
%{_datadir}/foomatic
%{_mandir}/*/*
-%files -n cups-drivers -f filelist.main
-%defattr(-,root,root)
-
-%post -n cups-drivers
-/sbin/service cups condrestart >/dev/null 2>&1 || :
-
-%postun -n cups-drivers
-/sbin/service cups condrestart >/dev/null 2>&1 || :
-
-%files -n cups-drivers-pnm2ppa -f filelist.pnm2ppa
-
-%post -n cups-drivers-pnm2ppa
-/sbin/service cups condrestart >/dev/null 2>&1 || :
-
-%postun -n cups-drivers-pnm2ppa
-/sbin/service cups condrestart >/dev/null 2>&1 || :
-
-%files -n cups-drivers-hpijs -f filelist.hpijs
-
-%post -n cups-drivers-hpijs
-/sbin/service cups condrestart >/dev/null 2>&1 || :
-
-%postun -n cups-drivers-hpijs
-/sbin/service cups condrestart >/dev/null 2>&1 || :
-
%changelog
+* Fri Dec 6 2002 Tim Waugh 2.0.2-5
+- Omni XML wasn't well-formed.
+
+* Wed Nov 20 2002 Tim Waugh 2.0.2-4
+- Update gimp-print data.
+- Add 'generic postscript' model.
+
+* Mon Nov 11 2002 Tim Waugh 2.0.2-3
+- Update Omni printers to 0.7.1.
+
+* Tue Oct 22 2002 Tim Waugh 2.0.2-2
+- Fix file manifest for perl modules.
+- Add autodetect information for HP DeskJet 990C.
+
+* Mon Oct 21 2002 Tim Waugh 2.0.2-1
+- 2.0.2.
+- No longer need 67973, 970c patches.
+- Remove cups-drivers-* packages (no longer needed).
+- Remove files not shipped. Ship filter.conf.
+- Conditionally restart cups.
+- Use libdir.
+- Don't put things in site_perl; use vendor_perl instead (bug #73528).
+
* Fri Aug 9 2002 Tim Waugh 1.9-1.20020617.6
- Fix autodetect information for HPDJ970C.
diff --git a/sources b/sources
index 4ba734e..aac6016 100644
--- a/sources
+++ b/sources
@@ -1,3 +1,3 @@
-498c110ccee104254f1b8ab671fc4c42 Omni-printers.tar.bz2
-862fc23d3ce8706a051340e2e06d4d95 foomatic-1.9-20020617.tar.bz2
-dfebb115f05f63f5ce9e0241e72ddd8b gimp-print.tar.bz2
+ca95fa6fb5d576c9f2c8d20598b95b32 Omni-printers-0.7.1.tar.bz2
+233a227240e02380b45596e8615d9332 foomatic-2.0.2.tar.gz
+850219028293910381b5b229883da78d gimp-print-foomatic-db-4.2.4.tar.bz2