- Fixed installation path for perl module.
This commit is contained in:
parent
b5245c2ef7
commit
aa8ac3c317
39
foomatic-db-engine-perl.patch
Normal file
39
foomatic-db-engine-perl.patch
Normal file
@ -0,0 +1,39 @@
|
||||
diff -up foomatic-db-engine-4.0.3/configure.ac.perl foomatic-db-engine-4.0.3/configure.ac
|
||||
--- foomatic-db-engine-4.0.3/configure.ac.perl 2009-12-04 09:26:14.236782616 +0000
|
||||
+++ foomatic-db-engine-4.0.3/configure.ac 2009-12-04 09:29:08.819781206 +0000
|
||||
@@ -184,13 +184,13 @@ else
|
||||
PREFIX=$prefix
|
||||
fi
|
||||
echo -n Checking whether Perl will find libraries installed under $PREFIX...
|
||||
-if ( $PERL -V | egrep "^ *$PREFIX/lib(/perl[[0-9]]?|)(/site_perl|)/[[0-9]]" > /dev/null); then
|
||||
+if ( $PERL -V | egrep "^ *$PREFIX/lib(/perl[[0-9]]?|)(/site_perl|)" > /dev/null); then
|
||||
PERLPREFIX=$PREFIX
|
||||
echo " yes"
|
||||
else
|
||||
echo " no"
|
||||
echo -n Checking whether Perl will find libraries installed under /usr/local...
|
||||
- if ( $PERL -V | egrep "^ */usr/local/lib(/perl[[0-9]]?|)(/site_perl|)/[[0-9]]" > /dev/null); then
|
||||
+ if ( $PERL -V | egrep "^ */usr/local/lib(/perl[[0-9]]?|)(/site_perl|)" > /dev/null); then
|
||||
PERLPREFIX=/usr/local
|
||||
echo " yes"
|
||||
echo Installing the Perl libraries with prefix /usr/local.
|
||||
diff -up foomatic-db-engine-4.0.3/configure.perl foomatic-db-engine-4.0.3/configure
|
||||
--- foomatic-db-engine-4.0.3/configure.perl 2009-12-04 09:29:12.117906609 +0000
|
||||
+++ foomatic-db-engine-4.0.3/configure 2009-12-04 09:29:34.709782105 +0000
|
||||
@@ -4519,13 +4519,13 @@ else
|
||||
PREFIX=$prefix
|
||||
fi
|
||||
echo -n Checking whether Perl will find libraries installed under $PREFIX...
|
||||
-if ( $PERL -V | egrep "^ *$PREFIX/lib(/perl[0-9]?|)(/site_perl|)/[0-9]" > /dev/null); then
|
||||
+if ( $PERL -V | egrep "^ *$PREFIX/lib(/perl[0-9]?|)(/site_perl|)" > /dev/null); then
|
||||
PERLPREFIX=$PREFIX
|
||||
echo " yes"
|
||||
else
|
||||
echo " no"
|
||||
echo -n Checking whether Perl will find libraries installed under /usr/local...
|
||||
- if ( $PERL -V | egrep "^ */usr/local/lib(/perl[0-9]?|)(/site_perl|)/[0-9]" > /dev/null); then
|
||||
+ if ( $PERL -V | egrep "^ */usr/local/lib(/perl[0-9]?|)(/site_perl|)" > /dev/null); then
|
||||
PERLPREFIX=/usr/local
|
||||
echo " yes"
|
||||
echo Installing the Perl libraries with prefix /usr/local.
|
||||
diff -up foomatic-db-engine-4.0.3/Makefile.in.perl foomatic-db-engine-4.0.3/Makefile.in
|
@ -4,7 +4,7 @@
|
||||
Summary: Database of printers and printer drivers
|
||||
Name: foomatic
|
||||
Version: %{enginever}
|
||||
Release: 5%{?dist}
|
||||
Release: 7%{?dist}
|
||||
License: GPLv2+
|
||||
Group: System Environment/Libraries
|
||||
|
||||
@ -28,6 +28,9 @@ Patch101: foomatic-db-engine-libdir.patch
|
||||
# Handle non-UTF-8 encodings in imported PPD files.
|
||||
Patch102: foomatic-bad-utf8.patch
|
||||
|
||||
# Fixed installation path for perl module.
|
||||
Patch103: foomatic-db-engine-perl.patch
|
||||
|
||||
## PATCHES FOR FOOMATIC-DB-HPIJS (PATCHES 201 TO 300)
|
||||
|
||||
Url: http://www.linuxprinting.org
|
||||
@ -79,6 +82,7 @@ pushd foomatic-db-engine-%{enginever}
|
||||
chmod a+x mkinstalldirs
|
||||
%patch101 -p1 -b .libdir
|
||||
%patch102 -p1
|
||||
%patch103 -p1 -b .perl
|
||||
aclocal
|
||||
autoconf
|
||||
popd
|
||||
@ -156,6 +160,12 @@ rm -fr %buildroot $RPM_BUILD_DIR/%{name}
|
||||
%{_var}/cache/foomatic
|
||||
|
||||
%changelog
|
||||
* Fri Dec 4 2009 Tim Waugh <twaugh@redhat.com> - 4.0.3-7
|
||||
- Fixed installation path for perl module.
|
||||
|
||||
* Fri Dec 4 2009 Stepan Kasal <skasal@redhat.com> - 4.0.3-6
|
||||
- rebuild against perl 5.10.1
|
||||
|
||||
* Tue Nov 10 2009 Tim Waugh <twaugh@redhat.com> 4.0.3-5
|
||||
- Build requires cups.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user