diff --git a/.cvsignore b/.cvsignore
index 3888458..5528c8a 100644
--- a/.cvsignore
+++ b/.cvsignore
@@ -1,3 +1,3 @@
Omni-printers.tar.bz2
-foomatic-1.1-20020313.tar.bz2
+foomatic-1.9-20020617.tar.bz2
gimp-print.tar.bz2
diff --git a/foomatic.spec b/foomatic.spec
index 5fb2444..e5f715c 100644
--- a/foomatic.spec
+++ b/foomatic.spec
@@ -1,55 +1,54 @@
Summary: Foomatic printer database.
Name: foomatic
-Version: 1.1
-%define release_date 20020313
-%define sub_release 3
-Release: 0.%{release_date}.%{sub_release}
+Version: 1.9
+%define release_date 20020617
+%define sub_release 5
+Release: 1.%{release_date}.%{sub_release}
License: GPL
Group: System Environment/Libraries
# Generated by:
# NOW=`date '+%Y%m%d'`
# cvs -d:pserver:anonymous@cvs.linuxprinting.org:/usr/local/cvs export -D $NOW foomatic
-# tar cjf foomatic-1.1-$NOW.tar.bz2 foomatic
-Source0: foomatic-1.1-%{release_date}.tar.bz2
+# tar cjf foomatic-1.9-$NOW.tar.bz2 foomatic
+Source0: foomatic-%{version}-%{release_date}.tar.bz2
# Build Omni first to get this (you'll have to create the tarball by hand):
Source1: Omni-printers.tar.bz2
-# The foomatic-db info from gimp-print-4.2.0
+# The foomatic-db info from gimp-print-4.2.1 (--with-ijs --with-foomatic)
Source2: gimp-print.tar.bz2
# Script for generating cups-drivers package
Source3: gen-ppds
# Look in /usr/local/bin last, not first, in lpdomatic (bug #57915).
-Patch0: foomatic-1.1-20020306-path.patch
+Patch0: foomatic-1.9-20020517-path.patch
# Allow libdir and bindir to be overridden.
-Patch1: foomatic-1.1-20020130-libdir.patch
+Patch1: foomatic-1.9-20020517-libdir.patch
-# Back off to 1.0.2 for hpijs driver data.
-Patch2: foomatic-1.1-hpijs-1.0.2.patch
+# Fix autodetect information for HPLJ2100/2100M.
+Patch2: foomatic-1.9-20020617-67973.patch
Url: http://www.linuxprinting.org
BuildRequires: perl
Requires: perl >= 5.6.1
BuildRoot: %_tmppath/%name-%version-%release-root
Provides: perl(Foomatic::GrovePath)
-Requires: perl-Storable >= 0.6.11, perl-DateManip >= 5.39, perl-libxml-enno >= 1.02
+Requires: perl-DateManip >= 5.39, perl-libxml-enno >= 1.02
Requires: perl-libxml-perl >= 0.07, perl-Parse-Yapp >= 1.04, perl-XML-Dumper >= 0.4
-Requires: perl-XML-Encoding >= 1.01, perl-XML-Parser >= 2.29, perl-XML-Twig >= 2.02
-Requires: perl-XML-Grove, perl-libwww-perl
+Requires: perl-XML-Encoding >= 1.01, perl-XML-Parser >= 2.29
# For 'rm' and '/sbin/service' in post
PreReq: fileutils initscripts
-BuildRequires: perl-Storable >= 0.6.11, perl-DateManip >= 5.39, perl-libxml-enno >= 1.02
+BuildRequires: perl-DateManip >= 5.39, perl-libxml-enno >= 1.02
BuildRequires: perl-libxml-perl >= 0.07, perl-Parse-Yapp >= 1.04, perl-XML-Dumper >= 0.4
BuildRequires: perl-XML-Encoding >= 1.01, perl-XML-Parser >= 2.29, perl-XML-Twig >= 2.02
BuildRequires: perl-XML-Grove, perl-libwww-perl
BuildRequires: perl-URI
-# We need ghostscript to have the gimp-print-4.2.0 driver.
-Conflicts: ghostscript < 6.52
+# We need ghostscript to have the gimp-print-4.2.0 driver, and hpijs 1.1.
+Conflicts: ghostscript < 7.05
%description
Foomatic is a comprehensive, spooler-independent database of printers,
@@ -87,8 +86,8 @@ CUPS drivers for PPA (HP-compatible GDI) printers
%package -n cups-drivers-hpijs
Summary: CUPS drivers for HP printers using the optimized hpijs driver
-Requires: hpijs >= 1.0.1
-Requires: ghostscript >= 6.52-2
+Requires: hpijs >= 1.1
+Requires: ghostscript >= 7.05
Prereq: /sbin/service
Group: System Environment/Daemons
@@ -99,7 +98,7 @@ CUPS drivers for HP printers using the optimized hpijs driver
%setup -q -n foomatic
%patch0 -p1 -b .path
%patch1 -p1 -b .libdir
-%patch2 -p1 -b .hpijs1.0.2
+%patch2 -p1 -b .67973
# Omni printers
tar xjf %{SOURCE1}
@@ -108,7 +107,15 @@ tar xjf %{SOURCE1}
rm db/source/driver/stp.xml
( cd db/source; tar xjf %{SOURCE2} )
+# Whenever the recommended driver is gimp-print-ijs, change it to
+# gimp-print (this is already done upstream).
+perl -pi -e 's,gimp-print-ijs,gimp-print,' \
+ db/source/printer/*.xml
+
+./make_configure
+
%build
+%configure
make PREFIX=%{_prefix} INSTALLPREFIX=%buildroot CFLAGS="$RPM_OPT_FLAGS"
%install
@@ -117,7 +124,7 @@ rm -rf $RPM_BUILD_ROOT
eval `perl '-V:installsitelib'`
mkdir -p $RPM_BUILD_ROOT/$installsitelib
export INSTALLSITELIB=$RPM_BUILD_ROOT/$installsitelib
-make PREFIX=%{_prefix} \
+make DESTDIR=%buildroot PREFIX=%{_prefix} \
INSTALLPREFIX=%buildroot \
INSTALLSITELIB=$RPM_BUILD_ROOT/$installsitelib \
install
@@ -129,17 +136,18 @@ make PREFIX=%{_prefix} \
cd Omni-printers;
P_DIR=$RPM_BUILD_ROOT/usr/share/foomatic/db/source/printer
for P in *.xml; do
- if [ ! -f $P_DIR/$P ]; then
- cp $P $P_DIR;
- fi;
+ if [ ! -f $P_DIR/$P ]; then
+ cp $P $P_DIR;
+ fi;
done;
cd ..
+# Remove ghostscript UPP drivers that are gone in 7.05
+rm -f %{buildroot}%{_datadir}/foomatic/db/source/driver/{bj8pa06n,bjc6000a1,PM760p,PM820p,s400a1,sharp,Stc670pl,Stc670p,Stc680p,Stc760p,Stc777p,Stp720p,Stp870p}.upp.xml
+
mkdir -p $RPM_BUILD_ROOT/var/cache/foomatic/{pcache,compiled}
# cups-drivers packages
-mv %{buildroot}/%{_datadir}/foomatic/db/compiled{,.moved}
-mv %{buildroot}/%{_datadir}/foomatic/db/pcache{,.moved}
mkdir -p $RPM_BUILD_DIR/%{name}/foomatic-cache
export FOOMATIC_CACHEDIR="$RPM_BUILD_DIR/%{name}/foomatic-cache"
export FOOMATIC_LIBDIR="%{buildroot}/%{_datadir}/foomatic"
@@ -148,12 +156,8 @@ export FOOMATIC_SBINDIR="%{buildroot}/%{_sbindir}"
export FOOMATIC_PERLINC="%{buildroot}/$installsitelib"
%{SOURCE3} "$RPM_BUILD_ROOT/%{_datadir}/cups/model/foomatic" \
"$RPM_BUILD_DIR/%{name}"
-mkdir -p $RPM_BUILD_ROOT/%{_bindir}
-install -c -m 755 %{SOURCE3} $RPM_BUILD_ROOT/%{_bindir}
perl -pi -e "s,^$RPM_BUILD_ROOT,,g" $RPM_BUILD_DIR/%{name}/filelist.*
-perl -pi -e "s,^%dir $RPM_BUILD_ROOT,,g" $RPM_BUILD_DIR/%{name}/filelist.*
-mv %{buildroot}/%{_datadir}/foomatic/db/compiled{.moved,}
-mv %{buildroot}/%{_datadir}/foomatic/db/pcache{.moved,}
+perl -pi -e "s,^%dir $RPM_BUILD_ROOT,%dir ,g" $RPM_BUILD_DIR/%{name}/filelist.*
%post
# zap the cache
@@ -188,31 +192,75 @@ rm -fr %buildroot $RPM_BUILD_DIR/%{name}
%files -n cups-drivers -f filelist.main
%defattr(-,root,root)
-%{_bindir}/gen-ppds
%post -n cups-drivers
-/sbin/service cups condrestart || :
+/sbin/service cups condrestart >/dev/null 2>&1 || :
%postun -n cups-drivers
-/sbin/service cups condrestart || :
+/sbin/service cups condrestart >/dev/null 2>&1 || :
%files -n cups-drivers-pnm2ppa -f filelist.pnm2ppa
%post -n cups-drivers-pnm2ppa
-/sbin/service cups condrestart || :
+/sbin/service cups condrestart >/dev/null 2>&1 || :
%postun -n cups-drivers-pnm2ppa
-/sbin/service cups condrestart || :
+/sbin/service cups condrestart >/dev/null 2>&1 || :
%files -n cups-drivers-hpijs -f filelist.hpijs
%post -n cups-drivers-hpijs
-/sbin/service cups condrestart || :
+/sbin/service cups condrestart >/dev/null 2>&1 || :
%postun -n cups-drivers-hpijs
-/sbin/service cups condrestart || :
+/sbin/service cups condrestart >/dev/null 2>&1 || :
%changelog
+* Thu Aug 8 2002 Tim Waugh 1.9-1.20020617.5
+- For gimp-print, use the Ghostscript stp driver in preference to the
+ IJS interface.
+
+* Thu Jul 25 2002 Tim Waugh 1.9-1.20020617.4
+- Quieten scriptlets.
+
+* Fri Jul 5 2002 Tim Waugh 1.9-1.20020617.3
+- Fix autodetect information for HPLJ2100/2100M.
+
+* Fri Jun 21 2002 Tim Powers 1.9-1.20020617.2
+- automated rebuild
+
+* Wed Jun 19 2002 Tim Waugh 1.9-0.20020617.2
+- Omni 0.7.0 printers.
+
+* Mon Jun 17 2002 Tim Waugh 1.9-0.20020617.1
+- Update to CVS.
+- Remove some more explicit perl dependencies that are picked up
+ automatically.
+
+* Wed May 29 2002 Tim Waugh 1.9-0.20020517.3
+- Remove explicit perl-Storable dependency; it should be perl(Storable),
+ and that is picked up automatically.
+
+* Tue May 28 2002 Tim Waugh 1.9-0.20020517.2
+- Fix release number.
+- Drop gen-ppds from the file manifest---use foomatic-compiledb instead
+ (bug #63622).
+
+* Sun May 26 2002 Tim Powers
+- automated rebuild
+
+* Thu May 23 2002 Tim Waugh 1.9-0.20020517.1
+- Remove ghostscript UPP drivers that are gone in 7.05.
+
+* Sat May 18 2002 Tim Waugh 1.9-0.20020517.0.1
+- Update to CVS.
+- Updated requirements.
+- Updated path and libdir patches.
+- Drop hpijs 1.0.2 patch.
+- foomatic-datafile has moved to %%{_bindir}.
+- Update gimp-print data to 4.2.1.
+- Update Omni printer data to 0.6.1.
+
* Thu Apr 4 2002 Tim Waugh 1.1-0.20020313.3
- Fix the hpijs option data too (bug #62587).
diff --git a/sources b/sources
index 19be59f..4ba734e 100644
--- a/sources
+++ b/sources
@@ -1,3 +1,3 @@
-59bce92c9e46045153e512fecbf2dd08 Omni-printers.tar.bz2
-25bcd3a08ce503cf75c4bde836b0c2b2 foomatic-1.1-20020313.tar.bz2
-659e6fb2af2f721c1f0d206242ba517e gimp-print.tar.bz2
+498c110ccee104254f1b8ab671fc4c42 Omni-printers.tar.bz2
+862fc23d3ce8706a051340e2e06d4d95 foomatic-1.9-20020617.tar.bz2
+dfebb115f05f63f5ce9e0241e72ddd8b gimp-print.tar.bz2