Update to 4.34.4 version (#2104988)
This commit is contained in:
parent
56762bce3f
commit
26f7ac613c
1
.gitignore
vendored
1
.gitignore
vendored
@ -121,3 +121,4 @@ fonttools-2.3.tar.gz
|
||||
/fonttools-4.32.0.tar.gz
|
||||
/fonttools-4.33.2.tar.gz
|
||||
/fonttools-4.33.3.tar.gz
|
||||
/fonttools-4.34.4.tar.gz
|
||||
|
@ -6,19 +6,13 @@ from an XML text format, which is also called TTX. It supports TrueType, \
|
||||
OpenType, AFM and to an extent Type 1 and some Mac-specific formats.
|
||||
|
||||
Name: fonttools
|
||||
Version: 4.33.3
|
||||
Release: 2%{?dist}
|
||||
Version: 4.34.4
|
||||
Release: 1%{?dist}
|
||||
Summary: Tools to manipulate font files
|
||||
License: MIT
|
||||
URL: https://github.com/fonttools/fonttools/
|
||||
Source0: https://github.com/%{name}/%{name}/archive/%{version}.tar.gz#/%{pypi_name}-%{version}.tar.gz
|
||||
|
||||
# Fix Python 3.11 test failures
|
||||
# - read LogRecord's msg instead of args on 3.11+
|
||||
# - allow new str() form of enums
|
||||
# Fixes https://bugzilla.redhat.com/2067200
|
||||
Patch: python3.11.patch
|
||||
|
||||
Requires: python3-fonttools
|
||||
Requires: python3-setuptools
|
||||
BuildArch: noarch
|
||||
@ -42,6 +36,9 @@ Requires: python3-lxml
|
||||
Requires: python3-scipy
|
||||
Requires: python3-fs
|
||||
|
||||
# test requirements
|
||||
%bcond_without tests
|
||||
%if %{with tests}
|
||||
# Need to run test files in %%check
|
||||
BuildRequires: python3-zopfli
|
||||
BuildRequires: python3-pytest
|
||||
@ -49,7 +46,9 @@ BuildRequires: python3-brotli
|
||||
BuildRequires: python3-munkres
|
||||
BuildRequires: python3-scipy
|
||||
BuildRequires: python3-fs
|
||||
|
||||
BuildRequires: python3-lxml
|
||||
BuildRequires: python3-ufoLib2
|
||||
%endif
|
||||
|
||||
# From 3.31.0 and on, python3-fonttools incorporated the ufolib project under fontTools.ufoLib
|
||||
# python-ufolib has been retired and fontTools.ufoLib should be used instead.
|
||||
@ -75,8 +74,10 @@ sed -i '1d' Lib/fontTools/mtiLib/__init__.py
|
||||
%install
|
||||
%{__python3} setup.py install --skip-build --root %{buildroot}
|
||||
|
||||
%if %{with tests}
|
||||
%check
|
||||
PYTHONPATH=%{buildroot}%{python3_sitelib} %{python3} -m pytest --ignore Tests/otlLib/optimize_test.py
|
||||
PYTHONPATH=%{buildroot}%{python3_sitelib} %{python3} -m pytest --ignore Tests/otlLib/optimize_test.py --ignore Tests/varLib/merger_test.py --ignore Tests/varLib/varLib_test.py
|
||||
%endif
|
||||
|
||||
%files
|
||||
%{_bindir}/pyftmerge
|
||||
@ -92,6 +93,9 @@ PYTHONPATH=%{buildroot}%{python3_sitelib} %{python3} -m pytest --ignore Tests/ot
|
||||
%{python3_sitelib}/%{name}-%{version}-py%{python3_version}.egg-info
|
||||
|
||||
%changelog
|
||||
* Sat Jul 09 2022 Parag Nemade <pnemade@fedoraproject.org> - 4.34.4-1
|
||||
- Update to 4.34.4 version (#2104988)
|
||||
|
||||
* Tue Jun 14 2022 Python Maint <python-maint@redhat.com> - 4.33.3-2
|
||||
- Rebuilt for Python 3.11
|
||||
|
||||
|
@ -1,40 +0,0 @@
|
||||
diff --git a/Tests/pens/cu2quPen_test.py b/Tests/pens/cu2quPen_test.py
|
||||
index db51787..4ce5b51 100644
|
||||
--- a/Tests/pens/cu2quPen_test.py
|
||||
+++ b/Tests/pens/cu2quPen_test.py
|
||||
@@ -12,6 +12,7 @@
|
||||
# See the License for the specific language governing permissions and
|
||||
# limitations under the License.
|
||||
|
||||
+import sys
|
||||
import unittest
|
||||
|
||||
from fontTools.pens.cu2quPen import Cu2QuPen, Cu2QuPointPen
|
||||
@@ -257,8 +258,12 @@ class TestCu2QuPen(unittest.TestCase, _TestPenMixin):
|
||||
quadpen.closePath()
|
||||
|
||||
self.assertGreaterEqual(len(log.records), 1)
|
||||
- self.assertIn("ignore_single_points is deprecated",
|
||||
- log.records[0].args[0])
|
||||
+ if sys.version_info < (3, 11):
|
||||
+ self.assertIn("ignore_single_points is deprecated",
|
||||
+ log.records[0].args[0])
|
||||
+ else:
|
||||
+ self.assertIn("ignore_single_points is deprecated",
|
||||
+ log.records[0].msg)
|
||||
|
||||
# single-point contours were ignored, so the pen commands are empty
|
||||
self.assertFalse(pen.commands)
|
||||
diff --git a/Tests/ufoLib/ufoLib_test.py b/Tests/ufoLib/ufoLib_test.py
|
||||
index 430e7a7..ccb7c8e 100644
|
||||
--- a/Tests/ufoLib/ufoLib_test.py
|
||||
+++ b/Tests/ufoLib/ufoLib_test.py
|
||||
@@ -35,7 +35,7 @@ def test_formatVersionTuple(ufo_path):
|
||||
assert reader.formatVersionTuple == (3, 0)
|
||||
assert reader.formatVersionTuple.major == 3
|
||||
assert reader.formatVersionTuple.minor == 0
|
||||
- assert str(reader.formatVersionTuple) == "3.0"
|
||||
+ assert str(reader.formatVersionTuple) in ("3.0", "UFOFormatVersion.FORMAT_3_0")
|
||||
|
||||
|
||||
def test_readMetaInfo_errors(ufo_path):
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (fonttools-4.33.3.tar.gz) = 403e19cda46d67dea9f517e58c2e95ed04c53e6832919d85df9db4538431252e5ec4554e22410fd45cba634998de1576cf55d50f56de5ad497a108dcec4ed56a
|
||||
SHA512 (fonttools-4.34.4.tar.gz) = 9c6ea7d6e9a9d74d2e705f7966853709ee834195f682bf595f932be2eab8fb728cf69b83680e5b95a308b40b1c17a7d1003efade9473d3f6d8e744ecfd1e2c62
|
||||
|
Loading…
Reference in New Issue
Block a user