Resolves:rhbz#1823525 - fontforge fails to build with Sphinx 3.0.0
This commit is contained in:
parent
58f23472d6
commit
cf517d7106
@ -0,0 +1,62 @@
|
||||
From 36b52b9902a9e3858ef34ec006b6ad5da6374de1 Mon Sep 17 00:00:00 2001
|
||||
From: Jeremy Tan <jtanx@outlook.com>
|
||||
Date: Mon, 6 Apr 2020 20:57:14 +1000
|
||||
Subject: [PATCH] sphinx: make changes to support Sphinx 3
|
||||
|
||||
---
|
||||
doc/sphinx/scripting/python/fontforge.rst | 18 +++---------------
|
||||
1 file changed, 3 insertions(+), 15 deletions(-)
|
||||
|
||||
diff --git a/doc/sphinx/scripting/python/fontforge.rst b/doc/sphinx/scripting/python/fontforge.rst
|
||||
index b97332229..f726b1ed4 100644
|
||||
--- a/doc/sphinx/scripting/python/fontforge.rst
|
||||
+++ b/doc/sphinx/scripting/python/fontforge.rst
|
||||
@@ -1365,6 +1365,7 @@ Layers may be compared to see if their contours are similar.
|
||||
layer.stroke("calligraphic", width, height, angle[, FLAGS])
|
||||
layer.stroke("polygon", contour[, FLAGS])
|
||||
(Legacy interface)
|
||||
+ :noindex:
|
||||
|
||||
.. method:: layer.stroke("circular", width [, CAP, JOIN, ANGLE, KEYWORD])
|
||||
layer.stroke("elliptical", width, minor_width [, ANGLE, CAP, JOIN, KEYWORD])
|
||||
@@ -2458,6 +2459,7 @@ must be created through the font.
|
||||
glyph.stroke("calligraphic", width, height, angle[, FLAGS])
|
||||
glyph.stroke("polygon", contour[, FLAGS])
|
||||
(Legacy interface)
|
||||
+ :noindex:
|
||||
|
||||
.. method:: glyph.stroke("circular", width[, CAP, JOIN, ANGLE, KEYWORD])
|
||||
glyph.stroke("elliptical", width, minor_width[, ANGLE, CAP, JOIN, KEYWORD])
|
||||
@@ -4786,21 +4788,6 @@ See the :class:`selection` type for how to alter the selection.
|
||||
Extrema should be marked by on-curve points. If a curve in any selected
|
||||
glyph lacks a point at a significant extremum this command will add one.
|
||||
|
||||
-.. method:: font.addSmallCaps()
|
||||
-
|
||||
- For all selected upper or lower case letters in the latin, greek and
|
||||
- cyrillic scripts this will try to create a small caps version of that glyph
|
||||
- in a new glyph slot.
|
||||
-
|
||||
- So if you select "A" (or "a") then a glyph "a.sc" will be created (if "a.sc"
|
||||
- already exists, it will be reused, and its current contents cleared).
|
||||
-
|
||||
- The contents of "a.sc" will be based on the upper case variant of this glyph
|
||||
- (and that variant must be present for the command to work). FontForge will
|
||||
- also create two lookups (unless appropriate ones already exist) one, bound
|
||||
- to the feature 'c2sc' will map upper case letters to small caps, the other,
|
||||
- bound to feature 'smcp' will map lower case letters to small caps.
|
||||
-
|
||||
.. method:: font.autoHint()
|
||||
|
||||
Generates PostScript hints for all selected glyphs.
|
||||
@@ -4993,6 +4980,7 @@ See the :class:`selection` type for how to alter the selection.
|
||||
font.stroke("calligraphic", width, height, angle[, FLAGS])
|
||||
font.stroke("polygon", contour[, FLAGS])
|
||||
(Legacy interface)
|
||||
+ :noindex:
|
||||
|
||||
.. method:: font.stroke("circular", width[, CAP, JOIN, ANGLE, KEYWORD])
|
||||
font.stroke("elliptical", width, minor_width[, ANGLE, CAP, JOIN, KEYWORD])
|
||||
--
|
||||
2.26.0
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
Name: fontforge
|
||||
Version: 20200314
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
Summary: Outline and bitmap font editor
|
||||
|
||||
License: GPLv3+
|
||||
@ -12,6 +12,8 @@ Source0: https://github.com/fontforge/%{name}/archive/%{gittag0}.tar.gz#/
|
||||
|
||||
# https://github.com/fontforge/fontforge/pull/4253
|
||||
Patch0: fontforge-20200314-Call-gdk_set_allowed_backends-before-gdk_init.patch
|
||||
# https://github.com/fontforge/fontforge/pull/4269
|
||||
Patch1: fontforge-20200314-sphinx-make-changes-to-support-Sphinx-3.patch
|
||||
|
||||
Requires: xdg-utils
|
||||
Requires: autotrace
|
||||
@ -68,6 +70,7 @@ This package contains documentation files for %{name}.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
# Remove tests that requires Internet access
|
||||
sed -i '45d;83d;101d;102d;114d;115d;125d' tests/CMakeLists.txt
|
||||
@ -133,6 +136,9 @@ popd
|
||||
%doc %{_pkgdocdir}
|
||||
|
||||
%changelog
|
||||
* Wed Apr 15 2020 Parag Nemade <pnemade AT redhat DOT com> - 20200314-4
|
||||
- Resolves:rhbz#1823525 - fontforge fails to build with Sphinx 3.0.0
|
||||
|
||||
* Thu Apr 02 2020 Parag Nemade <pnemade AT redhat DOT com> - 20200314-3
|
||||
- Fix the GDK backend UI issues
|
||||
- Move back to using GDK backend
|
||||
|
Loading…
Reference in New Issue
Block a user