Apply patch for python modules loading (fixes #489109) use install -p to

fix multiarch issue (fixes #480685)
This commit is contained in:
Kevin Fenzi 2009-04-02 06:12:28 +00:00
parent ce97b9fcac
commit 8e5b406f4c
2 changed files with 51 additions and 1 deletions

View File

@ -0,0 +1,41 @@
diff -Nur fontforge-20090224.orig/configure fontforge-20090224/configure
--- fontforge-20090224.orig/configure 2008-12-24 14:04:18.000000000 -0700
+++ fontforge-20090224/configure 2009-04-01 22:56:07.000000000 -0600
@@ -26670,6 +26670,7 @@
else
PYLIBS=""
fi
+ PYDEFINES="$PYDEFINES, ('SOLIBDIR','\"$libdir/\"')"
PY=pyhook/setup.py
fi
diff -Nur fontforge-20090224.orig/pyhook/loadfontforge.h fontforge-20090224/pyhook/loadfontforge.h
--- fontforge-20090224.orig/pyhook/loadfontforge.h 2007-12-23 19:28:35.000000000 -0700
+++ fontforge-20090224/pyhook/loadfontforge.h 2009-04-01 22:49:08.000000000 -0600
@@ -11,7 +11,7 @@
if ( (lib = dlopen("libgunicode" SO_EXT,RTLD_LAZY))==NULL ) {
#ifdef PREFIX
- lib = dlopen( PREFIX "/lib/" "libgunicode" SO_EXT,RTLD_LAZY);
+ lib = dlopen( SOLIBDIR "libgunicode.so.3" ,RTLD_LAZY);
#endif
}
if ( lib==NULL ) {
@@ -21,7 +21,7 @@
if ( (lib = dlopen("libgutils" SO_EXT,RTLD_LAZY))==NULL ) {
#ifdef PREFIX
- lib = dlopen( PREFIX "/lib/" "libgutils" SO_EXT,RTLD_LAZY);
+ lib = dlopen( SOLIBDIR "libgutils.so.1" ,RTLD_LAZY);
#endif
}
if ( lib==NULL ) {
@@ -31,7 +31,7 @@
if ( (lib = dlopen("libfontforge" SO_EXT,RTLD_LAZY))==NULL ) {
#ifdef PREFIX
- lib = dlopen( PREFIX "/lib/" "libfontforge" SO_EXT,RTLD_LAZY);
+ lib = dlopen( SOLIBDIR "libfontforge.so.1" SO_EXT,RTLD_LAZY);
#endif
}
if ( lib==NULL ) {

View File

@ -5,7 +5,7 @@
Name: fontforge
Version: 20090224
Release: 1%{?dist}
Release: 2%{?dist}
Summary: Outline and bitmap font editor
Group: Applications/Publishing
@ -15,6 +15,7 @@ Source0: http://downloads.sourceforge.net/fontforge/fontforge_full-%{vers
Source1: fontforge.desktop
Source2: http://downloads.sourceforge.net/fontforge/fontforge_htdocs-%{docs_version}.tar.bz2
Source3: fontforge.xml
Patch1: fontforge-20090224-pythondl.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Requires: xdg-utils
@ -55,6 +56,8 @@ to compile applications against fontforge.
%prep
%setup -q -n %{name}-%{version}
%patch1 -p1
mkdir htdocs
tar xjf %{SOURCE2} -C htdocs
rm -rf htdocs/scripts
@ -68,6 +71,8 @@ rm -rf htdocs/flags/CVS
%{__sed} -i 's/\r//' htdocs/corpchar.txt
%build
export INSTALL='/usr/bin/install -p'
%configure --with-freetype-bytecode=no --with-regular-link --enable-pyextension
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
@ -142,6 +147,10 @@ update-mime-database %{_datadir}/mime &> /dev/null || :
%{_libdir}/pkgconfig/*.pc
%changelog
* Sun Apr 02 2009 Kevin Fenzi <kevin@tummy.com> - 20090224-2
- Apply patch for python modules loading (fixes #489109)
- use install -p to fix multiarch issue (fixes #480685)
* Thu Feb 26 2009 Kevin Fenzi <kevin@tummy.com> - 20090224-1
- Upgrade to 20090224