import fontforge-20170731-13.el8

This commit is contained in:
CentOS Sources 2019-11-05 17:02:39 -05:00 committed by Andrew Lukoshko
parent 1776e3748d
commit 82eab5ce73
3 changed files with 29 additions and 18 deletions

View File

@ -206,15 +206,6 @@ diff -urN fontforge-20170731.old/fontforge/featurefile.c fontforge-20170731/font
return;
}
gm = chunkalloc(sizeof(*gm));
@@ -4639,7 +4648,7 @@
}
r->lookup_cnt = lc;
}
-
+ free(bcovers);
return( fpst );
}
@@ -7092,6 +7101,7 @@
}
if ( f!=NULL && f->type == ft_feat_end )
@ -1330,14 +1321,6 @@ diff -urN fontforge-20170731.old/fontforge/sfd.c fontforge-20170731/fontforge/sf
if (d->lastgroupvkern != NULL) d->lastgroupvkern->next = kerntmp; else sf->groupvkerns = kerntmp;
d->lastgroupvkern = kerntmp;
}
@@ -8267,6 +8302,7 @@
//
return false;
}
+ free(kc);
return true;
}
@@ -8710,6 +8746,7 @@
else if ( lastnamedinstance !=NULL )
lastnamedinstance->names = names;

View File

@ -0,0 +1,12 @@
diff -urN fontforge-20170731.old/fontforge/Makefile.am fontforge-20170731/fontforge/Makefile.am
--- fontforge-20170731.old/fontforge/Makefile.am 2017-07-31 03:19:01.000000000 +0530
+++ fontforge-20170731/fontforge/Makefile.am 2019-06-01 23:35:57.644257299 +0530
@@ -192,7 +192,7 @@
# without optimization.
splinerefigure.lo: $(srcdir)/splinerefigure.c $(srcdir)/splinefont.h
$(LIBTOOL) --mode=compile $(CC) $(RAW_COMPILE_PLATFORM_CFLAGS) -g -c -o \
- splinerefigure.lo $(AM_CPPFLAGS) $(srcdir)/splinerefigure.c
+ splinerefigure.lo $(AM_CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) $(srcdir)/splinerefigure.c
#--------------------------------------------------------------------------
EXTRA_DIST = generate_codepoint_selector.py threaddummy.c

View File

@ -4,7 +4,7 @@
Name: fontforge
Version: %{gittag0}
Release: 8%{?dist}
Release: 13%{?dist}
Summary: Outline and bitmap font editor
License: GPLv3+
@ -17,6 +17,7 @@ Patch0: fontforge-20140813-use-system-uthash.patch
# Fedora specific patch to have python3 support only
Patch1: Add-python3-support.patch
Patch2: fontforge-20170731-covscan-issue-fix.patch
Patch3: fontforge-20170731-override-upstream-optimization-flags-splinerefigure-c.patch
Requires: xdg-utils
Requires: autotrace
@ -156,6 +157,21 @@ chmod 644 $RPM_BUILD_ROOT%{_datadir}/fontforge/nodejs/collabwebview/js/contentEd
%doc htdocs
%changelog
* Sun Jun 02 2019 Parag Nemade <pnemade AT redhat DOT com> - 20170731-13
- Resolves:rh#1665940 - harden the missing splinerefigure.c file
* Fri May 31 2019 Parag Nemade <pnemade AT redhat DOT com> - 20170731-12
- Resolves:rh#1665940 - Fixed covscan patch to fix some font packages build
* Mon May 20 2019 Parag Nemade <pnemade AT redhat DOT com> - 20170731-11
- Resolves:rh#1682233 - Fixed gating.yml rule
* Sat May 18 2019 Parag Nemade <pnemade AT redhat DOT com> - 20170731-10
- Resolves:rh#1682233 - fontforge changes blocked until gating tests are added
* Mon May 13 2019 Parag Nemade <pnemade AT redhat DOT com> - 20170731-9
- Resolves:rh#1665940 - fontforge: Use after free during dejavu-fonts build
* Tue Oct 30 2018 Parag Nemade <pnemade AT redhat DOT com> - 20170731-8
- Resolves:rh#1644224 - fix some issues from covscan patch