Update to 20201107 version (#1895648)
Signed-off-by: Parag Nemade <pnemade@fedoraproject.org>
This commit is contained in:
parent
8d8438727b
commit
58a47602b9
1
.gitignore
vendored
1
.gitignore
vendored
@ -22,3 +22,4 @@ fontforge_full-20100501.tar.bz2
|
||||
/fontforge-20190317.tar.gz
|
||||
/fontforge-20190413.tar.gz
|
||||
/fontforge-20200314.tar.gz
|
||||
/fontforge-20201107.tar.gz
|
||||
|
@ -1,27 +0,0 @@
|
||||
From ee14a6389d19e2f45219134058e07f10585fa6d3 Mon Sep 17 00:00:00 2001
|
||||
From: Jeremy Tan <jtanx@outlook.com>
|
||||
Date: Thu, 2 Apr 2020 18:03:47 +0800
|
||||
Subject: [PATCH] Call gdk_set_allowed_backends before gdk_init
|
||||
|
||||
Fixes #4247
|
||||
---
|
||||
fontforgeexe/startui.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/fontforgeexe/startui.c b/fontforgeexe/startui.c
|
||||
index 06f5200a4..114bb7fb6 100644
|
||||
--- a/fontforgeexe/startui.c
|
||||
+++ b/fontforgeexe/startui.c
|
||||
@@ -1182,8 +1182,8 @@ int fontforge_main( int argc, char **argv ) {
|
||||
#endif
|
||||
}
|
||||
#ifdef FONTFORGE_CAN_USE_GDK
|
||||
- gdk_init(&argc, &argv);
|
||||
gdk_set_allowed_backends("win32,quartz,x11");
|
||||
+ gdk_init(&argc, &argv);
|
||||
#endif
|
||||
ensureDotFontForgeIsSetup();
|
||||
#if defined(__MINGW32__) && !defined(_NO_LIBCAIRO)
|
||||
--
|
||||
2.26.0
|
||||
|
@ -1,284 +0,0 @@
|
||||
--- doc/sphinx/glossary.rst.old 2020-03-14 09:06:49.000000000 +0530
|
||||
+++ doc/sphinx/glossary.rst 2020-08-05 12:06:45.574903248 +0530
|
||||
@@ -23,13 +23,13 @@
|
||||
Both Hebrew and Arabic have optional vowel marks and are called "impure"
|
||||
abjads. Ancient Phoenician had nothing but consonants and is a "pure" abjad.
|
||||
|
||||
- See Also: :term:`alphabet`,
|
||||
- :term:`abugida`, :term:`syllabary` and
|
||||
+ See Also: :term:`Alphabet`,
|
||||
+ :term:`Abugida`, :term:`Syllabary` and
|
||||
the relevant `Wikipedia article <http://en.wikipedia.org/wiki/Abjad>`__.
|
||||
|
||||
Abugida
|
||||
- An abugida is somewhere in between an :term:`alphabet` and
|
||||
- a :term:`syllabary`. The Indic writing systems are
|
||||
+ An abugida is somewhere in between an :term:`alphabet <Alphabet>` and
|
||||
+ a :term:`syllabary <Syllabary>`. The Indic writing systems are
|
||||
probably the best known abugidas.
|
||||
|
||||
In most abugidas there are independant glyphs for the consonants, and each
|
||||
@@ -45,8 +45,8 @@
|
||||
An abugida differs from an abjad in that vowels (other than the default) must
|
||||
be marked in the abugida.
|
||||
|
||||
- See Also: :term:`alphabet`, :term:`abjad`,
|
||||
- :term:`syllabary` and the relevant
|
||||
+ See Also: :term:`Alphabet`, :term:`Abjad`,
|
||||
+ :term:`Syllabary` and the relevant
|
||||
`Wikipedia article <http://en.wikipedia.org/wiki/Abugida>`__.
|
||||
|
||||
Advance Width
|
||||
@@ -62,8 +62,8 @@
|
||||
vowels alike -- and (in theory anyway) all phonemes in a word will be marked
|
||||
by an appropriate glyph.
|
||||
|
||||
- See Also: :term:`abjad`, :term:`abugida`,
|
||||
- :term:`syllabary` and the relevant
|
||||
+ See Also: :term:`Abjad`, :term:`Abugida`,
|
||||
+ :term:`Syllabary` and the relevant
|
||||
`Wikipedia article <http://en.wikipedia.org/wiki/Alphabet>`__.
|
||||
|
||||
Apple Advanced Typography
|
||||
@@ -83,7 +83,7 @@
|
||||
|
||||
Ascent
|
||||
In traditional typography the ascent of a font was the distance from the top
|
||||
- of a block of type to the :term:`baseline`.
|
||||
+ of a block of type to the :term:`baseline <Baseline>`.
|
||||
|
||||
Its precise meaning in modern typography seems to vary with different
|
||||
definers.
|
||||
@@ -127,7 +127,7 @@
|
||||
Black letter
|
||||
Any of various type families based on medieval handwriting.
|
||||
|
||||
- See also :term:`gothic`.
|
||||
+ See also :term:`Gothic`.
|
||||
|
||||
BMP
|
||||
Basic Multilingual Plane
|
||||
@@ -142,13 +142,13 @@
|
||||
(0xE0000-0xEFFFF)
|
||||
|
||||
Bold
|
||||
- A common font :term:`style`. The stems of the glyphs are
|
||||
+ A common font :term:`style <Style>`. The stems of the glyphs are
|
||||
wider than in the normal font, giving the letters a darker impression. Bold
|
||||
is one of the few :term:`LGC` styles that translate readily to
|
||||
other scripts.
|
||||
|
||||
Bopomofo
|
||||
- A (modern~1911) Chinese (Mandarin) :term:`alphabet` used
|
||||
+ A (modern~1911) Chinese (Mandarin) :term:`alphabet <Alphabet>` used
|
||||
to provide phonetic transliteration of Han ideographs in dictionaries.
|
||||
|
||||
Boustrophedon
|
||||
@@ -158,7 +158,7 @@
|
||||
Writing "as the ox plows", that is alternating between left to right and
|
||||
right to left writing directions. Early alphabets (Old Canaanite, and the
|
||||
very early greek writings (and, surprisingly,
|
||||
- :term:`fuþark`)) used this. Often the right to left glyphs
|
||||
+ :term:`Fuþark`)) used this. Often the right to left glyphs
|
||||
would be mirrors of the left to right ones. As far as I know, no modern
|
||||
writing system uses this method (nor does OpenType have any support for it).
|
||||
See Also :term:`Bidi`.
|
||||
@@ -181,7 +181,7 @@
|
||||
|
||||
Character
|
||||
A character is a Platonic ideal reified into at least one
|
||||
- :term:`glyph`. For example the letter "s" is a character
|
||||
+ :term:`glyph <Glyph>`. For example the letter "s" is a character
|
||||
which is reified into several different glyphs: "S", "s", "*s*", long-s, etc.
|
||||
Note that these glyphs can look fairly different from each other, however
|
||||
although the glyph for an integral sign might be the same as the long-s
|
||||
@@ -232,7 +232,7 @@
|
||||
|
||||
Descent
|
||||
In traditional typography the descent of a font was the distance from the
|
||||
- bottom of a block of type to the :term:`baseline`.
|
||||
+ bottom of a block of type to the :term:`baseline <Baseline>`.
|
||||
|
||||
Its precise meaning in modern typography seems to vary with different
|
||||
definers.
|
||||
@@ -248,7 +248,7 @@
|
||||
:ref:`anchored marks <anchorcontrol.DeviceTable>`.
|
||||
|
||||
Didot point
|
||||
- The European :term:`point`. 62 :sup:`2`/:small:`3` points per
|
||||
+ The European :term:`point <Point>`. 62 :sup:`2`/:small:`3` points per
|
||||
23.566mm ( 2.66pt/mm or 67.55pt/inch ). There is also a "metric" didiot
|
||||
point: .4mm.
|
||||
|
||||
@@ -275,7 +275,7 @@
|
||||
|
||||
Encoding
|
||||
An encoding is a mapping from a set of bytes onto a
|
||||
- :term:`character set`. It is what determines which
|
||||
+ :term:`character set <Character set>`. It is what determines which
|
||||
byte sequence represents which character. The words "encoding" and "character
|
||||
set" are often used synonymously. The specification for ASCII specifies both
|
||||
a character set and an encoding. But CJK character sets often have multiple
|
||||
@@ -293,7 +293,7 @@
|
||||
two sounds associated with it, but it does, see also
|
||||
:term:`Thorn`)
|
||||
|
||||
- Even-Odd Fill rule
|
||||
+ Even-Odd Fill Rule
|
||||
To determine if a pixel should be
|
||||
:ref:`filled using this rule <editexample2.even-odd-non-zero>`, draw a line from the
|
||||
pixel to infinity (in any direction) then count the number of times contours
|
||||
@@ -332,7 +332,7 @@
|
||||
Font
|
||||
A collection of :term:`glyphs <Glyph>`, generally with at least one
|
||||
glyph associated with each character in the font's
|
||||
- :term:`character set`, often with an encoding.
|
||||
+ :term:`character set <Character set>`, often with an encoding.
|
||||
|
||||
A font contains much of the information needed to turn a sequence of bytes
|
||||
into a set of pictures representing the characters specified by those bytes.
|
||||
@@ -342,8 +342,8 @@
|
||||
different font for each point-size.
|
||||
|
||||
Font Family, or just Family
|
||||
- A collection of related :term:`font`\ s. Often including plain,
|
||||
- italic and bold :term:`style`\ s.
|
||||
+ A collection of related :term:`font <Font>`\ s. Often including plain,
|
||||
+ italic and bold :term:`style <Style>`\ s.
|
||||
|
||||
FontForge
|
||||
This.
|
||||
@@ -356,7 +356,7 @@
|
||||
Fractur
|
||||
The old black letter writing style used in Germany up until world war II.
|
||||
|
||||
- See also :term:`gothic`.
|
||||
+ See also :term:`Gothic`.
|
||||
|
||||
Fuþark
|
||||
Futhark
|
||||
@@ -430,7 +430,7 @@
|
||||
China.
|
||||
|
||||
Hangul
|
||||
- The Korean :term:`syllabary`. The only syllabary (that
|
||||
+ The Korean :term:`Syllabary`. The only syllabary (that
|
||||
I'm aware of anway) based on an alphabet -- the letters of the alphabet never
|
||||
appear alone, but only as groups of two or three making up a syllable.
|
||||
|
||||
@@ -439,11 +439,11 @@
|
||||
|
||||
Hints
|
||||
These are described in detail in :ref:`the main manual <overview.Hints>`.
|
||||
- They help the rasterizer to draw a :term:`glyph` well at
|
||||
+ They help the rasterizer to draw a :term:`glyph <Glyph>` well at
|
||||
small pointsizes.
|
||||
|
||||
Hint Masks
|
||||
- At any given point on a contour :term:`hints` may not
|
||||
+ At any given point on a contour :term:`hints <Hints>` may not
|
||||
:term:`conflict <Conflicting hints>`. However different points in a
|
||||
glyph may need conflicting hints. So every now and then a contour will change
|
||||
which hints are active. Each list of active hints is called a hint mask.
|
||||
@@ -457,7 +457,7 @@
|
||||
Generally used to mean Han (Chinese) characters.
|
||||
|
||||
Italic
|
||||
- A slanted :term:`style` of a font, generally used for
|
||||
+ A slanted :term:`style <Style>` of a font, generally used for
|
||||
emphasis.
|
||||
|
||||
Italic differs from :term:`Oblique` in that the
|
||||
@@ -498,7 +498,7 @@
|
||||
to it.
|
||||
|
||||
Kern pair
|
||||
- A pair of glyphs for which :term:`kerning` information has
|
||||
+ A pair of glyphs for which :term:`kerning <Kerning>` information has
|
||||
been specified.
|
||||
|
||||
Kerning by classes
|
||||
@@ -541,9 +541,9 @@
|
||||
|
||||
Manyogana
|
||||
An early Japanese script, ancestral to both
|
||||
- :term:`hiragana` and :term:`katakana`.
|
||||
+ :term:`Hiragana` and :term:`Katakana`.
|
||||
`Manyogana <http://en.wikipedia.org/wiki/Manyogana>`__ used
|
||||
- :term:`kanji` for their phontic sounds, and over the years
|
||||
+ :term:`Kanji` for their phontic sounds, and over the years
|
||||
these kanji were simplified into hiragana and katahana.
|
||||
|
||||
Metal Type
|
||||
@@ -622,7 +622,7 @@
|
||||
:doc:`here for the tables used by FontForge </techref/TrueOpenTables>`.
|
||||
|
||||
Oblique
|
||||
- A slanted :term:`style` of a font, generally used for
|
||||
+ A slanted :term:`style <Style>` of a font, generally used for
|
||||
emphasis.
|
||||
|
||||
Oblique differs from :term:`Italic` in that the
|
||||
@@ -695,7 +695,7 @@
|
||||
`See Caslon's type specimen sheet on Wikipedia. <http://en.wikipedia.org/wiki/Alphabet>`__
|
||||
|
||||
Pica point
|
||||
- The Anglo-American :term:`point`. With 72.27 points per inch
|
||||
+ The Anglo-American :term:`point <Point>`. With 72.27 points per inch
|
||||
( 2.85pt /mm ).
|
||||
|
||||
Point
|
||||
@@ -708,7 +708,7 @@
|
||||
points per inch, 2.86pt/mm).
|
||||
|
||||
The didiot and pica points were so arranged that text at a given point-size
|
||||
- would have approximately the same :term:`cap-height` in
|
||||
+ would have approximately the same :term:`cap-height <Cap-height>` in
|
||||
both systems, the didot point would have extra white-space above the capitals
|
||||
to contain the accents present in most non-English Latin based scripts.
|
||||
|
||||
@@ -757,7 +757,7 @@
|
||||
again only allows a 1 byte encoding, but the OpenType wrapper extends this to
|
||||
provide more complex encoding types.
|
||||
* Type 3 -- This format allows full postscript within the font, but it means
|
||||
- that no :term:`hints` are allowed, so these fonts will not
|
||||
+ that no :term:`hints <Hints>` are allowed, so these fonts will not
|
||||
look as nice at small point-sizes. Also most (screen) rasterizers are
|
||||
incapable of dealing with them. A type 3 font is limited to a one byte
|
||||
encoding (ie. only 256 glyphs may be encoded).
|
||||
@@ -922,13 +922,13 @@
|
||||
Style
|
||||
There are various conventional variants of a font. In probably any writing
|
||||
system the thickness of the stems of the glyphs may be varied, this is called
|
||||
- the :term:`weight` of a font. Common weights are normal and
|
||||
+ the :term:`weight <Weight>` of a font. Common weights are normal and
|
||||
bold.
|
||||
|
||||
- In :term:`LGC` alphabets an :term:`italic` (or
|
||||
- :term:`oblique`) style has arisen and is used for emphasis.
|
||||
+ In :term:`LGC` alphabets an :term:`italic <Italic>` (or
|
||||
+ :term:`oblique <Oblique>`) style has arisen and is used for emphasis.
|
||||
|
||||
- Fonts are often compressed into a :term:`condensed`
|
||||
+ Fonts are often compressed into a :term:`condensed <Condensed>`
|
||||
style, or expanded out into an :term:`extended style <Extended>`.
|
||||
|
||||
Various other styles are in occasional use: underline, overstrike, outline,
|
||||
@@ -945,7 +945,7 @@
|
||||
tend to be bigger than alphabets (Japanese KataKana requires about 60
|
||||
different characters, while the Korean Hangul requires tens of thousands).
|
||||
|
||||
- See Also: :term:`abjad`, :term:`abugida`, :term:`alphabet` and the relevant
|
||||
+ See Also: :term:`Abjad`, :term:`Abugida`, :term:`Alphabet` and the relevant
|
||||
`Wikipedia article <http://en.wikipedia.org/wiki/S%20yllabary>`__.
|
||||
|
||||
TeX
|
||||
@@ -1061,7 +1061,7 @@
|
||||
|
||||
Width
|
||||
This is a slightly ambiguous term and is sometimes used to mean the
|
||||
- :term:`advance width` (the distance from the start of
|
||||
+ :term:`advance width <Advance Width>` (the distance from the start of
|
||||
this glyph to the start of the next glyph), and sometimes used to mean the
|
||||
distance from the left side bearing to the right side bearing.
|
||||
|
@ -1,62 +0,0 @@
|
||||
From 36b52b9902a9e3858ef34ec006b6ad5da6374de1 Mon Sep 17 00:00:00 2001
|
||||
From: Jeremy Tan <jtanx@outlook.com>
|
||||
Date: Mon, 6 Apr 2020 20:57:14 +1000
|
||||
Subject: [PATCH] sphinx: make changes to support Sphinx 3
|
||||
|
||||
---
|
||||
doc/sphinx/scripting/python/fontforge.rst | 18 +++---------------
|
||||
1 file changed, 3 insertions(+), 15 deletions(-)
|
||||
|
||||
diff --git a/doc/sphinx/scripting/python/fontforge.rst b/doc/sphinx/scripting/python/fontforge.rst
|
||||
index b97332229..f726b1ed4 100644
|
||||
--- a/doc/sphinx/scripting/python/fontforge.rst
|
||||
+++ b/doc/sphinx/scripting/python/fontforge.rst
|
||||
@@ -1365,6 +1365,7 @@ Layers may be compared to see if their contours are similar.
|
||||
layer.stroke("calligraphic", width, height, angle[, FLAGS])
|
||||
layer.stroke("polygon", contour[, FLAGS])
|
||||
(Legacy interface)
|
||||
+ :noindex:
|
||||
|
||||
.. method:: layer.stroke("circular", width [, CAP, JOIN, ANGLE, KEYWORD])
|
||||
layer.stroke("elliptical", width, minor_width [, ANGLE, CAP, JOIN, KEYWORD])
|
||||
@@ -2458,6 +2459,7 @@ must be created through the font.
|
||||
glyph.stroke("calligraphic", width, height, angle[, FLAGS])
|
||||
glyph.stroke("polygon", contour[, FLAGS])
|
||||
(Legacy interface)
|
||||
+ :noindex:
|
||||
|
||||
.. method:: glyph.stroke("circular", width[, CAP, JOIN, ANGLE, KEYWORD])
|
||||
glyph.stroke("elliptical", width, minor_width[, ANGLE, CAP, JOIN, KEYWORD])
|
||||
@@ -4786,21 +4788,6 @@ See the :class:`selection` type for how to alter the selection.
|
||||
Extrema should be marked by on-curve points. If a curve in any selected
|
||||
glyph lacks a point at a significant extremum this command will add one.
|
||||
|
||||
-.. method:: font.addSmallCaps()
|
||||
-
|
||||
- For all selected upper or lower case letters in the latin, greek and
|
||||
- cyrillic scripts this will try to create a small caps version of that glyph
|
||||
- in a new glyph slot.
|
||||
-
|
||||
- So if you select "A" (or "a") then a glyph "a.sc" will be created (if "a.sc"
|
||||
- already exists, it will be reused, and its current contents cleared).
|
||||
-
|
||||
- The contents of "a.sc" will be based on the upper case variant of this glyph
|
||||
- (and that variant must be present for the command to work). FontForge will
|
||||
- also create two lookups (unless appropriate ones already exist) one, bound
|
||||
- to the feature 'c2sc' will map upper case letters to small caps, the other,
|
||||
- bound to feature 'smcp' will map lower case letters to small caps.
|
||||
-
|
||||
.. method:: font.autoHint()
|
||||
|
||||
Generates PostScript hints for all selected glyphs.
|
||||
@@ -4993,6 +4980,7 @@ See the :class:`selection` type for how to alter the selection.
|
||||
font.stroke("calligraphic", width, height, angle[, FLAGS])
|
||||
font.stroke("polygon", contour[, FLAGS])
|
||||
(Legacy interface)
|
||||
+ :noindex:
|
||||
|
||||
.. method:: font.stroke("circular", width[, CAP, JOIN, ANGLE, KEYWORD])
|
||||
font.stroke("elliptical", width, minor_width[, ANGLE, CAP, JOIN, KEYWORD])
|
||||
--
|
||||
2.26.0
|
||||
|
@ -1,20 +1,13 @@
|
||||
%global gettext_package FontForge
|
||||
%global gittag0 20200314
|
||||
|
||||
Name: fontforge
|
||||
Version: 20200314
|
||||
Release: 10%{?dist}
|
||||
Version: 20201107
|
||||
Release: 1%{?dist}
|
||||
Summary: Outline and bitmap font editor
|
||||
|
||||
License: GPLv3+
|
||||
URL: http://fontforge.github.io/
|
||||
Source0: https://github.com/fontforge/%{name}/archive/%{gittag0}.tar.gz#/%{name}-%{version}.tar.gz
|
||||
|
||||
# https://github.com/fontforge/fontforge/pull/4253
|
||||
Patch0: fontforge-20200314-Call-gdk_set_allowed_backends-before-gdk_init.patch
|
||||
# https://github.com/fontforge/fontforge/pull/4269
|
||||
Patch1: fontforge-20200314-sphinx-make-changes-to-support-Sphinx-3.patch
|
||||
Patch2: fontforge-20200314-fix-glossary.rst-file.patch
|
||||
Source0: https://github.com/fontforge/%{name}/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
|
||||
|
||||
Requires: xdg-utils
|
||||
Requires: autotrace
|
||||
@ -74,12 +67,9 @@ This package contains documentation files for %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p0
|
||||
|
||||
# Remove tests that requires Internet access
|
||||
sed -i '45d;83d;101d;102d;114d;115d;125d' tests/CMakeLists.txt
|
||||
sed -i '45d;83d;101d;102d;114d;115d;127d' tests/CMakeLists.txt
|
||||
rm tests/test003.pe tests/test130.pe tests/test0101.py tests/test929.py
|
||||
# Remove tests for s390x
|
||||
rm tests/test0004.py tests/test1009.py tests/test1010.py
|
||||
@ -136,6 +126,10 @@ popd
|
||||
%doc %{_pkgdocdir}
|
||||
|
||||
%changelog
|
||||
* Wed Nov 25 2020 Parag Nemade <pnemade AT redhat DOT com> - 20201107-1
|
||||
- Update to 20201107 version (#1895648)
|
||||
- removed %%gittag0 macro, as it cause problem to automated package update script
|
||||
|
||||
* Sun Nov 22 2020 Benjamin A. Beasley <code@musicinmybrain.net> - 20200314-10
|
||||
- Add py_provides macros to provide python3-fontforge, python3-psMat, etc.
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (fontforge-20200314.tar.gz) = 9eecee6162d5d160c9fe5d3e229763edb0b52f53529659f0fa8b41cf3edf0685509f51d3993da0e6e2c36fecde867af60062e131e10d7fdfbaac16323855818f
|
||||
SHA512 (fontforge-20201107.tar.gz) = 7b5672bc87b4be9211ebc4a20dfb9a7dd8d870f5fc34c74c78f663ab1c25ca7818ddcb52b67d748dd6720b62eab7cb14bb586a86525703f2c15aca3b65d53e26
|
||||
|
Loading…
Reference in New Issue
Block a user