Updated to version 7.1.2.
This commit is contained in:
parent
3cae3a5825
commit
a2bff58183
1
.gitignore
vendored
1
.gitignore
vendored
@ -10,3 +10,4 @@
|
||||
/7.0.1.tar.gz
|
||||
/7.0.2.tar.gz
|
||||
/7.0.3.tar.gz
|
||||
/7.1.2.tar.gz
|
||||
|
@ -1,10 +1,10 @@
|
||||
diff --git a/doc/build.py b/doc/build.py
|
||||
index d2ca1d03..8df66bda 100755
|
||||
index 4d5ef955..94ac1074 100755
|
||||
--- a/doc/build.py
|
||||
+++ b/doc/build.py
|
||||
@@ -7,16 +7,6 @@ from subprocess import check_call, check_output, CalledProcessError, Popen, PIPE
|
||||
|
||||
versions = ['1.0.0', '1.1.0', '2.0.0', '3.0.2', '4.0.0', '4.1.0', '5.0.0', '5.1.0', '5.2.0', '5.2.1', '5.3.0', '6.0.0', '6.1.0', '6.1.1', '6.1.2', '6.2.0', '6.2.1', '7.0.0', '7.0.1', '7.0.2', '7.0.3']
|
||||
versions = ['1.0.0', '1.1.0', '2.0.0', '3.0.2', '4.0.0', '4.1.0', '5.0.0', '5.1.0', '5.2.0', '5.2.1', '5.3.0', '6.0.0', '6.1.0', '6.1.1', '6.1.2', '6.2.0', '6.2.1', '7.0.0', '7.0.1', '7.0.2', '7.0.3', '7.1.0', '7.1.1', '7.1.2']
|
||||
|
||||
-def create_build_env(dirname='virtualenv'):
|
||||
- # Create virtualenv.
|
||||
@ -19,7 +19,7 @@ index d2ca1d03..8df66bda 100755
|
||||
def build_docs(version='dev', **kwargs):
|
||||
doc_dir = kwargs.get('doc_dir', os.path.dirname(os.path.realpath(__file__)))
|
||||
work_dir = kwargs.get('work_dir', '.')
|
||||
@@ -78,5 +68,4 @@ def build_docs(version='dev', **kwargs):
|
||||
@@ -79,5 +69,4 @@ def build_docs(version='dev', **kwargs):
|
||||
return html_dir
|
||||
|
||||
if __name__ == '__main__':
|
||||
|
@ -1,27 +1,17 @@
|
||||
diff --git a/doc/build.py b/doc/build.py
|
||||
index 06e105aa..d2ca1d03 100755
|
||||
index bae311d4..4d5ef955 100755
|
||||
--- a/doc/build.py
|
||||
+++ b/doc/build.py
|
||||
@@ -4,27 +4,9 @@
|
||||
@@ -4,17 +4,9 @@
|
||||
from __future__ import print_function
|
||||
import errno, os, shutil, sys, tempfile
|
||||
from subprocess import check_call, check_output, CalledProcessError, Popen, PIPE
|
||||
-from distutils.version import LooseVersion
|
||||
|
||||
versions = ['1.0.0', '1.1.0', '2.0.0', '3.0.2', '4.0.0', '4.1.0', '5.0.0', '5.1.0', '5.2.0', '5.2.1', '5.3.0', '6.0.0', '6.1.0', '6.1.1', '6.1.2', '6.2.0', '6.2.1', '7.0.0', '7.0.1', '7.0.2', '7.0.3']
|
||||
versions = ['1.0.0', '1.1.0', '2.0.0', '3.0.2', '4.0.0', '4.1.0', '5.0.0', '5.1.0', '5.2.0', '5.2.1', '5.3.0', '6.0.0', '6.1.0', '6.1.1', '6.1.2', '6.2.0', '6.2.1', '7.0.0', '7.0.1', '7.0.2', '7.0.3', '7.1.0', '7.1.1', '7.1.2']
|
||||
|
||||
-def pip_install(package, commit=None, **kwargs):
|
||||
- "Install package using pip."
|
||||
- min_version = kwargs.get('min_version')
|
||||
- if min_version:
|
||||
- from pkg_resources import get_distribution, DistributionNotFound
|
||||
- try:
|
||||
- installed_version = get_distribution(os.path.basename(package)).version
|
||||
- if LooseVersion(installed_version) >= min_version:
|
||||
- print('{} {} already installed'.format(package, min_version))
|
||||
- return
|
||||
- except DistributionNotFound:
|
||||
- pass
|
||||
- if commit:
|
||||
- package = 'git+https://github.com/{0}.git@{1}'.format(package, commit)
|
||||
- print('Installing {0}'.format(package))
|
||||
@ -30,7 +20,7 @@ index 06e105aa..d2ca1d03 100755
|
||||
def create_build_env(dirname='virtualenv'):
|
||||
# Create virtualenv.
|
||||
if not os.path.exists(dirname):
|
||||
@@ -34,30 +16,6 @@ def create_build_env(dirname='virtualenv'):
|
||||
@@ -24,29 +16,6 @@ def create_build_env(dirname='virtualenv'):
|
||||
activate_this_file = os.path.join(dirname, scripts_dir, 'activate_this.py')
|
||||
with open(activate_this_file) as f:
|
||||
exec(f.read(), dict(__file__=activate_this_file))
|
||||
@ -52,12 +42,11 @@ index 06e105aa..d2ca1d03 100755
|
||||
- check_call(['pip', 'install', '--upgrade', 'distribute'])
|
||||
- except DistributionNotFound:
|
||||
- pass
|
||||
- # Install Sphinx and Breathe.
|
||||
- pip_install('sphinx-doc/sphinx', '12b83372ac9316e8cbe86e7fed889296a4cc29ee',
|
||||
- min_version='1.4.1.dev20160531')
|
||||
- # Install Sphinx and Breathe. Require the exact version of Sphinx which is
|
||||
- # compatible with Breathe.
|
||||
- pip_install('sphinx-doc/sphinx', '12b83372ac9316e8cbe86e7fed889296a4cc29ee')
|
||||
- pip_install('michaeljones/breathe',
|
||||
- '129222318f7c8f865d2631e7da7b033567e7f56a',
|
||||
- min_version='4.2.0')
|
||||
- '129222318f7c8f865d2631e7da7b033567e7f56a')
|
||||
|
||||
def build_docs(version='dev', **kwargs):
|
||||
doc_dir = kwargs.get('doc_dir', os.path.dirname(os.path.realpath(__file__)))
|
||||
|
@ -1,22 +0,0 @@
|
||||
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
|
||||
index 9b2063b8..589deacc 100644
|
||||
--- a/doc/CMakeLists.txt
|
||||
+++ b/doc/CMakeLists.txt
|
||||
@@ -4,11 +4,13 @@ if (NOT DOXYGEN)
|
||||
return ()
|
||||
endif ()
|
||||
|
||||
+find_package(PythonInterp
|
||||
+ QUIET REQUIRED)
|
||||
find_program(SPHINX_EXECUTABLE
|
||||
NAMES sphinx-build sphinx-build-3)
|
||||
add_custom_target(doc
|
||||
COMMAND ${CMAKE_COMMAND} -E env SPHINX_EXECUTABLE=${SPHINX_EXECUTABLE}
|
||||
- ${CMAKE_CURRENT_SOURCE_DIR}/build.py ${FMT_VERSION}
|
||||
+ ${PYTHON_EXECUTABLE} ${CMAKE_CURRENT_SOURCE_DIR}/build.py ${FMT_VERSION}
|
||||
SOURCES api.rst syntax.rst usage.rst build.py conf.py _templates/layout.html)
|
||||
|
||||
install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/html/
|
||||
--
|
||||
2.26.2
|
||||
|
@ -1,34 +1,48 @@
|
||||
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
|
||||
index 108aa71e..9b2063b8 100644
|
||||
index 06848450..8e5e8a83 100644
|
||||
--- a/doc/CMakeLists.txt
|
||||
+++ b/doc/CMakeLists.txt
|
||||
@@ -4,8 +4,11 @@ if (NOT DOXYGEN)
|
||||
return ()
|
||||
@@ -5,10 +5,11 @@ if (NOT DOXYGEN)
|
||||
endif ()
|
||||
|
||||
+find_program(SPHINX_EXECUTABLE
|
||||
+ NAMES sphinx-build sphinx-build-3)
|
||||
find_package(PythonInterp QUIET REQUIRED)
|
||||
+find_program(SPHINX_EXECUTABLE NAMES sphinx-build sphinx-build-3)
|
||||
|
||||
add_custom_target(doc
|
||||
- COMMAND ${CMAKE_CURRENT_SOURCE_DIR}/build.py ${FMT_VERSION}
|
||||
+ COMMAND ${CMAKE_COMMAND} -E env SPHINX_EXECUTABLE=${SPHINX_EXECUTABLE}
|
||||
+ ${CMAKE_CURRENT_SOURCE_DIR}/build.py ${FMT_VERSION}
|
||||
COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_CURRENT_SOURCE_DIR}/build.py
|
||||
- ${FMT_VERSION}
|
||||
+ ${SPHINX_EXECUTABLE} ${FMT_VERSION}
|
||||
SOURCES api.rst syntax.rst usage.rst build.py conf.py _templates/layout.html)
|
||||
|
||||
install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/html/
|
||||
include(GNUInstallDirs)
|
||||
diff --git a/doc/build.py b/doc/build.py
|
||||
index 8df66bda..840fdf40 100755
|
||||
index 94ac1074..686c8b1a 100755
|
||||
--- a/doc/build.py
|
||||
+++ b/doc/build.py
|
||||
@@ -49,7 +49,8 @@ def build_docs(version='dev', **kwargs):
|
||||
@@ -7,7 +7,7 @@ from subprocess import check_call, check_output, CalledProcessError, Popen, PIPE
|
||||
|
||||
versions = ['1.0.0', '1.1.0', '2.0.0', '3.0.2', '4.0.0', '4.1.0', '5.0.0', '5.1.0', '5.2.0', '5.2.1', '5.3.0', '6.0.0', '6.1.0', '6.1.1', '6.1.2', '6.2.0', '6.2.1', '7.0.0', '7.0.1', '7.0.2', '7.0.3', '7.1.0', '7.1.1', '7.1.2']
|
||||
|
||||
-def build_docs(version='dev', **kwargs):
|
||||
+def build_docs(sphinx_executable='sphinx-build', version='dev', **kwargs):
|
||||
doc_dir = kwargs.get('doc_dir', os.path.dirname(os.path.realpath(__file__)))
|
||||
work_dir = kwargs.get('work_dir', '.')
|
||||
include_dir = kwargs.get(
|
||||
@@ -50,7 +50,7 @@ def build_docs(version='dev', **kwargs):
|
||||
raise CalledProcessError(p.returncode, cmd)
|
||||
html_dir = os.path.join(work_dir, 'html')
|
||||
main_versions = reversed(versions[-3:])
|
||||
- check_call(['sphinx-build',
|
||||
+ sphinx_build = os.environ.get('SPHINX_EXECUTABLE', 'sphinx-build')
|
||||
+ check_call([sphinx_build,
|
||||
+ check_call([sphinx_executable,
|
||||
'-Dbreathe_projects.format=' + os.path.abspath(doxyxml_dir),
|
||||
'-Dversion=' + version, '-Drelease=' + version,
|
||||
'-Aversion=' + version, '-Aversions=' + ','.join(main_versions),
|
||||
@@ -69,4 +69,4 @@ def build_docs(version='dev', **kwargs):
|
||||
return html_dir
|
||||
|
||||
if __name__ == '__main__':
|
||||
- build_docs(sys.argv[1])
|
||||
+ build_docs(sys.argv[1], sys.argv[2])
|
||||
--
|
||||
2.26.2
|
||||
|
||||
|
@ -1,8 +1,8 @@
|
||||
diff --git a/doc/index.rst b/doc/index.rst
|
||||
index 59dc6652..087795ef 100644
|
||||
index 58f29295..ae14f8e0 100644
|
||||
--- a/doc/index.rst
|
||||
+++ b/doc/index.rst
|
||||
@@ -191,12 +191,3 @@ Ease of Use
|
||||
@@ -189,12 +189,3 @@ Ease of Use
|
||||
just three header files and no external dependencies.
|
||||
A permissive MIT `license <https://github.com/fmtlib/fmt#license>`_ allows
|
||||
using the library both in open-source and commercial projects.
|
||||
|
6
fmt.spec
6
fmt.spec
@ -2,7 +2,7 @@
|
||||
|
||||
%bcond_with doc
|
||||
Name: fmt
|
||||
Version: 7.0.3
|
||||
Version: 7.1.2
|
||||
Release: 1%{?dist}
|
||||
Summary: Small, safe and fast formatting library for C++
|
||||
|
||||
@ -16,7 +16,6 @@ Patch4: doc-_templates-layout-stripped-Google-Analytics.patch
|
||||
Patch5: doc-_templates-layout-stripped-download-links.patch
|
||||
Patch6: doc-index-removed-GitHub-iframe.patch
|
||||
Patch7: doc-build-use-sphinx-build-3.patch
|
||||
Patch8: doc-build-use-python3.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
@ -129,6 +128,9 @@ rm -rf %{_vpath_builddir}/doc/html/{.buildinfo,.doctrees,objects.inv}
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Nov 10 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 7.1.2-1
|
||||
- Updated to version 7.1.2.
|
||||
|
||||
* Sat Aug 08 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 7.0.3-1
|
||||
- Updated to version 7.0.3.
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (7.0.3.tar.gz) = 26afe55255414e27d58c2389fcc8643b64adc04ecc3604f87024e6421706833cbad8ee4caf514dfb7e88da4162ab3e5ff8ff81b83b5f2fb66e9959e4d1bf0f9a
|
||||
SHA512 (7.1.2.tar.gz) = e245a3860df4414ad7ea114d2d5686d0c8ae06fbc45f4af0a232ad4bbf0797e5845d731e307af67aad920d3587e5e424135bffeab09132690edb387c47f4fe15
|
||||
|
Loading…
Reference in New Issue
Block a user